The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

System not backing up?

Discussion in 'Data Protection' started by pski, May 13, 2015.

  1. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    Ill attach a screen shot. I have everything configured correctly i believe.

    Amazon S3 was validated and verified.

    i checked the bucket and no files have been uploaded.. I have another service (Manage WP) and it is able to upload just fine.


    Is there a way for force a backup.. and im NOT talking about legacy backups as I do not use that, since it does not sync into Amazon S3..

    OR do i need to use that and then the other backup system takes ove.... idk im lost..


    advise??
     

    Attached Files:

  2. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    ok i have update..


    after running command: /usr/local/cpanel/bin/backup



    i got this:
    [2015-05-13 17:04:49 +0000] info [backup]
    *********** NOTICE ***********

    You have enabled BACKUPMOUNT in the /var/cpanel/backups/config file, but there is no mount point that matches /backup in the /etc/fstab file.

    Until you resolve this issue, backups will not run. To resolve this issue, you may either:

    1. Disable the "Mount Backup Drive as Needed" option in the "Backup Configuration" feature of WHM. Choose this option if:
    - Your backup partition is always mounted.
    - You do not use a special backup partition or mount to store backups.
    - You have a special case where cPanel should trust that the backup directory is configured properly.

    or

    2. Configure the backup directory mount point /backup in the /etc/fstab file. Choose this option if:
    - You want your backup partition or mount to automatically mount and unmount before and after backups are complete.
    - You have simply forgotten to set up the mount point in the /etc/fstab file.

    Please note that the BACKUPDIR must be the mount point, not a subdirectory of another mount.

    *********** NOTICE ***********


    not sure it thats talking about the legacy or not, im trying to use the backup system to upload to my amazon s3 account.
     
  3. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    Additional Information: i followed these directions: http://tecadmin.net/mount-s3-bucket-centosrhel-ubuntu-using-s3fs/

    and its not going well. having issues at step 4:
    ./configure --prefix=/usr/local


    ####SHELL OUTPUT####
    checking for DEPS... configure: error: Package requirements (fuse >= 2.8.4 libcurl >= 7.0 libxml-2.0 >= 2.6 libcrypto >= 0.9) were not met:

    No package 'fuse' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables DEPS_CFLAGS
    and DEPS_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.
    ######
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    You can force a backup generation via:

    Code:
    /usr/local/cpanel/bin/backup --force
    You are presented with the path to a log file when running this command. Review the log and let us know if you notice any error messages.

    Thank you.
     
  5. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    [2015-05-13 18:08:22 +0000] info [backup]
    *********** NOTICE ***********

    You have enabled BACKUPMOUNT in the /var/cpanel/backups/config file, but there is no mount point that matches /backup in the /etc/fstab file.

    Until you resolve this issue, backups will not run. To resolve this issue, you may either:

    1. Disable the "Mount Backup Drive as Needed" option in the "Backup Configuration" feature of WHM. Choose this option if:
    - Your backup partition is always mounted.
    - You do not use a special backup partition or mount to store backups.
    - You have a special case where cPanel should trust that the backup directory is configured properly.

    or

    2. Configure the backup directory mount point /backup in the /etc/fstab file. Choose this option if:
    - You want your backup partition or mount to automatically mount and unmount before and after backups are complete.
    - You have simply forgotten to set up the mount point in the /etc/fstab file.

    Please note that the BACKUPDIR must be the mount point, not a subdirectory of another mount.

    *********** NOTICE ***********
     
  6. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    im at the point i need to *mount, but not sure how to do that with fstab.. all the instruction assume i already know how to use it
     
  7. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    Ok i have gotton to this point:
    root@server.ecommsrv1.net [s3fs]# df -Th /mnt/s3/ecommsrv1
    Filesystem Type Size Used Avail Use% Mounted on
    s3fs fuse.s3fs 256T 0 256T 0% /mnt/s3/ecommsrv1


    NOW,, its getting this to sync*? with the default backup directory, or i guess declaring this AS the backup directory in cpanel. and i guess fstab (no idea how to use fstab, current attempts are unsucessful)
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    You should simply disable the "Mount Backup Drive as Needed" option in the "Backup Configuration" feature of WHM if you plan to use Amazon S3 for backups.

    Thank you.
     
    pski likes this.
  9. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    I did that. still getting the same error


    [2015-05-13 18:42:42 +0000] info [backup]
    *********** NOTICE ***********

    You have enabled BACKUPMOUNT in the /var/cpanel/backups/config file, but there is no mount point that matches /backup in the /etc/fstab file.

    Until you resolve this issue, backups will not run. To resolve this issue, you may either:

    1. Disable the "Mount Backup Drive as Needed" option in the "Backup Configuration" feature of WHM. Choose this option if:
    - Your backup partition is always mounted.
    - You do not use a special backup partition or mount to store backups.
    - You have a special case where cPanel should trust that the backup directory is configured properly.

    or

    2. Configure the backup directory mount point /backup in the /etc/fstab file. Choose this option if:
    - You want your backup partition or mount to automatically mount and unmount before and after backups are complete.
    - You have simply forgotten to set up the mount point in the /etc/fstab file.

    Please note that the BACKUPDIR must be the mount point, not a subdirectory of another mount.

    *********** NOTICE ***********
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  11. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    Got it..

    for some reason.. /var/cpanel/backups/config file did not update when i changed where the location was.. that and disabling the "Mount Backup Drive as Needed" did the trick.. and its working.. Thanks for all the great support.
     
  12. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    Also to note, i ended up following this tutorial

    idevelopment.info/data/AWS/AWS_Tips/AWS_Management/AWS_20.shtml
     
    #12 pski, May 13, 2015
    Last edited by a moderator: May 15, 2015
  13. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  14. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    Heh,, only half way through, i have 2 servers, lol.. the second one gave me a rather differrent set of errors.. in the log it reads:

    /bin/gtar: Removing leading `/' from member names
    /bin/gtar: Removing leading `/' from member names
    /bin/gtar: Removing leading `/' from member names
    /bin/gtar: Removing leading `/' from member names
    /bin/gtar: Removing leading `/' from member names
    /bin/gtar: Removing leading `/' from member names
    /bin/gtar: Removing leading `/' from member names
    /bin/gtar: Removing leading `/' from member names
    /bin/gtar: Removing leading `/' from member names


    after running command:
    /usr/local/cpanel/bin/backup --force

    this is after doing the install like i did before, and the install went smoothly.
     
  15. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  16. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    Ahh.. Yes it i did.. Sweetness. NOW we will just have to wait and how how the schedule works. :)

    Thanks again
     
  17. pski

    pski Active Member

    Joined:
    Feb 5, 2015
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Anchorage, Alaska
    cPanel Access Level:
    Root Administrator
    Not sure how helpful this would be but just wanted to share:

    Code:
    
    1. Install the following prerequisite packages
        yum -y install gcc
        yum -y install libstdc++-devel
        yum -y install gcc-c++
        yum -y install curl-devel
        yum -y install libxml2-devel
        yum -y install openssl-devel
        yum -y install mailcap
        yum -y install make
        yum -y install svn
    
    2. Download, compile, and install the FUSE (Filesystem in Userspace) module.
        Note: s3fs requires FUSE version 2.8.4 when running CentOS 5. Using a version of FUSE higher than version 2.8.4 on CentOS 5 will result in error when attempting to mount the S3 bucket.
    
       CentOS 6
       yum remove fuse fuse* fuse-devel
       cd /usr/local/src
       wget http://sourceforge.net/projects/fuse/files/fuse-2.X/2.9.1/fuse-2.9.1.tar.gz
       tar -xzvf fuse-2.9.1.tar.gz
       cd fuse-2.9.1
       ./configure --prefix=/usr
       make
       make install
       ldconfig
       export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/lib64/pkgconfig/
       pkg-config --modversion fuse
          Output > 2.9.1*
       ldconfig -v | grep fuse
          Output > libfuse.so.2 -> libfuse.so.2.9.1
    
       CentOS 5 - I have not tested these so I wont list them, I don't want to provide information I don't know works.
    
    3. Manually load the FUSE module for the first time.
       modprobe fuse
    
    4. Download, compile, and install the latest version of s3fs.
       cd /usr/local/src
       svn checkout http://s3fs.googlecode.com/svn/trunk/ s3fs
       cd s3fs
       autoreconf --install
       ./configure --prefix=/usr
       make
       make install
       ldconfig
    
    5. Verify the installation.
       s3fs --version
    
    6. Create an s3fs password file for storing your AWS Access Key ID and Secret Access Key.
    The default location for the s3fs password file can be created:
    [LIST]
    [*]using a .passwd-s3fs file in the users home directory (i.e. ~/.passwd-s3fs)
    [*]using the system-wide /etc/passwd-s3fs file
    [/LIST]
    The s3fs password file has the following format. Use this format if you have only one set of credentials. Specify your AWS Access Key ID and Secret Access Key separated by a colon with no spaces between.
    
       AccessKeyId:SecretAccessKey
    
    I used the following to inport my password:
       echo AccessKeyId:SecretAccessKey > ~/.passwd-s3fs
    
    Following that is:
       touch /root/.passwd-s3fs
       chmod 600 /root/.passwd-s3fs
      
    vi /root/.passwd-s3fs - Used to verify. Use ' esc ' and then  ' :q! ' to quit the editor.
    
    7. Create a directory for mounting the S3 bucket.
       mkdir -p /mnt/s3/foldername
    
    8. Mount the S3 bucket using the correct permissions and any other options.
       s3fs -o allow_other -o use_cache=/tmp bucketname /mnt/s3/foldername
    
    [LIST]
    [*]The -o allow_other option allows all other users on the server read / write access to the mounted directory. Obviously, this can be a huge security hole.
    [*]The -o use_cache=/tmp option specifies the location where to store locally cached folders and files. This enables local file caching which minimizes downloads.
    Note: make certain you have plenty of space dedicated to the cache directory before considering this option. Depending on the size of the files being copied, this directory can fill up very quickly!
    [*]The -o default_acl=public-read-write option will set anything you write to the bucket as publicly viewable and writable (by default, it's set to private).
    [*]The -o default_acl=public-read option will set anything you write to the bucket as publicly viewable (by default, it's set to private).
    [/LIST]
    9. Verify the s3fs mounted file system.
       grep s3fs /etc/mtab
          Output > s3fs /mnt/s3/foldername fuse.s3fs rw,nosuid,nodev,allow_other 0 0
    
      
    df -Th /mnt/s3/examplefolder
          Output >
    Filesystem Type        Size  Used Avail  Use%  Mounted on
    
                         s3fs           fuse.s3fs 256T  0      256T  0%      /mnt/s3/foldername
    
    10. Mount the S3 bucket when the server boots.
    I mounted the bucket manually by editing the /etx/fstab file using filezilla, and adding the following line, aligning my spacing with the other. (not sure if that makes a difference.)
       s3fs#bucketname          /mnt/s3/foldername       fuse    allow_others    0 0
    
    11. Change the backup directory so that it matches the fsab file
    I edited the file manually again using filezilla, but i believe you can do this straight through WHM.
       /var/cpanel/backups/config
    
    ---
    BACKUPACCTS: 'yes'
    BACKUPBWDATA: 'yes'
    BACKUPDAYS: 1,3,5,6
    BACKUPDIR: /mnt/s3/foldername
    BACKUPENABLE: 'yes'
    BACKUPFILES: 'yes'
    BACKUPLOGS: 'yes'
    BACKUPMOUNT: 'yes'
    BACKUPSUSPENDEDACCTS: 'no'
    BACKUPTYPE: compressed
    BACKUP_DAILY_ENABLE: 'yes'
    BACKUP_DAILY_RETENTION: 7
    BACKUP_MONTHLY_DATES: 15
    BACKUP_MONTHLY_ENABLE: 'yes'
    BACKUP_MONTHLY_RETENTION: 2
    BACKUP_WEEKLY_DAY: 0
    BACKUP_WEEKLY_ENABLE: 'yes'
    BACKUP_WEEKLY_RETENTION: 4
    ERRORTHRESHHOLD: 3
    GZIPRSYNCOPTS: --rsyncable
    KEEPLOCAL: 0
    LINKDEST: 0
    LOCALZONESONLY: 'no'
    MAXIMUM_TIMEOUT: 2700
    MYSQLBACKUP: accounts
    POSTBACKUP: 'no'
    PREBACKUP: -1
    PSQLBACKUP: 'no'
    
    Note: Your file may look different then mine, these are just the settings i have.
    
    12: Execute a backup
       /usr/local/cpanel/bin/backup --force
    
    Note: To watch the progress of the backup use the following command. The above command will give you the " LOGFILENUMBER " which will be used in the below command.
       tail -f /usr/local/cpanel/logs/cpbackup/LOGFILENUMBER.log 
    
    
    *If it does not start. try
    13: Disable Mount Backup Drive as Needed
       WHM > BAckup > Backup Configuration > Mount Backup Drive as Needed > Disable
    
    
     
    #17 pski, May 14, 2015
    Last edited by a moderator: May 15, 2015
Loading...

Share This Page