System PHP-FPM Configuration isn't applied to all domains

Operating System & Version
CentOS 7.7
cPanel & WHM Version
86.0.18

GoranG

Registered
Apr 23, 2020
3
0
1
Macedonia
cPanel Access Level
Root Administrator
Hi,

I'm trying to change the Max Children setting for all domains, so I go in MultiPHP Manager, System PHP-FPM Configuration, and I increase the Max Children setting here. Then I click on Save Configuration, and when I check individual domains, I see that some have the new setting, while some still have the default Max Children setting of 5. Am I doing something wrong? Is there an adittional step that needs to be performed?

Thanks
 

kdean

Well-Known Member
Oct 19, 2012
377
65
78
Orlando, FL
cPanel Access Level
Root Administrator
Once a domain has it's own settings in it's .yaml file, the default settings no longer apply. That just applies domains without settings and new domains.

You can likely more quickly review the settings for each here:

/var/cpanel/userdata/<account_username>/<domain_name>.php-fpm.yaml

If you remove the pm_max_children line from these files and rebuild php-fpm they will inherit the default again or you can change the number and rebuild if you don't do the same per domain in WHM.

Rebuilding after changes to these files is:

/scripts/php_fpm_config --rebuild
 

GoranG

Registered
Apr 23, 2020
3
0
1
Macedonia
cPanel Access Level
Root Administrator
Removing the line from the yaml files and rebuilding php-fpm works. I wrote a bash script to quickly do it for all domains, and now they all have the same max_children value.

Thank you.