Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

System Update failing - Requires: libc.so.6

Discussion in 'General Discussion' started by filmotheklown, Sep 1, 2017.

Tags:
  1. filmotheklown

    filmotheklown Member

    Joined:
    Oct 3, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    151
    I'm trying to run:

    Home »Software »System Update


    And get the following error:

    Code:
    System update process has started.
    ---> Package nasm.x86_64 0:2.07-7.el6 will be updated
    ---> Package nasm.x86_64 0:2.13.01-0.fc24 will be an update
    --> Processing Dependency: libc.so.6(GLIBC_2.14)(64bit) for package: nasm-2.13.01-0.fc24.x86_64
    --> Finished Dependency Resolution
    <span class='text-danger'>Error: Package: nasm-2.13.01-0.fc24.x86_64 (nasm)</span>
              [COLOR=#ff0000]Requires: libc.so.6(GLIBC_2.14)[/COLOR](64bit)
     You could try using --skip-broken to work around the problem
    ** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
    proftpd-1.3.5-1.cp1136.x86_64 has missing requires of cpanel-perl-514
    proftpd-1.3.5-1.cp1136.x86_64 has missing requires of cpanel-perl-514
    proftpd-1.3.5-1.cp1136.x86_64 has missing requires of cpanel-perl-514(CDB_File)
    proftpd-1.3.5-1.cp1136.x86_64 has missing requires of cpanel-perl-514(CDB_File)
    proftpd-1.3.5-1.cp1136.x86_64 has missing requires of cpanel-perl-514(Cpanel::Class)
    
    yum exited 256
    
    System update process has finished.
    
    But it seems like I already have libc installed (but it's 2.12):

    Code:
    root@srv05 [~]# yum install glibc-2.12-1.209.el6_9.2.i686
    Loaded plugins: fastestmirror, presto
    Setting up Install Process
    Loading mirror speeds from cached hostfile
     * cpanel-addons-production-feed: 104.219.172.10
     * base: mirror.hmc.edu
     * epel: dl.fedoraproject.org
     * extras: mirror.sjc02.svwh.net
     * rpmforge: mirror.hmc.edu
     * updates: repos.lax.quadranet.com
    Package glibc-2.12-1.209.el6_9.2.i686 already installed and latest version
    Nothing to do
    I tried

    yum update glibc-2.12-1.209.el6_9.2.i686

    But that didn't do anything productive.


    Couple of questions:

    1. Should I just ignore this error and 'skip broken'
      1. If I choose this option what is the command line I should enter to do this?
    2. How do I fix the underlying problem regarding not seeing or finding libc ?
      1. The error seems to request glibc 2.14 and my current cPanel system has 2.12 ??
     
    #1 filmotheklown, Sep 1, 2017
    Last edited by a moderator: Sep 1, 2017
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,165
    Likes Received:
    1,372
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    This error message suggests the NASM RPM you have installed on the system requires glibc version 2.14 or newer. Since CentOS 6 only offers glibc 2.12, updating the NASM RPM fails. It looks like the NASM RPM installed on your system is not the default RPM offered with CentOS 6. You can check which repo you installed it from with the following command:

    Code:
    yum info nasm|grep From
    You'd need to reinstall the NASM RPM from the CentOS 6 base repo to prevent this error message from occurring.

    Thank you.
     
Loading...

Share This Page