system update fails: duplicate package

tinodesigns

Active Member
Jan 24, 2019
36
2
8
Germany
cPanel Access Level
Root Administrator
Hi all,

I noticed that my WHM is non longer updating so I tried the system update manually however I get the following error:
libssh2-1.8.0-3.el7.x86_64 is a duplicate with libssh2-1.4.3-12.el7_6.2.i686

I tried to to run yum makecache and also fully cleared the cache beforehand but my /va/ partition is running out of space.

I also get the following errors:
Protected multilib versions: 4:perl-libs-5.16.3-299.el7_9.x86_64 != 4:perl-libs-5.16.3-294.el7_6.i686
Error: Protected multilib versions: gd-2.0.35-26.el7.i686 != gd-2.0.35-27.el7_9.x86_64
Error: Protected multilib versions: libacl-2.2.51-15.el7.x86_64 != libacl-2.2.51-14.el7.i686
Error: Protected multilib versions: ghostscript-9.25-5.el7.x86_64 != ghostscript-9.07-31.el7_6.11.i686
Error: Protected multilib versions: ea-php74-pear-1.10.12-4.13.26.cpanel.noarch != ea-php74-pear-1.10.7-4.4.6.cpanel.noarch
Error: Protected multilib versions: libmount-2.23.2-65.el7_9.1.x86_64 != libmount-2.23.2-59.el7_6.1.i686
Error: Protected multilib versions: ea-php73-pear-1.10.12-4.13.18.cpanel.noarch != ea-php73-pear-1.10.7-4.7.5.cpanel.noarch
Error: Protected multilib versions: ea-php72-pear-1.10.12-4.13.17.cpanel.noarch != ea-php72-pear-1.10.7-4.7.6.cpanel.noarch
Error: Protected multilib versions: libblkid-2.23.2-59.el7_6.1.i686 != libblkid-2.23.2-65.el7_9.1.x86_64
Error: Protected multilib versions: ea-php56-pear-1.10.12-4.13.20.cpanel.noarch != ea-php56-pear-1.10.7-4.6.6.cpanel.noarch
Error: Protected multilib versions: libuuid-2.23.2-59.el7_6.1.i686 != libuuid-2.23.2-65.el7_9.1.x86_64
Error: Protected multilib versions: 4:perl-devel-5.16.3-295.el7.x86_64 != 4:perl-devel-5.16.3-294.el7_6.i686

Can anyone tell me how to resolve this?

Trying to update WHM and cpanel to the latest version. Current version is: v100.0.12

Thanks
Tino
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,481
1,966
363
cPanel Access Level
Root Administrator
Hey there! It looks like somehow your system has both 64-bit and 32-bit packages installed for the same software. Your server is likely 64-bit but you should confirm that with this command:

Code:
uname -i
That will likely show "x86_64" as the output, indicating you are on a 64-bit operating system. If so, you can manually remove the packages that end in .i686 from the system and that will likely take care of the issue.
 

tinodesigns

Active Member
Jan 24, 2019
36
2
8
Germany
cPanel Access Level
Root Administrator
I just removed the duplicate libssh2 and tried system update again. Now I get this error:

libssh2-devel-1.4.3-12.el7_6.2.x86_64 has missing requires of libssh2 = ('0', '1.4.3', '12.el7_6.2')

Any solution?

thanks
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,481
1,966
363
cPanel Access Level
Root Administrator
It would be best to work with your hosting provider for further issues on this. Some of these packages, like libssh and perl-libs could cause issues for the server if not handled properly. I'm hesitant to provide further instruction over the forums without knowing for sure the state of the system and if there are deeper, underlying causes for these problems.
 

tinodesigns

Active Member
Jan 24, 2019
36
2
8
Germany
cPanel Access Level
Root Administrator
Well they just basically told me the same thing. Get rid of i686 and if it doesn't work that I might watn to contact cPanel support :D

I just replied and pointed out the new error about some requiry missing:
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
libssh2-devel-1.4.3-12.el7_6.2.x86_64 has missing requires of libssh2 = ('0', '1.4.3', '12.el7_6.2')

Let's see what they say.

If you have any idea let me know.

Thanks
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,481
1,966
363
cPanel Access Level
Root Administrator
It seems odd to me that the host would say to contact cPanel, as that specific package in your example is controlled by the operating system itself, so we don't modify or distribute that in any way.

What happens if you use the WHM >> Rebuild RPM Databases tool?
 

tinodesigns

Active Member
Jan 24, 2019
36
2
8
Germany
cPanel Access Level
Root Administrator
I also just tried yum update --skip-broken

that gives me this:
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for perl-libs which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of perl-libs of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude perl-libs.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of perl-libs installed, but
yum can only see an upgrade for one of those architectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of perl-libs installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: 4:perl-libs-5.16.3-299.el7_9.x86_64 != 4:perl-libs-5.16.3-294.el7_6.i686
Error: Protected multilib versions: gd-2.0.35-26.el7.i686 != gd-2.0.35-27.el7_9.x86_64
Error: Protected multilib versions: libacl-2.2.51-15.el7.x86_64 != libacl-2.2.51-14.el7.i686
Error: Protected multilib versions: ghostscript-9.25-5.el7.x86_64 != ghostscript-9.07-31.el7_6.11.i686
Error: Protected multilib versions: ea-php74-pear-1.10.12-4.13.26.cpanel.noarch != ea-php74-pear-1.10.7-4.4.6.cpanel.noarch
Error: Protected multilib versions: libmount-2.23.2-65.el7_9.1.x86_64 != libmount-2.23.2-59.el7_6.1.i686
Error: Protected multilib versions: ea-php73-pear-1.10.12-4.13.18.cpanel.noarch != ea-php73-pear-1.10.7-4.7.5.cpanel.noarch
Error: Protected multilib versions: ea-php72-pear-1.10.12-4.13.17.cpanel.noarch != ea-php72-pear-1.10.7-4.7.6.cpanel.noarch
Error: Protected multilib versions: libblkid-2.23.2-59.el7_6.1.i686 != libblkid-2.23.2-65.el7_9.1.x86_64
Error: Protected multilib versions: ea-php56-pear-1.10.12-4.13.20.cpanel.noarch != ea-php56-pear-1.10.7-4.6.6.cpanel.noarch
Error: Protected multilib versions: libuuid-2.23.2-59.el7_6.1.i686 != libuuid-2.23.2-65.el7_9.1.x86_64
Error: Protected multilib versions: 4:perl-devel-5.16.3-295.el7.x86_64 != 4:perl-devel-5.16.3-294.el7_6.i686

--

Trying to remove those i686 versions BTW doesn't get any result. It is not possible to remove them. I get thise error for each:
error: package 4:perl-devel-5.16.3-294.el7_6.i686 is not installed
 

tinodesigns

Active Member
Jan 24, 2019
36
2
8
Germany
cPanel Access Level
Root Administrator
It seems odd to me that the host would say to contact cPanel, as that specific package in your example is controlled by the operating system itself, so we don't modify or distribute that in any way.

What happens if you use the WHM >> Rebuild RPM Databases tool?
I just did that running yum update now.

Do you need the rebuild RPM output? It's quite a lot.
 

tinodesigns

Active Member
Jan 24, 2019
36
2
8
Germany
cPanel Access Level
Root Administrator
Ok everything seems to be fine now. System Update went through fine now. Thanks for the help.

I'll try the regular WHM update to the latest version sometime next week.

Again thanks a lot. the RPM database rebuild tool seemed to have done the trick.