The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tamaño Upload

Discussion in 'Discusión en Español' started by migarcia, Jun 20, 2014.

  1. migarcia

    migarcia Well-Known Member

    Joined:
    Nov 16, 2012
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Barcelona
    cPanel Access Level:
    Website Owner
    Tengo un servidor con una treintena de clientes, y me aparece la necesidad de modificar el "upload_max_filesize", mientras buscaba una solucion, intente modificar ese valor para todos en CPanel->Tweak Settings->PHP y me he encontrado que aqui me indica tamaño maximo 50Mb, pero en cambio en phpinfo() me indica tamaño maximo 10 Mb...Me podeis ayudar? COn modificarlo para uno solo seria lo mejor, pero si no se puede, como modificarlo a todos...


    PHP5 Handler fcgi
    suExec ON

    Nota: He encontrado en CPanel->Service Configuration->PHP Configuration editor la posibilidad de cambiar el "upload_max_file_size" para todos, entonces no entiendo para que esta en Tweak,
     
  2. jortiz565

    jortiz565 Active Member

    Joined:
    Oct 31, 2012
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Hola,

    En whm>>Service Configuration>>PHP Configuration
    Usted podra cambiar el php upload max size para todos sus clientes. Es la forma correcta de hacerlo.

    Si desea hacerlo para un usuario especifico entonces debera crear un php.ini para dicho usuario y cambiar el valor. Tenga en cuenta que si usted cambia algun otro valor,este usuario al tener su php.ini no recibira el cambio.
     
  3. jortiz565

    jortiz565 Active Member

    Joined:
    Oct 31, 2012
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Olvide mencionar que si deseas crear el php personalizado entonces deberás hacer lo siguiente:

    En root via ssh
    cp -pv /usr/local/lib/php.ini /home/USUARIO/public_html/php.ini
    chown -v USUARIO:USUARIO /home/USUARIO/public_html/php.ini

    En el .htaccess del usuario debes añadir esta lina
    suPHP_ConfigPath /home/USUARIO/public_html

    Debes reemplazar USUARIO por el usuario de cpanel.

    Espero mi respuesta te sea útil.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Check to see if there is an individual php.ini file within the account that is overwriting the global value that you configured. That could explain while the option you modified is not enacted.

    Thank you.

    Translation:

    Hola :)

    Revise para ver si hay un archivo php.ini individual dentro de la cuenta que se sobrescribe el valor global que se ha configurado. Eso podría explicar, mientras que la opción que ha modificado no es aprobada.

    Gracias.
     
  5. migarcia

    migarcia Well-Known Member

    Joined:
    Nov 16, 2012
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Barcelona
    cPanel Access Level:
    Website Owner
    Gracias, de momento dejare cambiado el de todos los clientes.
    Por curiosidad me puede indicar para que sirve CPanel->Tweak Settings->PHP, ya que cuando se cambia el tamaño ahi, no sirve para nada
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Would you be able to clarify your last message? I'm not sure I understand if the issue persists.

    Thank you.

    Translation:

    ¿Sería usted capaz de aclarar su último mensaje? No estoy seguro de entender si el problema persiste.

    Gracias.
     

Share This Page