The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Temp Link Disabled?

Discussion in 'General Discussion' started by Humdizzle, Jul 13, 2004.

  1. Humdizzle

    Humdizzle Registered

    Joined:
    Jul 13, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My host told me temp links are now disabled by cpanel standardly. How do I enable it.When I try to send someone their temp link it doesnt work. Like this http://67.18.184.218/~jinohost It doesn't go to the site.
     
  2. Logger

    Logger Member

    Joined:
    Feb 23, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Yep, same issue here. I looked through the WHM options and there is no option to toggle this feature on and off...
     
  3. Humdizzle

    Humdizzle Registered

    Joined:
    Jul 13, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I wish this were eaisier. I need this to work or all chaos will erupt.
     
  4. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    Check your httpd.conf file to see if it contains something like

    <IfModule mod_userdir.c>
    UserDir disabled
    UserDir enabled username
    UserDir public_html
    </IfModule>

    If so, just remove it and restart apache. A backup copy should always be made when editing that file though because an error in it won't let apache restart.

    There are other ways to disable it, but that's the first one I'd check.
     
  5. Humdizzle

    Humdizzle Registered

    Joined:
    Jul 13, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I'm kind of new at owning my own server, but how do you do that?
    I know a very little because before I bought the server I had a reseller.
     
    #5 Humdizzle, Jul 13, 2004
    Last edited: Jul 13, 2004
  6. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    That file is usually at /usr/local/apache/conf/httpd.conf and can only be accessed as root. You can either use a shell program or an ftp program that offers secure connections. The programs I use are at vandyke.com.
     
  7. Logger

    Logger Member

    Joined:
    Feb 23, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Yah, but I want it enabled. :)

    I have the mod_userdir directives in httpd.conf:
    Code:
    <IfModule mod_userdir.c>
    UserDir disabled
    UserDir enabled nobody
    </IfModule>
    
    What edits to that will enable it? I tried various things but nothing worked....
     
  8. Logger

    Logger Member

    Joined:
    Feb 23, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I unchecked "DefaultHost (nobody)" and saved it and it works. :)
     
Loading...

Share This Page