The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Template Error: The template file must be given.

Discussion in 'General Discussion' started by techclan, Apr 14, 2011.

  1. techclan

    techclan Member

    Joined:
    Aug 15, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    After update to WHM 11.28.87 I get "Template Error: The template file must be given" when add new domains or park them.
    Everything seems to complete ok but going to the domain forwards to /cgi-sys/defaultwebpage.cgi with that error.

    I Tried Apache Update
    I Tried Force Cpanel Update
    I Tried Rebuilding Apache Configuration
    Same Issue.

    Any help is appreciated.
     
    #1 techclan, Apr 14, 2011
    Last edited by a moderator: Apr 14, 2011
  2. techclan

    techclan Member

    Joined:
    Aug 15, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Issue resolved by performing below via ssh:
    cd /usr/bin
    mv perl perl-backup
    ln -s /usr/local/bin/perl perl
     
  3. Chris.Bshm

    Chris.Bshm Member

    Joined:
    Oct 20, 2011
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Before running these commands, you must make sure there is not already a symlink between the two files as you may symlink a symlink.

    You can run `ll /usr/bin/perl /usr/local/bin/perl` to check prior to running anything - if you have any questions please open a support ticket before moving the Perl binaries around.
     
  4. katz_global

    katz_global Well-Known Member
    PartnerNOC

    Joined:
    Oct 18, 2003
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hosting from: Panama, Hong Kong, Singapore, Malays
    I did find an easy fix for this. Under: Main >> Account Functions >> Web Template Editor

    All you need to do is press the revert to default template button below where the html goes. The perl fix above only caused more issues for me, which cpanel has had to help with.
     
    #4 katz_global, Aug 1, 2012
    Last edited: Aug 1, 2012
Loading...

Share This Page