The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

terminatereseller doesn't work?

Discussion in 'cPanel Developers' started by sparek-3, Jul 7, 2015.

  1. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,381
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    The terminatereseller API call doesn't appear to work:

    Code:
    /json-api/terminatereseller?api.version=1&reseller=reselleruser&terminatereseller=1
    returns

    Code:
    [reason] => _unsetupreseller requires a user to unsetup
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Your call is incorrect. You need to specify 'user' not 'reseller'. Hence:

    Code:
    /json-api/terminatereseller?api.version=1&user=reselleruser&terminatereseller=1
    
    The documentation on this is incorrect. I'll file a case to get it fixed.
     
  3. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,381
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Indeed, when using user instead of reseller this works. I was just going by what was in the documentation.

    Thanks
     
Loading...
Similar Threads - terminatereseller doesn't
  1. Scruff
    Replies:
    4
    Views:
    393
  2. mtorromeo
    Replies:
    5
    Views:
    463

Share This Page