The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Test" failing in User Level Filtering for me and my hosting co

Discussion in 'E-mail Discussions' started by MrArtist, Jun 9, 2014.

  1. MrArtist

    MrArtist Member

    Joined:
    Jun 9, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hi

    I'm having a problem with using the "Test" facility under User Level Filtering (for an addon domain).

    No matter what I try, when I use the Test button after setting up a filter, all I seem to get is the following:

    (NB, substitutions made for real domain/server names etc)

    >>>> 220-server1.xyz.hostingco.net ESMTP #3 Mon, 09 Jun 2014 10:54:21 -0500
    >>>> 220-We do not authorize the use of this system to transport unsolicited,
    >>>> 220 and/or bulk e-mail.
    <<<< HELO server1.xyz.hostingco.net
    >>>> 250 server1.xyz.hostingco.net Hello localhost [127.0.0.1]
    <<<< MAIL FROM: myXYZaccount@server1.xyz.hostingco.net
    >>>> 250 OK
    <<<< RCPT TO: /home/myXYZaccount/etc/mydomain1.com/user1/filter
    >>>> 501 /home/myXYZaccount/etc/mydomain1.com/user1/filter: recipient address must contain a domain
    /usr/sbin/sendmail: unexpected response 501 to RCPT TO command
    <<<< DATA
    >>>> 503-All RCPT commands were rejected with this error:
    >>>> 503-501 /home/myXYZaccount/etc/mydomain1.com/user1/filter: recipient address must contain a domain
    >>>> 503 valid RCPT command must precede DATA
    /usr/sbin/sendmail: unexpected response 503 to DATA command

    -------------

    The actual filter seems to work in real life, it's just the test that doesn't!

    I have copied a full text version of one of the emails that does forward (including the headers) which does obviously contain the search phrase, but still no joy.

    I have tried various To/From contains/is variants but it seems the feature is broken. My well known hosting supplier have tested it at various terminals at their end and get the same failure and say it's a cPanel problem but I can't find anything recent mentions about similar issues, just stuff from about 2008.

    The exact filter format I'm currently using is:
    (it works in real life but not in cPanel test mode)

    "Any Header" "Contains" "user1@domain1.com"
    Redirect to "user1@domain2.com"

    Is this a problem anyone else is getting at the moment? Is it working for you? Is my hosting company correct in saying it's nothing to do with them?

    Just a thought, could this have anything to do with removing addon domain subdomain references in Advanced DNS Zone Editor that I also used a different naming structure on when creating the addon domains?

    Many thanks in advance for any suggestions.
     
  2. MrArtist

    MrArtist Member

    Joined:
    Jun 9, 2014
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Just a quick note that my hosting company tested this problem with their own email address and that the problem is not related to addon domains and the renaming of them.
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    I attempted to reproduce this issue but the filter test succeeded. Could you have your hosting provider open a support ticket with us so we can attempt to reproduce the issue and open an internal case if necessary? Please post the ticket number here so we can follow-up and update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page