Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

test.fcgi file is not working

Discussion in 'General Discussion' started by its_joe, Apr 8, 2007.

  1. its_joe

    its_joe Well-Known Member

    Joined:
    Feb 15, 2007
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    166
    Hello,

    I have uploaded one file test.fcgi and it's coding is as follows;

    =================================
    #!/usr/bin/perl
    use FCGI;
    $cnt = 0;
    while (FCGI::accept() >= 0)
    {
    print ("Content-type: text/html\r\n\r\n");
    print ("<head>\n<title>FastCGI Demo Page (perl)</title>\n</head>\n");
    print ("<h1>FastCGI Demo Page (perl)</h1>\n");
    print ("This is coming from a FastCGI server.\n<BR>\n");
    print ("Running on <EM>$ENV{USER}</EM> to <EM>$ENV{REMOTE_HOST}</EM>\n<BR>\n");
    $cnt++;
    print ("This is connection number $cnt\n");
    }
    =================================
    this file is in /home/abc/public_html/cgi-bin of the website. The permission and ownership of the file is correct . But when i try to browse this file from the web-browser it don't work.

    Please suggest a solution for this.

    its_joe
     
  2. its_joe

    its_joe Well-Known Member

    Joined:
    Feb 15, 2007
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    166
    Hello ??? anyone ????
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice