Text/code Editor Character Type issues

Jinovich

Member
Mar 16, 2008
16
0
51
First of all I am aware this isn't a support forum, but I like communities and the diversity of answers so here we go.

At the moment, when editing files using the cpanel text or code editor I get the following message:

We have attempted to auto-detect the encoding of this file. However, this is not a foolproof process since some files will display properly with multiple different encodings. You should select the encoding that this file was originally created with. It is very important that you select the proper encoding; saving your file with the wrong encoding may result in the corruption of your text. If you are only using a Western European language like English, Spanish or French without any special characters you can safely assume "ISO-8859-1" will work just fine. If you are using a non-western language or you have special characters that are not HTML encoded in your file, you should enter "utf-8". If your file appears with text like this: or You may have selected the incorrect encoding. If this happens, you should immediately abort the edit and select the correct encoding. You should not save the file; this will likely corrupt the text permanently.
This is not on one server but several independent servers from different hosts, I also came across this when helping a friend with their site.

Is there a resolution to this?

Is this a bug in the latest build?

Anyway of bypassing or disabling this prompt?

I am using:
WHM 11.15.0 cPanel 11.18.2-S21594
CENTOS Enterprise 4.6 i686 on standard - WHM X v3.1.0
Thanks a lot,

Jin


EDIT: Appears to be affecting several users, guess we are going to have to stick it out and wait for an update.
 
Last edited:

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
First of all I am aware this isn't a support forum, but I like communities and the diversity of answers so here we go.

At the moment, when editing files using the cpanel text or code editor I get the following message:



This is not on one server but several independent servers from different hosts, I also came across this when helping a friend with their site.

Is there a resolution to this?

Is this a bug in the latest build?

Anyway of bypassing or disabling this prompt?

I am using:


Thanks a lot,

Jin


EDIT: Appears to be affecting several users, guess we are going to have to stick it out and wait for an update.
It's a 'feature.' It can be disabled in the next build(s).
 

anton_latvia

Well-Known Member
PartnerNOC
May 11, 2004
410
17
168
Latvia
cPanel Access Level
Root Administrator
When using Firefox it does not allow to choose any other encoding than US-ASCII, drop down box is not being opened and "up-down" arrows do not work. In IE6 everything is working fine. Latest CURRENT.
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
When using Firefox it does not allow to choose any other encoding than US-ASCII, drop down box is not being opened and "up-down" arrows do not work. In IE6 everything is working fine. Latest CURRENT.
It's working fine for me using 11.23.1-C24785