Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The “Apache PHP-FPM” service is down

Discussion in 'EasyApache' started by wkt, Apr 20, 2017.

Tags:
  1. wkt

    wkt Registered

    Joined:
    Apr 20, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ukraine
    cPanel Access Level:
    Root Administrator
    Hello,

    First of all I would like to mention that I have already got acquainted with the following threads concerning this issue, however none of these seemed to solve the issue completely:
    Monitor Service - PHP-FPM service for Apache
    SOLVED - Chkservd showing apache_php_fpm down

    I have recently installed cPanel/WHM 64.0 on 2 CentOS 7 servers and LFD keeps sending email alerts about the "apache_php_fpm" service being down:

    Code:
    # /scripts/restartsrv_apache_php_fpm --check
    (XID b9gv98) The “Apache PHP-FPM” service is down.
    I have followed the steps in both threads above and tried deleting "www.conf" files one by one, but "apache_php_fpm" passed the check only after all "www.conf" files had been deleted:

    Code:
    # rm /opt/cpanel/ea-php54/root/etc/php-fpm.d/www.conf
    # rm /opt/cpanel/ea-php55/root/etc/php-fpm.d/www.conf
    # rm /opt/cpanel/ea-php56/root/etc/php-fpm.d/www.conf
    # rm /opt/cpanel/ea-php70/root/etc/php-fpm.d/www.conf
    # rm /opt/cpanel/ea-php71/root/etc/php-fpm.d/www.conf
    Then I executed the following commands:

    Code:
    # /scripts/restartsrv_apache_php_fpm --check
    The 'apache_php_fpm' service passed the check.
    Code:
    # /scripts/restartsrv_apache_php_fpm
    Service Status
    
    apache_php_fpm restarted successfully.
    Looks good and first I thought that this had resolved the issue, however when I rebooted the server, it appeared that all "ea-php{XX}-php-fpm.service" services were down (though the "apache_php_fpm" service was active); here is the output for "ea-php54-php-fpm.service" status:

    Code:
    # systemctl status ea-php54-php-fpm.service
    ● ea-php54-php-fpm.service - The PHP FastCGI Process Manager
       Loaded: loaded (/usr/lib/systemd/system/ea-php54-php-fpm.service; enabled; vendor preset: disabled)
       Active: failed (Result: exit-code) since Thu 2017-04-20 15:43:59 CEST; 21min ago
      Process: 3009 ExecStart=/opt/cpanel/ea-php54/root/usr/sbin/php-fpm --nodaemonize (code=exited, status=78)
     Main PID: 3009 (code=exited, status=78)
    
    Apr 20 15:43:59 server1.blackmesafacility.com systemd[1]: Starting The PHP FastCGI Process Manager...
    Apr 20 15:43:59 server1.blackmesafacility.com php-fpm[3009]: [20-Apr-2017 15:43:59] WARNING: Nothing matches the include pattern '/opt/cpanel/ea-php54/root/etc/php-fpm.d/*.conf' from /opt/cpanel/ea-php54/root/etc/php-fpm.conf at line 11.
    Apr 20 15:43:59 server1.example.com php-fpm[3009]: [20-Apr-2017 15:43:59] ERROR: No pool defined. at least one pool section must be specified in config file
    Apr 20 15:43:59 server1.example.com php-fpm[3009]: [20-Apr-2017 15:43:59] ERROR: failed to post process the configuration
    Apr 20 15:43:59 server1.example.com php-fpm[3009]: [20-Apr-2017 15:43:59] ERROR: FPM initialization failed
    Apr 20 15:43:59 server1.example.com systemd[1]: ea-php54-php-fpm.service: main process exited, code=exited, status=78/n/a
    Apr 20 15:43:59 server1.example.com systemd[1]: Failed to start The PHP FastCGI Process Manager.
    Apr 20 15:43:59 server1.example.com systemd[1]: Unit ea-php54-php-fpm.service entered failed state.
    Apr 20 15:43:59 server1.example.com systemd[1]: ea-php54-php-fpm.service failed.
    Hint: Some lines were ellipsized, use -l to show in full.
    So, my understanding is that the "ea-php{XX}-php-fpm.service" services simply need at least one *.conf file in the /opt/cpanel/ea-php{XX}/root/etc/php-fpm.d/ directory, so when I create one, I will be able to start "ea-php{XX}-php-fpm.service". Please correct me if I am wrong.

    Still, I would like to know what exactly is wrong with those www.conf files. I do not want to run into troubles when I start to create config files for real users with active sites.

    Thank you in advance for your assistance!
     
    #1 wkt, Apr 20, 2017
    Last edited by a moderator: Apr 20, 2017
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,659
    Likes Received:
    1,428
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    That's a normal output from the "systemctl status ea-php54-php-fpm.service" command when no accounts on PHP 5.4 have PHP-FPM enabled. The service is only active when at least one account on that PHP version is using PHP-FPM.

    The use of the "www.conf" file was part of an unsupported method of enabling PHP-FPM (before it was officially supported in the product). Did you enable or configure PHP-FPM using a method other than the options available in the product?

    Thank you.
     

Share This Page