Endre Ottem

Registered
Jan 17, 2009
4
1
51
I have multiple servers (including one that I installed as late as week ago, with nothing on it except CSF and Softaculous).

Yesterday I had no problems with the servers, but today I get an error message saying "The API request failed with the following error: 200 - OK." when I try to do things like:
- Edit a feature in "Feature Manager"
- Open "Manage API Tokens"
- Open cPanel for one of the accounts

This happens on ALL my servers. They're not connected in any way, other than that they are all configured in WHMCS. The servers are located in different places (most of them are in my own datacenter here in Norway, one stands in my office, three are installed at Hetzner in Germany).

Other things seem to work fine (I haven't tested everything of course), but when I try to open "Update Preferences" or open "cPHulk Brute Force Protection", the page hangs (also on all servers).

The only thing I can think of as a source of the problem is WHMCS. Found out a couple of days ago that WHMCS had "Application Links" enabled. I don't want to WHMCS to interfere with my servers more than absolutely necessary, so I disabled it.

I have tried forcing a cPanel update to no avail. I have of course also tried rebooting (some of) the servers.
 

Endre Ottem

Registered
Jan 17, 2009
4
1
51
EDIT: Please disregard this post. Found it worked when I tried from another PC. Turned out to be caused by a browser plugin used to disable CORS (that I need as a developer when I work with a local webserver and fetches data from public servers).

I tried to edit my original post, but was denied as the forum software believes the text in the previous paragraph looked too much like spam. Go figure... :)
 
  • Like
Reactions: cPanelMichael

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,216
463
Hello @Endre Ottem,

I'm glad to see you were able to solve the issue. Thanks for updating us with the outcome.
 

sarhosting

Well-Known Member
Oct 1, 2007
170
2
68
United States
cPanel Access Level
Root Administrator
Twitter
If you are using uBlock Origin Extra, you will have the issue as well.
Thanks to @Endre Ottem for pointing out a browser extension was the cause.
Confirmed by switching over to Safari (which had no plugins) and Chrome Incognito.
So far, uBlock Origin itself causes no issue so if you have that installed, it's okay to leave it.
 

Attachments