The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The backup process on "myserver" encountered an error.

Discussion in 'Data Protection' started by ladydi711, Oct 15, 2015.

  1. ladydi711

    ladydi711 Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    120
    Likes Received:
    3
    Trophy Points:
    18
    I received an error on my backups for the first time overnight.


    The backup process completed, but 19 errors occurred.

    18 of my accounts received:
    “/usr/local/cpanel/bin/pkgacct” reported error code “2” when it ended.

    One error is:
    Failed to compress file “/mnt/backup/2015-10-15/system/files/_etc_shadow”.

    Another in the body of the email notice:
    [2015-10-15 05:55:10 -0500] warn [backup] No such application: pigz at /usr/local/cpanel/Cpanel/Backup/Utility.pm line 125.

    Backups have been working fine prior to this. Has anyone seen these or know what problem they indicate?
     
    #1 ladydi711, Oct 15, 2015
    Last edited by a moderator: Oct 16, 2015
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    It's important to let us know the version numbers for cPanel and your OS when reporting this type of issue, per the instructions at:

    Guide To Opening An Effective Forums Thread

    Are you using cPanel version 11.52 on a CentOS 5 system? If so, please run "/scripts/upcp --force" to ensure 11.52.0.15 is installed. It includes the following resolution for backup failures:

    Fixed case CPANEL-1961: Update cpanel-perl-514-Archive-Tar-Builder to 2.0000-7.cp1146.

    Thank you.
     
  3. ladydi711

    ladydi711 Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    120
    Likes Received:
    3
    Trophy Points:
    18
    Thanks. cPanel also updated to 11.52.0.15 overnight, so perhaps there was some overlap. I will see how the backup goes overnight and will reply with more detail if there is still an issue. THANKS!
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You can also force a backup generation at anytime via:

    Code:
    /usr/local/cpanel/bin/backup --force
    Thank you.
     
  5. ladydi711

    ladydi711 Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    120
    Likes Received:
    3
    Trophy Points:
    18
    I am still facing this issue; the update to 11.52.0.15 is complete, but each scheduled backup is still reporting these errors.
     
  6. filoucp

    filoucp Member

    Joined:
    Aug 28, 2005
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    I've got a similar error since the 11.52 update. ( got 11.52.0.15 on CentOS 6.7 )

    “/usr/local/cpanel/bin/pkgacct” reported error code “2” when it ended.

    [2015-10-19 04:10:21 +0200] warn [backup] “/usr/local/cpanel/bin/pkgacct” reported error code “2” when it ended. at /usr/local/cpanel/Cpanel/Backup/Utility.pm line 216.

    It was working ok before the update.
     
  7. DemetriD

    DemetriD Registered

    Joined:
    Apr 1, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    And similarly with our VPS running 11.52.0.15:

    Failed to compress file “/backups/2015-10-20/system/files/_etc_shadow”.

    “/usr/local/cpanel/3rdparty/bin/pigz” reported error code “13” when it ended.

    and in the log:
    [2015-10-20 02:37:39 +0100] warn [backup] No such application: pigz at /usr/local/cpanel/Cpanel/Backup/Utility.pm line 125.
     
  8. ladydi711

    ladydi711 Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    120
    Likes Received:
    3
    Trophy Points:
    18
    I've opened a ticket with cPanel, and at this point they are thinking it has to do with my /backup being on a NAS device. I have another ticket open with my hosting provider to inquire about that.

    What types of devices are you backing up to?

    Also, while I thought it started after the update to 11.52.0.15, cPanel points out they have been failing prior to that, but I only just started receiving the errors :\

    For the _etc_shadow error, they indicated that the file could not be manipulated. However, since I am not the only one getting this, I find that odd as well....

    I look forward to any feed back on this discussion!
     
  9. Stewart Adam

    Stewart Adam Registered

    Joined:
    Sep 24, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    We're seeing the same error (no such application pigz) in our backup logs as well. Our backup is also on a NAS (mounted using sshfs).

    There's also this line about /etc/shadow:

    Code:
    pigz: abort: read error on /backup_streaming/2015-10-26/system/files/_etc_shadow (Permission denied)

    We're seeing this on the backups for all 3 servers we have configured with backups to NAS, WHM 11.52.0 (build 18) on CentOS 7 X86_64.
     
  10. ladydi711

    ladydi711 Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    120
    Likes Received:
    3
    Trophy Points:
    18
    Do you also get the following on any of your accounts?:
    “/usr/local/cpanel/bin/pkgacct” reported error code “2” when it ended.

    I have not had much luck getting my host and NAS provider to respond with any info. It seems this is more common that just my particular NAS configuration.
     
  11. Stewart Adam

    Stewart Adam Registered

    Joined:
    Sep 24, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    I don't get that message, only the following one:
    The issue with system/files/_etc_shadow is due to the fact that the file seems to get created with no read permissions, so it can't be read for compression.
     
  12. ladydi711

    ladydi711 Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    120
    Likes Received:
    3
    Trophy Points:
    18
    “/usr/local/cpanel/bin/pkgacct” reported error code “2” when it ended.
    Do you know how your NAS is mounted? cPanel support believes my issue is related to the NAS being mounted as cifs and has me looking into the locking mechanism being used.
     
  13. filoucp

    filoucp Member

    Joined:
    Aug 28, 2005
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    I've got the same error since i updated to WHM 11.52. I backup to a cifs mounted NAS.
    Do i need to open a support ticket for that ?
     
  14. Stewart Adam

    Stewart Adam Registered

    Joined:
    Sep 24, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Canada
    cPanel Access Level:
    Root Administrator
    Mine is mounted using FUSE's sshfs.
     
  15. ladydi711

    ladydi711 Well-Known Member

    Joined:
    Sep 4, 2001
    Messages:
    120
    Likes Received:
    3
    Trophy Points:
    18
    I have tickets open with both my host/NAS provider and cPanel. Action item is on my NAS provider at this point. When I get any feedback I will share.

    I have used this NAS for almost 2 years without issue until now.
     
  16. therealbenhogan

    therealbenhogan Registered

    Joined:
    Oct 30, 2015
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Root Administrator
    Hi,

    I am having the same issue on 2 servers. I have root access to both. Here are the system details for them:

    /etc/redhat-release:CentOS release 6.7 (Final)
    /usr/local/cpanel/version:11.52.0.20
    /var/cpanel/envtype:standard

    and for the second:

    /etc/redhat-release:CentOS release 6.7 (Final)
    /usr/local/cpanel/version:11.52.0.20
    /var/cpanel/envtype:kvm

    Many thanks!
     
  17. filoucp

    filoucp Member

    Joined:
    Aug 28, 2005
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    Same here. Hope to get updates soon.
     
  18. Andrzej Nawrot

    Andrzej Nawrot Registered

    Joined:
    Sep 29, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Poznan, Poland, Poland
    cPanel Access Level:
    Root Administrator
    I have the same problem. NAS is NFS mounted.

    Failed to compress file “/backup/2015-11-01/system/files/_etc_shadow”.
    “/usr/local/cpanel/3rdparty/bin/pigz” reported error code “13” when it ended.

    CENTOS 7.1 x86_64 kvm – fenix

    WHM 11.52.0 (build 20
     
    #18 Andrzej Nawrot, Nov 2, 2015
    Last edited by a moderator: Nov 2, 2015
  19. filoucp

    filoucp Member

    Joined:
    Aug 28, 2005
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    I opened a ticket for this and Cpanel told me that this is a NAS problem and this is not due to the backup script. It seems that all of our hosting providers made a change on the same day of the 11.52 update :(
     
  20. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The best way to determine if there's an issue with your NAS mount is to try manually moving a file or using rsync to move a file to the mount from the primary filesystem. EX:

    Code:
    mv /root/test.file /mnt/nasbackup/
    Ensure the test file is at least 100MB when testing.

    Thank you.
     
Loading...

Share This Page