The desired locale has been saved to your browser

arjanvr

Well-Known Member
Dec 13, 2013
113
1
18
cPanel Access Level
Root Administrator
A client who has trouble with his webmail sees this message.

"The desired locale has been saved to your browser.
To change the locale in this browser again, select another locale on this screen." Could this be related? I found this but it does not make sense. When I login I don't see the message and he cannot login and does with Windows mobile 10 and edge browser. Client has left us but it would be good to know if this was the cause or unrelated for future reference
How to change the locale of the cPanel interface
You can choose a new language setting (locale) in which to view the cPanel interface. This change sets a cookie in your browser that will expire after one year. You will need to perform this step each time that you log in to webmail from a new browser, whenever you delete cookies, and after the cookie expires.

To change the cPanel interface's locale, perform the following steps:

At the bottom of the cPanel login interface, click the desired locale name.
The interface will refresh and the following message will appear:

The desired locale has been saved to your browser.
To change the locale in this browser again, select another locale on this screen.
Finish the login process as described above."


Important:

The locale that you select from the cPanel login interface will not change the associated cPanel account's default locale. If you wish to change your account's default locale, use theChange Language interface (Home >> Preferences >> Change Language).
 
Last edited by a moderator:

arjanvr

Well-Known Member
Dec 13, 2013
113
1
18
cPanel Access Level
Root Administrator
That a (ex)client gets that message when logging into webmail and is unable to login. While other people can login and don't get that message. I don't quit understand what is causing this? And to prevent this for future clients we need to know..
 

sarhosting

Well-Known Member
Oct 1, 2007
172
2
68
United States
cPanel Access Level
Root Administrator
Twitter
It usually mean "?locale=en" is appended to end of the URL. Delete it or use the "More locals" link.
We're not using Windows 10 as yet since it is not compatible with our McAfee Enterprise version so I can't test to see if Edge would have a issue login in.
 

Attachments

sarhosting

Well-Known Member
Oct 1, 2007
172
2
68
United States
cPanel Access Level
Root Administrator
Twitter
Just did a test on Chrome for Android and entered the credentials incorrectly (since that tends to happen on mobile devices) and had "undefined/?locale=en" appended to the URL. After entering the proper credentials it caused a 404 Error to be displayed when using the correct password. Was the 404 Error seen by your client as well?
 

Attachments

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,250
463
Hello :)

Please ensure you do not save the URL in your favorites or bookmarks unless it's a direct link to Webmail. Including locale or session details in the URL can result in warning messages.

Thank you.
 

sarhosting

Well-Known Member
Oct 1, 2007
172
2
68
United States
cPanel Access Level
Root Administrator
Twitter
Good point, cPanelMichael. If webmail is bookmarked by a user with a session detail, should it not say "Your session cookie is invalid. Please log in again." when they visit then redirect to the correct session when the credentials are confirmed? The desktop browsers do this just fine though it may take a few more seconds.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,250
463
Could you open a support ticket using the link in my signature so we can take a closer look and determine if an internal case is required? You can post the ticket number here so we can update this thread with the outcome.

Thank you.