The following RPMs are found to be altered from their original install state: ._test.pl

comma2007

Member
Dec 7, 2007
14
0
51
Hello,
every day I receive this message

Code:
Problems were detected with cPanel-provided files which are RPM controlled.
If you did not make these changes intentionally, you can correct them by running:

> /usr/local/cpanel/scripts/check_cpanel_rpms --fix

The following RPMs are found to be altered from their original install state: 
cpanel-perl-514-Crypt-IDEA,1.08,1.cp1136,/usr/local/cpanel/3rdparty/perl/514/lib64/perl5/cpanel_lib/x86_64-linux-64int/Crypt/._test.pl
I made the rpm fix many times, but nothing.
I looked and I've not the file ._test.pl in the position indicated.
Is this the ptoblem, am I missing that file?
And if yes where can I find it?

Thank you
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,903
2,237
463
Hello :)

Please let us know if the following commands help to resolve the issue:
Code:
rpm -ev --nodeps --justdb cpanel-perl-514-Crypt-IDEA-1.08-1.cp1136.x86_64
/scripts/check_cpanel_rpms --fix
Thank you.
 

comma2007

Member
Dec 7, 2007
14
0
51
Hi,
I made it
Code:
[[email protected] ~]# rpm -ev --nodeps --justdb cpanel-perl-514-Crypt-IDEA-1.08-1.cp1136.x86_64
[[email protected] ~]# /scripts/check_cpanel_rpms --fix
[20141003.163626]   Problems were detected with cPanel-provided files which are RPM controlled.
[20141003.163626]   If you did not make these changes intentionally, you can correct them by running:
[20141003.163626]   
[20141003.163626]   > /usr/local/cpanel/scripts/check_cpanel_rpms --fix
[20141003.163626]   The following RPMs are missing from your system:
[20141003.163626]   cpanel-perl-514-Crypt-IDEA-1.08-1.cp1136
[20141003.163631]   Removing 0 broken rpms: 
[20141003.163631]   rpm: non è stato specificato alcun pacchetto per la rimozione
[20141003.163631]   Downloading http://httpupdate.cpanel.net/RPM/11.36/centos/6/x86_64/rpm.md5
[20141003.163632]   Downloading http://httpupdate.cpanel.net/RPM/11.36/centos/6/x86_64/cpanel-perl-514-Crypt-IDEA-1.08-1.cp1136.x86_64.rpm
[20141003.163632]   Hooks system enabled
[20141003.163632]   Checking for and running RPM::Versions 'pre' hooks for any RPMs about to be installed
[20141003.163632]   All required 'pre' hooks have been run
[20141003.163633]   No RPMS need to be uninstalled
[20141003.163633]   Installing new rpms: cpanel-perl-514-Crypt-IDEA-1.08-1.cp1136.x86_64.rpm
[20141003.163633]   Preparazione pacchetti per l'installazione...
[20141003.163633]   cpanel-perl-514-Crypt-IDEA-1.08-1.cp1136
[20141003.163633]   Prelinking shared libraries and binaries: /usr/sbin/prelink -av -mR
[20141003.163633]   Checking for and running RPM::Versions 'post' hooks for any RPMs just installed
[20141003.163633]   All required 'post' hooks have been run
Thank you
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,903
2,237
463
Feel free to let us know if you experience this issue again after running those commands.

Thank you.
 

comma2007

Member
Dec 7, 2007
14
0
51
Hi,

after 4 days without any message from my cPanel server I can say that the issue is resolved.

Thank you Michael.