SOLVED The installation process was unable to synchronize cPanel & WHM

Nov 8, 2010
6
1
53
Here are the troubleshooting steps:

It looks like cPanel has one way to install WHM, and it's to use this command
they have on their site:
Code:
cd /home && curl -o latest -L https://securedownloads.cpanel.net/latest
&& sh latest

[[email protected]************ home]# md5sum ./latest
89335c4149daef89abbbf153b6609d04  ./latest
The command is executed:
After the main script downloads and runs, it checks to make sure it can get to
what it needs to get to its servers and states the connection is successful:
Code:
2017-04-20 10:03:10  948 ( INFO): Validating whether the system can look up
domains...
2017-04-20 10:03:10  960 (DEBUG):  Testing cpanel.net...
2017-04-20 10:03:10  960 (DEBUG):  Testing www.cpanel.net...
2017-04-20 10:03:10  960 (DEBUG):  Testing updates.cpanel.net...
2017-04-20 10:03:10  960 (DEBUG):  Testing httpupdate.cpanel.net...
2017-04-20 10:03:10  960 (DEBUG):  Testing layer2.cpanel.net...
2017-04-20 10:03:10  960 (DEBUG):  Testing layer1.cpanel.net...
2017-04-20 10:03:10  960 (DEBUG):  Testing www.google.com...
2017-04-20 10:03:10  994 ( INFO): The system successfully connected to the
httpupdate.cpanel.net server.
following that it looks like the script doesn't pass web traffic before it
prints out no packages are available:
Code:
[2017-04-20 10:19:15 -0600]  No package automake available.
[2017-04-20 10:19:15 -0600]  No package bind available.
[2017-04-20 10:19:15 -0600]  No package bind-devel available.
[2017-04-20 10:19:15 -0600]  No package bison available.
[2017-04-20 10:19:15 -0600]  No package boost-program-options available.
The following lines are printed:

Code:
^C2017-04-20 10:03:49  921 (DEBUG):  The installation process detected a failed
synchronization. The system will reattempt the synchronization with the
updatenow.static file...
2017-04-20 10:03:49  927 (FATAL): The installation process was unable to
synchronize cPanel & WHM. Verify that your network can connect to
httpupdate.cpanel.net and rerun the installer.
Removing /root/installer.lock.
Signal caught, cleaning up
Based on the packet capture, we can tell what server the installer is attempting
to connect to and curl to that server.

Code:
[[email protected]************ ~]# curl httpupdate128.cpanel.net
<!DOCTYPE html>
<html dir="ltr" lang="en-US">
    <head>
. . . . . . .



10:03:47.200691 IP ************.60588 > httpupdate128.cpanel.net.http:
Flags [.], ack 1411, win 251, options [nop,nop,TS val 62717118 ecr 1463274798],
length 0
10:03:47.227148 IP httpupdate128.cpanel.net.http > ************.60588:
Flags [P.], seq 2261:2266, ack 459, win 243, options [nop,nop,TS val 1463274824
ecr 62717119], length 5
We're more than confirming bidirectional traffic using ping here...

This isn't a matter of our servers or connectivity, but a matter we need to
resolve with cPanel

So far it looks like the script has:

[2017-04-20 10:03:41 -0600] Using mirror '64.50.186.230' for host
'httpupdate.cpanel.net'. It seems to be really glued on this IP at the moment.


I think the script is ignoring the answer file...
[[email protected]************ home]# ping httpupdate.cpanel.net
PING httpupdate.cpanel.net (94.75.231.77) 56(84) bytes of data.

Out of the following:

Code:
;; ANSWER SECTION:
httpupdate.cpanel.net. 17 IN A 70.87.220.252
httpupdate.cpanel.net. 17 IN A 72.29.88.74
httpupdate.cpanel.net. 17 IN A 74.50.120.123
httpupdate.cpanel.net. 17 IN A 83.170.94.2
httpupdate.cpanel.net. 17 IN A 85.13.201.2
httpupdate.cpanel.net. 17 IN A 94.75.231.77
httpupdate.cpanel.net. 17 IN A 204.10.37.146
httpupdate.cpanel.net. 17 IN A 208.43.108.66
httpupdate.cpanel.net. 17 IN A 208.43.129.162
httpupdate.cpanel.net. 17 IN A 208.74.121.39
httpupdate.cpanel.net. 17 IN A 208.78.42.4
httpupdate.cpanel.net. 17 IN A 208.109.109.239
httpupdate.cpanel.net. 17 IN A 209.85.80.214
httpupdate.cpanel.net. 17 IN A 216.38.56.98
httpupdate.cpanel.net. 17 IN A 63.247.66.98
httpupdate.cpanel.net. 17 IN A 64.50.186.230
httpupdate.cpanel.net. 17 IN A 66.23.237.210
httpupdate.cpanel.net. 17 IN A 67.159.2.2
httpupdate.cpanel.net. 17 IN A 67.205.110.4
httpupdate.cpanel.net. 17 IN A 67.222.0.10
httpupdate.cpanel.net. 17 IN A 67.227.128.74
httpupdate.cpanel.net. 17 IN A 69.50.192.73
httpupdate.cpanel.net. 17 IN A 69.72.212.10
httpupdate.cpanel.net. 17 IN A 69.72.212.11
httpupdate.cpanel.net. 17 IN A 69.73.140.17
Let me clarify for the line that states: "answer file... "

I think the script is ignoring the /etc/hosts file entry...
94.75.231.77 httpupdate.cpanel.net
[[email protected]************ home]# ping httpupdate.cpanel.net
PING httpupdate.cpanel.net (94.75.231.77) 56(84) bytes of data.


What I'm trying to do is install WHM/cPanel, but it's failing. (Cloud Linux.)

Code:
Linux ************ 3.10.0-427.36.1.lve1.4.40.el7.x86_64 #1 SMP Thu Mar 9 05:49:24 EST 2017 x86_64 x86_64 x86_64 GNU/Linux

[2017-04-20 12:35:02 -0600]   Using mirror '94.75.231.77' for host 'httpupdate.cpanel.net'.
Result: 2017-04-20 12:35:39  927 (FATAL): The installation process was unable to synchronize cPanel & WHM. Verify that your network can connect to httpupdate.cpanel.net and rerun the installer.
Communication appears to work with this server as well.
[[email protected]************ home]# curl 94.75.231.77
<!DOCTYPE html> etc...
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,220
463
Nov 8, 2010
6
1
53
We can tell which command did something :)
The output from rhnreg_ks would indicate a failure to execute properly.

however the clnreg_ks command appears to work properly:
[[email protected]************ home]# clnreg_ks --force
Profilename: ************
<this sat for a few minutes.>

Once it was done, I re-ran just the "sh latest" command and it appears to be working so far.

[2017-04-20 12:47:43 -0600] Using mirror '94.75.231.77' for host 'httpupdate.cpanel.net'.

The strange thing is, this is a new install with a licensed IP address... I can't say for sure that clnreg_ks would be there without the initial install?

Hopefully adding a md5 sum doesn't mess people up in the future if they are checking and their version is different.
md5sum /usr/sbin/clnreg_ks
517656b749bc426059b71ad8e03c6f93 /usr/sbin/clnreg_ks
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,220
463
however the clnreg_ks command appears to work properly:
[[email protected]************ home]# clnreg_ks --force
Profilename: ************
<this sat for a few minutes.>

Once it was done, I re-ran just the "sh latest" command and it appears to be working so far.

[2017-04-20 12:47:43 -0600] Using mirror '94.75.231.77' for host 'httpupdate.cpanel.net'.
Hello,

I'm happy to see that helped. Let us know if you encounter any additional issues with the installation.

Thank you.
 
Nov 8, 2010
6
1
53
on the other hosts: I'm using is Install processes:
1) Run the install command. "cd /home && curl -o latest -L https://securedownloads.cpanel.net/latest && sh latest"
2) Wait for the failure, and run the command "clnreg_ks --force", this takes less than two minutes.
3) Then run the command: "sh latest"

I'll post if it's successful when "I'm done drinking my coffee."
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,220
463
I'm happy to see it worked well. Thank you for updating us with the outcome.
 

amin alnasra

Member
Apr 16, 2015
9
0
1
palestine
cPanel Access Level
Root Administrator
on the other hosts: I'm using is Install processes:
1) Run the install command. "cd /home && curl -o latest -L https://securedownloads.cpanel.net/latest && sh latest"
2) Wait for the failure, and run the command "clnreg_ks --force", this takes less than two minutes.
3) Then run the command: "sh latest"

I'll post if it's successful when "I'm done drinking my coffee."
thank you this work for me .
cloudlinux 7
 

quietFinn

Well-Known Member
Feb 4, 2006
1,394
181
193
Finland
cPanel Access Level
Root Administrator
Good day, I have the same issue, then when I key in " clnreg_ks --force"

SSH give me the result as below,


[[email protected] home]# clnreg_ks --force
-bash: clnreg_ks: command not found
Are you using CloudLinux?
If not that command does not exist.
 
  • Like
Reactions: cPanelAnthony

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
656
62
103
Houston, TX
cPanel Access Level
Root Administrator
Good day, I have the same issue, then when I key in " clnreg_ks --force"

SSH give me the result as below,


[[email protected] home]# clnreg_ks --force
-bash: clnreg_ks: command not found
Do you see any errors in the cPanel install log?

 

andersenchong

Registered
Oct 24, 2021
3
0
1
Malaysia
cPanel Access Level
Root Administrator
I had solve it yesterday.

I have these error I mention with install WHM at Centos 8, it failed for 3 times installation. but 4th times, I tried on Centos 7, it done perfectly. it look like at this moment not compatible to Centos 8