"The ionCube PHP Loader is disabled because of startup problems." error after apache

gundamz

Well-Known Member
Mar 27, 2002
245
0
316
Hi guys,

I am getting following error after i have compile apache 1.3 with php4(dso) & php5(cgi)

[email protected] # php -v
The ionCube PHP Loader is disabled because of startup problems.
Any ideas why this happen?
 
Last edited:

Radio_Head

Well-Known Member
Verifed Vendor
Feb 15, 2002
2,051
1
343
If you upgrade cpanel the problem will be fixed itself. One of the latest cpanel updates fully messed up cpanel internal php.ini.
 

gundamz

Well-Known Member
Mar 27, 2002
245
0
316
If you upgrade cpanel the problem will be fixed itself. One of the latest cpanel updates fully messed up cpanel internal php.ini.

i went to recompile apache 1.3 , php4 as DSO and php5 as cgi . i still get that error when i do a php -v ..

any ideas why?
 

gundamz

Well-Known Member
Mar 27, 2002
245
0
316
i think cgi version of php do not accept ioncube?
 

gtgeorge

Well-Known Member
Feb 28, 2007
85
0
156
i think cgi version of php do not accept ioncube?
That is not a true statement. :eek: Just add the appropriate line for your version of the ioncube/php loader in the php.ini for the php version you have the error for.

For instance
Code:
zend_extension=/etc/ioncube/ioncube_loader_lin_5.2.so
is what would be used for php 5.2 in the Zend area of the php.ini

Also keep in mind if you use a php.ini override file, you must include the zend section or it will drop ioncube from your default setup.
 
Last edited: