The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"The login is invalid" - Constantly unable to log into Webmail, WHM & FTP.

Discussion in 'General Discussion' started by LOF, Nov 23, 2014.

  1. LOF

    LOF Registered

    Joined:
    Nov 23, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Just started my Opencart website a month ago, and have been constantly battling login problems, for my Webmail and WHM, and even FTP, when my user name and passwords are correct.

    Just one instance - I could not log into my Webmail and WHM since last Thursday. I was still able to log into my FTP. Finally managed to log in to both my Webmail and WHM yesterday. Then right now, I can't log into my FTP. It is driving me crazy.

    My web host tells me there are no problems on server side and refuses to help me further.
    I have root access.
    I have also tried using different computers as advised by them.

    I have zero/very minimal technical knowledge..
     
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    from what you are describing sounds like cPHulk Brute Force Protection is blocking you only your provider can look into it for you
     
  3. LOF

    LOF Registered

    Joined:
    Nov 23, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    hi,

    this is the reply they gave me -

    " You have the server root access and you can do yourself. As we don't have access to your server as its unmanaged server. "

    How am i able to go around this cPHulk Brute Force Protection myself?
     
  4. JustSomeGuy

    JustSomeGuy Active Member

    Joined:
    Oct 13, 2007
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    It does sound like CPHulk. If so, just login through a different IP address.
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,787
    Likes Received:
    665
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    If your "root" user is still locked out, then you may need to obtain console access and disable cPhulk with commands such as:
    Code:
    for i in `ps aux | grep -i "cphulkd - process" | awk {'print $2'}` ;do kill -9 $i ;done
    /usr/local/cpanel/bin/cphulk_pam_ctl --disable
    Note that some users disable cPHulk and utilize a third-party application (e.g. CSF/LFD) to handle brute force attacks. This may be an option for you to consider.

    See this thread:

    cPhulk keeps locking me out

    Thank you.
     
  6. LOF

    LOF Registered

    Joined:
    Nov 23, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    thanks for all your help!

    But I still could not get in using a different IP address nor through ssh...

    have asked my web host to reset password again... although my passwords have all along been correct but this seems to work the last few times... Once I am able to log in again I will try to implement what you have suggested and see how that works out
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,787
    Likes Received:
    665
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Right, it's possible the account itself was locked out. You may need to get your hosting provider to disable cPHulk with console access:
    Code:
    for i in `ps aux | grep -i "cphulkd - process" | awk {'print $2'}` ;do kill -9 $i ;done
    /usr/local/cpanel/bin/cphulk_pam_ctl --disable
    
    Thank you.
     
Loading...

Share This Page