The MySQL server is currently offline adminbin Cpanel/cpmysql/DBCACHE: exit 2

asfik

Member
Mar 31, 2006
19
5
153
Indonesia
cPanel Access Level
Root Administrator
Hello,

We recently updated the cPanel to the latest version 100.0 (build 9) and then we can not connect to MySQL which located remotely with the error as below in cPanel database section:

MySQL® Databases
The MySQL server is currently offline.
adminbin Cpanel/cpmysql/DBCACHE: exit 2

Looking into cPanel error_log file we found the following entry:

[2022-02-16 14:45:43 +0800] info [install_plugin] Scheduling task to update API spec files
Cpanel::Exception::ModuleLoadError/(XID ay4ypa) The system failed to load the module "Cpanel::Database::MariaDB::MariaDB104" because of an error: Can't locate Cpanel/Database/MariaDB/MariaDB104.pm in @INC (you may need to install the Cpanel::Database::MariaDB::MariaDB104 module) (@INC contains: /usr/local/cpanel /usr/local/cpanel/3rdparty/perl/532/lib/perl5/cpanel_lib/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/532/lib/perl5/cpanel_lib /usr/local/cpanel/3rdparty/perl/532/lib/perl5/532/x86_64-linux-64int /usr/local/cpanel/3rdparty/perl/532/lib/perl5/532 /opt/cpanel/perl5/532/site_lib/x86_64-linux-64int /opt/cpanel/perl5/532/site_lib) at (eval 6) line 1.
BEGIN failed--compilation aborted at (eval 6) line 1.

Kindly please let me know how to fix the issue. Thank you
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
11,780
1,872
363
cPanel Access Level
Root Administrator
We'd likely need more detail than this to troubleshoot the issue. It would seem like there is an issue with the location installation of MariaDB, but that's just a guess based on the log output.

For this type of issue it would likely be best to submit a ticket to our team so we can check things on the system directly.
 

asfik

Member
Mar 31, 2006
19
5
153
Indonesia
cPanel Access Level
Root Administrator
We'd likely need more detail than this to troubleshoot the issue. It would seem like there is an issue with the location installation of MariaDB, but that's just a guess based on the log output.

For this type of issue it would likely be best to submit a ticket to our team so we can check things on the system directly.
Thanks. I just submitted ticket with ID 94417388