SOLVED The optional module, imagick, is not installed, or has been disabled

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,519
1,027
313
cPanel Access Level
Root Administrator
Hey there! The Pecl module isn't enough to get all the tools working directly with PHP. Can you try working through the steps here and let me know if that resolves the issue?

 

greektranslator

Well-Known Member
Jun 5, 2011
106
8
68
Greece
cPanel Access Level
Root Administrator
I had already installed them.

yum install ImageMagick ImageMagick-devel -y
Loaded plugins: fastestmirror, universal-hooks
Loading mirror speeds from cached hostfile
* EA4: 91.197.228.252
* EA4-experimental: 91.197.228.252
* cpanel-addons-production-feed: 91.197.228.252
* cpanel-plugins: 91.197.228.252
Package ImageMagick-6.9.10.68-3.el7.x86_64 already installed and latest version
Package ImageMagick-devel-6.9.10.68-3.el7.x86_64 already installed and latest version
Nothing to do
[[email protected] ~]#

find /opt/cpanel/ -iname pecl | grep bin
/opt/cpanel/ea-php72/root/usr/bin/pecl
/opt/cpanel/ea-php73/root/usr/bin/pecl
/opt/cpanel/ea-php74/root/usr/bin/pecl

/opt/cpanel/ea-php74/root/usr/bin/pecl install imagick

/opt/cpanel/ea-php74/root/usr/bin/pecl
[[email protected] ~]# ^C
[[email protected] ~]# /opt/cpanel/ea-php74/root/usr/bin/pecl install imagick
pecl/imagick is already installed and is the same as the released version 3.4.4
install failed

By the way in this bit, perhaps "cptest" should be "cpanelusername"?

Code:
echo "<?php phpinfo();" > /home/cpanelusername/public_html/phpinfo.php
chown cpanelusername:cpanelusername /home/cptest/public_html/phpinfo.php
chmod 0644 /home/cpanelusername/public_html/phpinfo.php
lynx --dump http://domain.tld/phpinfo.php | grep -i "imagick module"

By
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,519
1,027
313
cPanel Access Level
Root Administrator
Thanks for the additional details. It seems like there is something else going on with the system if those aren't being properly detected by Wordpress. It might be best to open a ticket to have our team check the issue. If you do open a ticket can you please post the number here so we can update the thread with the resolution.