The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The perl module Encode::Detect::Detector could not be installed.

Discussion in 'General Discussion' started by Polidoor, Apr 16, 2008.

  1. Polidoor

    Polidoor Member

    Joined:
    Jul 4, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Today received mail after updated WHM

    I tried the following but no luck :

    /scripts/checkperlmodules

    and

    http://servertune.com/kbase/entry/132/



    This module is required by cPanel, and the system may not function correctly until it is installed, and functional. Below is the results of the auto-install attempt:

    Test Run
    ==============
    Can't locate Encode/Detect/Detector.pm in @INC (@INC contains: /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl .) at - line 1.
    BEGIN failed--compilation aborted at - line 1.
     
  2. david510

    david510 Well-Known Member

    Joined:
    Aug 22, 2004
    Messages:
    473
    Likes Received:
    0
    Trophy Points:
    16
    Do this,

    type cpan and from cpan mode type below.

    install Detect::Module
     
  3. xamot

    xamot Registered

    Joined:
    Sep 11, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I got the same e-mail yesterday, did the manual cpan install thing and it seemed to install fine. Rerunning the cpan install I see "Detect::Module is up to date (1.2)."

    But I got the same e-mail that Encode::Detect::Detector could not be installed again today.
     
  4. Kevinfrom

    Kevinfrom Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
  5. jandafields

    jandafields Well-Known Member

    Joined:
    May 6, 2004
    Messages:
    426
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Detector.pm Error Every Night

    I get this email every night for 4 days now:

    I have installed Detect::Module through CPAN to try and fix it, and that is successful, but I continue to get this.

    Any suggestions?

    Code:
    
    This module is required by cPanel, and the system may not function correctly until it is installed, and functional.  Below is the results of the auto-install attempt:
    
    Test Run
    ==============
    Can't locate Encode/Detect/Detector.pm in @INC (@INC contains: /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.4/i686-linux /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.6.2 /usr/lib/perl5/site_perl .) at - line 1.
    BEGIN failed--compilation aborted at - line 1.
    
    
     
  6. bamm

    bamm Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Before submitting a ticket I wanted to check here to see if there is any further update on this.

    This is occuring on 2 of my servers now and it appears to be causing some issues with using features.

    I attempted to do the manual install following your instructions but when running the wget you suggested we're receiving 404 page not found:

    wget http://search.cpan.org/CPAN/authors/...ct-1.00.tar.gz
    --05:16:42-- http://search.cpan.org/CPAN/authors/...ct-1.00.tar.gz
    => `...ct-1.00.tar.gz'
    Resolving search.cpan.org... done.
    Connecting to search.cpan.org[216.52.237.135]:80... connected.
    HTTP request sent, awaiting response... 302 Found
    Location: http://mirror.hiwaay.net/CPAN/authors/...ct-1.00.tar.gz [following]
    --05:16:42-- http://mirror.hiwaay.net/CPAN/authors/...ct-1.00.tar.gz
    => `...ct-1.00.tar.gz'
    Resolving mirror.hiwaay.net... done.
    Connecting to mirror.hiwaay.net[216.180.99.217]:80... connected.
    HTTP request sent, awaiting response... 404 Not Found
    05:16:42 ERROR 404: Not Found.
     
  7. chaospire

    chaospire Registered

    Joined:
    Oct 2, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    The link gets truncated when you post.

    Try right clicking on the link to the file and selecting "Copy Link", then paste then: wget <pasted link>
     
  8. bamm

    bamm Well-Known Member

    Joined:
    Feb 24, 2003
    Messages:
    75
    Likes Received:
    0
    Trophy Points:
    6
    Chaospire,

    *shakes head* I should have seen that - haven't had my first cup of java yet this morning. Thank you for pointing that out.

    Is it possible that you could post the instructions for running build, make etc. that he mentions after adding the patch to Detector.xs?

    Thank you so much for your help.
     
  9. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    We have reported the bug to the module author. We hope it will be solved shortly, if not we will provide an alternate work around.
    Unless you have lots of files in non-latin charset it will probably make no difference for you.


    http://rt.cpan.org/Public/Bug/Display.html?id=35564
     
  10. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    Threads Merged
     
  11. JinGu

    JinGu Member

    Joined:
    Mar 26, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Any ETA on the work around?

    Thanks.
     
  12. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    The module's author has proposed a patch, if the patch works for you then you might let him know that so he'll be more inclined to publish it
     
  13. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    I am unable to find a test server with gcc 3.3 that this fails on, if someone has a server that suffers from this and you'd like me to test before and after w/ the author's proposed patch (and subsequently notify the author), then please create a ticket 'Attn: Dan' referencing this forum thread.

    thanks!
     
  14. Angel78

    Angel78 Well-Known Member

    Joined:
    May 9, 2002
    Messages:
    413
    Likes Received:
    1
    Trophy Points:
    16
    any news on this?
     
  15. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    http://rt.cpan.org/Public/Bug/Display.html?id=35564

    The module's author has proposed a patch, if the patch works for you then you might let him know that so he'll be more inclined to publish it

    In the meantime if you can't get it installed it won't break anything if tis missing, it will just fall back to a different module.
     
  16. Angel78

    Angel78 Well-Known Member

    Joined:
    May 9, 2002
    Messages:
    413
    Likes Received:
    1
    Trophy Points:
    16
    ok as I cant play guinea pig with this server Ill leave it until it has been solved out (as it will not affect Cpanel = perhaps you should modiffy the error message then).

    thank you
     
  17. greetingsc

    greetingsc Active Member

    Joined:
    May 18, 2004
    Messages:
    44
    Likes Received:
    0
    Trophy Points:
    6
    The proposed patch worked for me after getting the error for a couple weeks.

    Thanks for working on this Dan!

    Mike
     
    #17 greetingsc, May 27, 2008
    Last edited: May 27, 2008
Loading...

Share This Page