Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

The perl module Tie::Watch could not be installed.

Discussion in 'Database Discussion' started by winduff, Mar 14, 2008.

  1. winduff

    winduff Registered

    Joined:
    Jan 20, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    51
    Hey guys,

    I keep getting this email from my server:

    Code:
    This module is required by cPanel, and the system may not function correctly until it is installed, and functional.  Below is the results of the auto-install attempt:
    
    Test Run
    ==============
    Can't locate Tie/Watch.pm in @INC (@INC contains: /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.7/x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.6/x86_64-linux-thread-multi /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.8.7/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.8.6/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .) at - line 1.
    BEGIN failed--compilation aborted at - line 1.
    
    
    Installer Run
    ==============
    Fetching CPAN timestamp...Done
    Testing connection speed...(this could take a while)...Done
    Ping:1.509 Testing connection speed to cpan.noris.de using pureperl...(314800.00 bytes/s)...Done
    Ping:1.050 Testing connection speed to cpan.server-mirrors.com using pureperl...(155800.00 bytes/s)...Done
    Three usable mirrors located
    Mirror Check passed for cpan.noris.de (/index.html)
    Unknown config variable 'less'
    commit: wrote '/usr/lib/perl5/5.8.8/CPAN/Config.pm'
    CPAN: File::HomeDir loaded ok (v0.69)
    CPAN: Storable loaded ok (v2.18)
    Going to read /home/.cpan/Metadata
     Database was generated on Wed, 12 Mar 2008 12:30:55 GMT
    CPAN: LWP::UserAgent loaded ok (v2.036)
    CPAN: Time::HiRes loaded ok (v1.9712)
    Fetching with LWP:
     http://cpan.noris.de/authors/01mailrc.txt.gz
    CPAN: YAML loaded ok (v0.66)
    Going to read /home/.cpan/sources/authors/01mailrc.txt.gz
    ............................................................................DONE
    Fetching with LWP:
     http://cpan.noris.de/modules/02packages.details.txt.gz
    Going to read /home/.cpan/sources/modules/02packages.details.txt.gz
     Database was generated on Thu, 13 Mar 2008 11:31:03 GMT
    ............................................................................DONE
    Fetching with LWP:
     http://cpan.noris.de/modules/03modlist.data.gz
    Going to read /home/.cpan/sources/modules/03modlist.data.gz
    ............................................................................DONE
    Going to write /home/.cpan/Metadata
    Running install for module 'Tie::Watch'
    Running make for S/SR/SREZIC/Tk-804.028.tar.gz
    CPAN: Digest::SHA loaded ok (v5.45)
    Checksum for /home/.cpan/sources/authors/id/S/SR/SREZIC/Tk-804.028.tar.gz ok
    
    (... lots of stuff comes here... install log)
    	  
    gcc-64bit-hack: enabled
    /usr/bin/ld: skipping incompatible /usr/lib/libX11.so when searching for -lX11
    /usr/bin/ld: cannot find -lX11
    collect2: ld returned 1 exit status
    make: *** [blib/arch/auto/Tk/Tk.so] Error 1
     SREZIC/Tk-804.028.tar.gz
     /usr/bin/make OTHERLDFLAGS=-L/usr/lib64 LDFLAGS=-L/usr/lib64 EXTRALIBDIR=/usr/lib64 OTHERLDFLAGS=-L/usr/lib64 LDFLAGS=-L/usr/lib64 EXTRALIBDIR=/usr/lib64 -- NOT OK
    
    
    Running make install
     Make had returned bad status, install seems impossible
    perlmod--Install done
    
    Any idea whats causing this?

    Chris
     
  2. UmbraHosting

    UmbraHosting Member

    Joined:
    Mar 12, 2006
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    151
    I just received the same error, so I am looking for a solution as well. I'll update this thread when I resolve the issue.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice