The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The server has reached its limit for processing requests from your host.n451

Discussion in 'E-mail Discussions' started by MarcelB, Nov 12, 2008.

  1. MarcelB

    MarcelB Well-Known Member

    Joined:
    Dec 29, 2003
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    I keep having a large mail queue on server1 trying to send it to server2. Both servers are mine and IP's are allowed in the firewall.

    When I force email on server1 to be delivered through ConfigServer Mail Queues there is the following error:
    451-The server has reached its limit for processing requests from your host.n451 Please try again later.

    Even a reboot of server2 didn't solve the problem.

    What could be the problem here ?
     
  2. nickp666

    nickp666 Well-Known Member

    Joined:
    Jan 28, 2005
    Messages:
    770
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    /dev/null
    its probably exim's ratelimiting, add your servers IP's to the whitelist in WHM > Exim Configuration

    Also check the value of the 'Maximum Emails a Domain Can Send In 1 Hour' value in WHM > Tweak Settings
     
    #2 nickp666, Nov 13, 2008
    Last edited: Nov 13, 2008
  3. mikelegg

    mikelegg Well-Known Member

    Joined:
    Mar 29, 2005
    Messages:
    330
    Likes Received:
    0
    Trophy Points:
    16
    I just started having this problem with one of my servers rejecting mail from my backup MX server - despite the fact that the backup server is included in WHM >> Exim Configuration Editor >> Exim Backup Mail Hosts.

    The server was just down for some scheduled maintenance and now a heap of our customers mail is stuck in the secondary MX queue - unable to be accepted by the main server.
     
  4. mikelegg

    mikelegg Well-Known Member

    Joined:
    Mar 29, 2005
    Messages:
    330
    Likes Received:
    0
    Trophy Points:
    16
    I've found a temporary solution.

    I've turned off the "Ratelimit: incoming SMTP connections that do not send QUIT, have recently matched an RBL, or have attacked the server." option.

    The mail is being delivered now.

    So adding a backup server to /etc/backupmxhosts doesn't actually whitelist it.

    I'll need to find a way of turning this option back on without blocking the sMX server again.
     
  5. nitaish

    nitaish Well-Known Member
    PartnerNOC

    Joined:
    Jan 6, 2006
    Messages:
    123
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Mulund, India, India
    Here is the option

    Whitelist: Trusted Mail Hosts/IP Blocks (bypass all SMTP time checks except recipient verification)
     
  6. aarondwyer

    aarondwyer Well-Known Member

    Joined:
    Mar 26, 2005
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brisbane
    cPanel Access Level:
    Root Administrator
    I had this rate limiting issue on my backup MX server as well.

    I simply added it to /etc/backupmxhosts and it worked.

    However in my Exim I don't have the ability to tick the option for ...

    Whitelist: Backup Mail Hosts (bypass all SMTP ratelimits).

    I don't know why

    Aaron
     
  7. patriciaguedes

    patriciaguedes Registered

    Joined:
    Dec 6, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I found this same problem and did as below and it worked:
    You can change the max smtp connection in /etc/exim.conf using below parameter :

    smtp_accept_max = VALUE

    The VALUE is the number you need to set according to your needs. You can experiment by increasing it a bit from its current value and see if it fulfills your requirement else you can increase it further until it works for you.
     
  8. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I did want to note that smtp_accept_max is the maximum number of simultaneous SMTP connections on the machine for anyone who is not familiar with this setting. The default for cPanel machines in /etc/exim.conf is 100.

    The proper method to revise this value would be in WHM > Exim Configuration Editor > Advanced Editor area. In the topmost box, if you input the value and click the "Save" button:

    Code:
    smtp_accept_max = 200
    For example, it would change the value from "smtp_accept_max = 100" to the new 200 value. Any entries put at that topmost box for fields immediately below are removed and re-added with your new configuration setting.

    If you manually edit /etc/exim.conf instead under cPanel, then whenever /scripts/eximup --force is processed, the value you've changed will be removed and the default set again. Thus, you would want to use WHM > Exim Configuration Editor > Advanced Editor to change the value.

    To read about smtp_accept_max directive for exim, please review the following documentation from the exim site:

    Exim Specification - Main configuration
     
Loading...

Share This Page