The server's system package manager, 'YUM', failed. !!

eManuka

Member
Aug 19, 2014
5
0
1
cPanel Access Level
Root Administrator
Code:
!! ensure() rc was '0', exit status was '256', perl '$?' was '0', exit sig '0', core dump: '0', shell '$?' was '1' !!

!! Simulating failed Cpanel::SysPkgs as per 'simulate-failed-syspkgs' flag !!
!! Could not ensure pkglist 'gettext, automake19, libstdc++.x86_64, libpng-devel, readline-devel, openssl, libpng-dev, zlib-devel, autoconf261, libidn-devel, gmake, libidn, libXpm, openssl-devel, automake, coreutils, patch, libltdl3-devel, libltdl, libopenssl0.9.7-static-devel, readline-dev, libtool-ltdl-devel, libXpm-devel, sed, libXpm-dev, lsof, krb5-dev, flex, glibc-dev, expat-dev, krb5-devel, libstdc++-devel.x64_64, xorg-x11-devel, libtool-ltdl, libssl-dev, pam-devel, libopenssl0-devel, zlib1-devel, expat-devel, libopenssl0-dev, glibc-devel, expat, gcc-c++, zlib, bison, libjpeg-devel, libtool-libltdl-devel, libtool, openssl-dev, libopenssl0, libz-devel, libjpeg-dev, pam-dev, fileutils, libltdl-devel, libopenssl0.9.7-devel, e2fsprogs-devel, ca_root_nss, make, libstdc++-dev.x86_64, libX11-devel, libstdc++-devel.x86_64, gd, cpp, xorg-x11-dev, gcc, ssl-dev, lex, autoconf' !!
!! The server's system package manager, 'YUM', failed. !!
!!
This is the command that failed:
        yum -y install gettext automake19 libstdc++.x86_64 libpng-devel readline-devel openssl libpng-dev zlib-devel autoconf261 libidn-devel gmake libidn libXpm openssl-devel automake coreutils patch libltdl3-devel libltdl libopenssl0.9.7-static-devel readline-dev libtool-ltdl-devel libXpm-devel sed libXpm-dev lsof krb5-dev flex glibc-dev expat-dev krb5-devel libstdc++-devel.x64_64 xorg-x11-devel libtool-ltdl libssl-dev pam-devel libopenssl0-devel zlib1-devel expat-devel libopenssl0-dev glibc-devel expat gcc-c++ zlib bison libjpeg-devel libtool-libltdl-devel libtool openssl-dev libopenssl0 libz-devel libjpeg-dev pam-dev fileutils libltdl-devel libopenssl0.9.7-devel e2fsprogs-devel ca_root_nss make libstdc++-dev.x86_64 libX11-devel libstdc++-devel.x86_64 gd cpp xorg-x11-dev gcc ssl-dev lex autoconf
!!
!!
Since EasyApache was unable to resolve it automatically you should:
        1) Manually run the failed YUM command (shown above) via SSH
        2) See if your particular error is addressed at http://go.cpanel.net/eaerror
        3) Resolve the YUM problem manually
        4) Re-run EasyApache
!!
!! Please visit http://go.cpanel.net/eaerror for help with this error. !!

!! Restoring original working apache !!
!! Executing '/scripts/initsslhttpd' !!
!! Restarting 'httpd' ... !!
!! 'httpd' restart complete. !!
Building global cache for cpanel...Done
!! Executing '/scripts/initfpsuexec' !!
!! Executing '/scripts/initsslhttpd' !!
!! Executing '/scripts/fixmailman' !!
!! Executing '/scripts/update_apachectl' !!
Compiling report...
Sending report. As some of the attached files may be quite large, this could take a few minutes. Thanks for your patience.
!! If you  want to create a support ticket with cPanel regarding this please reference 'BuildAP Report Id': '14223025' !!
Report processed.
!! Feel free to submit a support ticket at https://tickets.cpanel.net/submit/index.cgi?reqtype=tickets !!
!! Verbose logfile is at '/usr/local/cpanel/logs/easy/apache/build.1408473896' !!
I tried to fix trough following code but non of them work!

/scripts/upcp --force
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,248
363
Hello :)

It's telling you the following command is unable to complete successfully due to a problem with your system package manager:

Code:
yum -y install gettext automake19 libstdc++.x86_64 libpng-devel readline-devel openssl libpng-dev zlib-devel autoconf261 libidn-devel gmake libidn libXpm openssl-devel automake coreutils patch libltdl3-devel libltdl libopenssl0.9.7-static-devel readline-dev libtool-ltdl-devel libXpm-devel sed libXpm-dev lsof krb5-dev flex glibc-dev expat-dev krb5-devel libstdc++-devel.x64_64 xorg-x11-devel libtool-ltdl libssl-dev pam-devel libopenssl0-devel zlib1-devel expat-devel libopenssl0-dev glibc-devel expat gcc-c++ zlib bison libjpeg-devel libtool-libltdl-devel libtool openssl-dev libopenssl0 libz-devel libjpeg-dev pam-dev fileutils libltdl-devel libopenssl0.9.7-devel e2fsprogs-devel ca_root_nss make libstdc++-dev.x86_64 libX11-devel libstdc++-devel.x86_64 gd cpp xorg-x11-dev gcc ssl-dev lex autoconf
Please run this command manually and let us know what error message you receive.

Thank you.
 

eManuka

Member
Aug 19, 2014
5
0
1
cPanel Access Level
Root Administrator
Hello :)

It's telling you the following command is unable to complete successfully due to a problem with your system package manager:

Code:
yum -y install gettext automake19 libstdc++.x86_64 libpng-devel readline-devel openssl libpng-dev zlib-devel autoconf261 libidn-devel gmake libidn libXpm openssl-devel automake coreutils patch libltdl3-devel libltdl libopenssl0.9.7-static-devel readline-dev libtool-ltdl-devel libXpm-devel sed libXpm-dev lsof krb5-dev flex glibc-dev expat-dev krb5-devel libstdc++-devel.x64_64 xorg-x11-devel libtool-ltdl libssl-dev pam-devel libopenssl0-devel zlib1-devel expat-devel libopenssl0-dev glibc-devel expat gcc-c++ zlib bison libjpeg-devel libtool-libltdl-devel libtool openssl-dev libopenssl0 libz-devel libjpeg-dev pam-dev fileutils libltdl-devel libopenssl0.9.7-devel e2fsprogs-devel ca_root_nss make libstdc++-dev.x86_64 libX11-devel libstdc++-devel.x86_64 gd cpp xorg-x11-dev gcc ssl-dev lex autoconf
Please run this command manually and let us know what error message you receive.

Thank you.
Code:
[email protected] [~]# yum -y install gettext automake19 libstdc++.x86_64 libpng-devel readline-devel openssl libpng-dev zlib-devel autoconf261 libidn-devel gmake libidn libXpm openssl-devel automake coreutils patch libltdl3-devel libltdl libopenssl0.9.7-static-devel readline-dev libtool-ltdl-devel libXpm-devel sed libXpm-dev lsof krb5-dev flex glibc-dev expat-dev krb5-devel libstdc++-devel.x64_64 xorg-x11-devel libtool-ltdl libssl-dev pam-devel libopenssl0-devel zlib1-devel expat-devel libopenssl0-dev glibc-devel expat gcc-c++ zlib bison libjpeg-devel libtool-libltdl-devel libtool openssl-dev libopenssl0 libz-devel libjpeg-dev pam-dev fileutils libltdl-devel libopenssl0.9.7-devel e2fsprogs-devel ca_root_nss make libstdc++-dev.x86_64 libX11-devel libstdc++-devel.x86_64 gd cpp xorg-x11-dev gcc ssl-dev lex autoconf
Setting up Install Process
Package gettext-0.17-16.el6.x86_64 already installed and latest version
No package automake19 available.
Package 2:libpng-devel-1.2.49-1.el6_2.x86_64 already installed and latest version
Package readline-devel-6.0-4.el6.x86_64 already installed and latest version
Package openssl-1.0.1e-16.el6_5.15.x86_64 already installed and latest version
No package libpng-dev available.
Package zlib-devel-1.2.3-29.el6.x86_64 already installed and latest version
No package autoconf261 available.
Package libidn-devel-1.18-2.el6.x86_64 already installed and latest version
No package gmake available.
Package libidn-1.18-2.el6.x86_64 already installed and latest version
Package openssl-devel-1.0.1e-16.el6_5.15.x86_64 already installed and latest version
Package patch-2.6-6.el6.x86_64 already installed and latest version
No package libltdl3-devel available.
No package libltdl available.
No package libopenssl0.9.7-static-devel available.
No package readline-dev available.
Package libtool-ltdl-devel-2.2.6-15.5.el6.x86_64 already installed and latest version
Package sed-4.2.1-10.el6.x86_64 already installed and latest version
No package libXpm-dev available.
Package lsof-4.82-4.el6.x86_64 already installed and latest version
No package krb5-dev available.
Package flex-2.5.35-8.el6.x86_64 already installed and latest version
No package glibc-dev available.
No package expat-dev available.
No package libstdc++-devel.x64_64 available.
No package xorg-x11-devel available.
Package libtool-ltdl-2.2.6-15.5.el6.x86_64 already installed and latest version
No package libssl-dev available.
No package libopenssl0-devel available.
No package zlib1-devel available.
Package expat-devel-2.0.1-11.el6_2.x86_64 already installed and latest version
No package libopenssl0-dev available.
Package expat-2.0.1-11.el6_2.x86_64 already installed and latest version
Package zlib-1.2.3-29.el6.x86_64 already installed and latest version
Package bison-2.4.1-5.el6.x86_64 already installed and latest version
No package libtool-libltdl-devel available.
Package libtool-2.2.6-15.5.el6.x86_64 already installed and latest version
No package openssl-dev available.
No package libopenssl0 available.
No package libz-devel available.
No package libjpeg-dev available.
No package pam-dev available.
No package libltdl-devel available.
No package libopenssl0.9.7-devel available.
No package ca_root_nss available.
Package 1:make-3.81-20.el6.x86_64 already installed and latest version
No package libstdc++-dev.x86_64 available.
No package xorg-x11-dev available.
No package ssl-dev available.
No package lex available.
Package autoconf-2.63-5.1.el6.noarch already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package automake.noarch 0:1.11.1-1.2.el6 will be updated
---> Package automake.noarch 0:1.11.1-4.el6 will be an update
---> Package coreutils.x86_64 0:8.4-19.el6 will be updated
--> Processing Dependency: coreutils = 8.4-19.el6 for package: coreutils-libs-8.4-19.el6.x86_64
---> Package coreutils.x86_64 0:8.4-31.el6_5.2 will be an update
---> Package cpp.x86_64 0:4.4.6-4.el6 will be updated
---> Package cpp.x86_64 0:4.4.7-4.el6 will be an update
---> Package e2fsprogs-devel.x86_64 0:1.41.12-12.el6 will be updated
---> Package e2fsprogs-devel.x86_64 0:1.41.12-18.el6_5.1 will be an update
--> Processing Dependency: libcom_err-devel = 1.41.12-18.el6_5.1 for package: e2fsprogs-devel-1.41.12-18.el6_5.1.x86_64
--> Processing Dependency: e2fsprogs-libs = 1.41.12-18.el6_5.1 for package: e2fsprogs-devel-1.41.12-18.el6_5.1.x86_64
---> Package gcc.x86_64 0:4.4.6-4.el6 will be updated
---> Package gcc.x86_64 0:4.4.7-4.el6 will be an update
--> Processing Dependency: libgomp = 4.4.7-4.el6 for package: gcc-4.4.7-4.el6.x86_64
--> Processing Dependency: libgcc >= 4.4.7-4.el6 for package: gcc-4.4.7-4.el6.x86_64
---> Package gcc-c++.x86_64 0:4.4.6-4.el6 will be updated
---> Package gcc-c++.x86_64 0:4.4.7-4.el6 will be an update
---> Package gd.x86_64 0:2.0.35-10.el6 will be updated
--> Processing Dependency: gd = 2.0.35-10.el6 for package: gd-devel-2.0.35-10.el6.x86_64
--> Processing Dependency: gd = 2.0.35-10.el6 for package: gd-progs-2.0.35-10.el6.x86_64
---> Package gd.x86_64 0:2.0.35-11.el6 will be an update
---> Package glibc-devel.x86_64 0:2.12-1.80.el6_3.6 will be updated
---> Package glibc-devel.x86_64 0:2.12-1.132.el6_5.3 will be an update
--> Processing Dependency: glibc-headers = 2.12-1.132.el6_5.3 for package: glibc-devel-2.12-1.132.el6_5.3.x86_64
--> Processing Dependency: glibc = 2.12-1.132.el6_5.3 for package: glibc-devel-2.12-1.132.el6_5.3.x86_64
---> Package krb5-devel.x86_64 0:1.9-33.el6_3.3 will be updated
---> Package krb5-devel.x86_64 0:1.10.3-15.el6_5.1 will be an update
--> Processing Dependency: krb5-libs = 1.10.3-15.el6_5.1 for package: krb5-devel-1.10.3-15.el6_5.1.x86_64
--> Processing Dependency: libkdb5.so.6()(64bit) for package: krb5-devel-1.10.3-15.el6_5.1.x86_64
---> Package libX11-devel.x86_64 0:1.3-2.el6 will be updated
---> Package libX11-devel.x86_64 0:1.5.0-4.el6 will be an update
--> Processing Dependency: libX11 = 1.5.0-4.el6 for package: libX11-devel-1.5.0-4.el6.x86_64
---> Package libXpm.x86_64 0:3.5.8-2.el6 will be updated
---> Package libXpm.x86_64 0:3.5.10-2.el6 will be an update
---> Package libXpm-devel.x86_64 0:3.5.8-2.el6 will be updated
---> Package libXpm-devel.x86_64 0:3.5.10-2.el6 will be an update
---> Package libjpeg-devel.x86_64 0:6b-46.el6 will be obsoleted
--> Processing Dependency: libjpeg-devel = 6b-46.el6 for package: libjpeg-static-6b-46.el6.x86_64
---> Package libjpeg-turbo-devel.x86_64 0:1.2.1-3.el6_5 will be obsoleting
--> Processing Dependency: libjpeg-turbo(x86-64) = 1.2.1-3.el6_5 for package: libjpeg-turbo-devel-1.2.1-3.el6_5.x86_64
---> Package libstdc++.x86_64 0:4.4.6-4.el6 will be updated
---> Package libstdc++.x86_64 0:4.4.7-4.el6 will be an update
---> Package libstdc++-devel.x86_64 0:4.4.6-4.el6 will be updated
---> Package libstdc++-devel.x86_64 0:4.4.7-4.el6 will be an update
---> Package pam-devel.x86_64 0:1.1.1-10.el6_2.1 will be updated
---> Package pam-devel.x86_64 0:1.1.1-17.el6 will be an update
--> Processing Dependency: pam = 1.1.1-17.el6 for package: pam-devel-1.1.1-17.el6.x86_64
--> Running transaction check
---> Package coreutils-libs.x86_64 0:8.4-19.el6 will be updated
---> Package coreutils-libs.x86_64 0:8.4-31.el6_5.2 will be an update
---> Package e2fsprogs-libs.x86_64 0:1.41.12-12.el6 will be updated
--> Processing Dependency: e2fsprogs-libs = 1.41.12-12.el6 for package: e2fsprogs-1.41.12-12.el6.x86_64
---> Package e2fsprogs-libs.x86_64 0:1.41.12-18.el6_5.1 will be an update
--> Processing Dependency: libcom_err = 1.41.12-18.el6_5.1 for package: e2fsprogs-libs-1.41.12-18.el6_5.1.x86_64
---> Package gd-devel.x86_64 0:2.0.35-10.el6 will be updated
---> Package gd-devel.x86_64 0:2.0.35-11.el6 will be an update
---> Package gd-progs.x86_64 0:2.0.35-10.el6 will be updated
---> Package gd-progs.x86_64 0:2.0.35-11.el6 will be an update
---> Package glibc.i686 0:2.12-1.80.el6_3.6 will be updated
--> Processing Dependency: glibc = 2.12-1.80.el6_3.6 for package: glibc-common-2.12-1.80.el6_3.6.x86_64
--> Processing Dependency: glibc = 2.12-1.80.el6_3.6 for package: glibc-devel-2.12-1.80.el6_3.6.i686
---> Package glibc.x86_64 0:2.12-1.80.el6_3.6 will be updated
--> Processing Dependency: glibc = 2.12-1.80.el6_3.6 for package: glibc-common-2.12-1.80.el6_3.6.x86_64
--> Processing Dependency: glibc = 2.12-1.80.el6_3.6 for package: glibc-devel-2.12-1.80.el6_3.6.i686
---> Package glibc.x86_64 0:2.12-1.107.el6 will be updated
--> Processing Dependency: glibc = 2.12-1.107.el6 for package: glibc-common-2.12-1.107.el6.x86_64
--> Processing Dependency: glibc = 2.12-1.107.el6 for package: glibc-devel-2.12-1.107.el6.i686
---> Package glibc.i686 0:2.12-1.132.el6_5.3 will be an update
---> Package glibc.x86_64 0:2.12-1.132.el6_5.3 will be an update
---> Package glibc-headers.x86_64 0:2.12-1.80.el6_3.6 will be updated
---> Package glibc-headers.x86_64 0:2.12-1.132.el6_5.3 will be an update
---> Package krb5-libs.x86_64 0:1.9-33.el6_3.3 will be updated
---> Package krb5-libs.x86_64 0:1.10.3-15.el6_5.1 will be an update
---> Package libX11.x86_64 0:1.3-2.el6 will be updated
---> Package libX11.x86_64 0:1.5.0-4.el6 will be an update
--> Processing Dependency: libX11-common = 1.5.0-4.el6 for package: libX11-1.5.0-4.el6.x86_64
---> Package libcom_err-devel.x86_64 0:1.41.12-12.el6 will be updated
---> Package libcom_err-devel.x86_64 0:1.41.12-18.el6_5.1 will be an update
---> Package libgcc.i686 0:4.4.6-4.el6 will be updated
---> Package libgcc.x86_64 0:4.4.6-4.el6 will be updated
---> Package libgcc.i686 0:4.4.7-4.el6 will be an update
---> Package libgcc.x86_64 0:4.4.7-4.el6 will be an update
---> Package libgomp.x86_64 0:4.4.6-4.el6 will be updated
---> Package libgomp.x86_64 0:4.4.7-4.el6 will be an update
---> Package libjpeg.x86_64 0:6b-46.el6 will be obsoleted
---> Package libjpeg-static.x86_64 0:6b-46.el6 will be obsoleted
---> Package libjpeg-turbo.x86_64 0:1.2.1-3.el6_5 will be obsoleting
---> Package libjpeg-turbo-static.x86_64 0:1.2.1-3.el6_5 will be obsoleting
---> Package pam.x86_64 0:1.1.1-10.el6_2.1 will be updated
---> Package pam.x86_64 0:1.1.1-17.el6 will be an update
--> Running transaction check
---> Package e2fsprogs.x86_64 0:1.41.12-12.el6 will be updated
---> Package e2fsprogs.x86_64 0:1.41.12-18.el6_5.1 will be an update
--> Processing Dependency: libss = 1.41.12-18.el6_5.1 for package: e2fsprogs-1.41.12-18.el6_5.1.x86_64
---> Package glibc.i686 0:2.12-1.80.el6_3.6 will be updated
---> Package glibc.x86_64 0:2.12-1.80.el6_3.6 will be updated
---> Package glibc-common.x86_64 0:2.12-1.80.el6_3.6 will be updated
---> Package glibc-common.x86_64 0:2.12-1.107.el6 will be updated
---> Package glibc-common.x86_64 0:2.12-1.132.el6_5.3 will be an update
---> Package glibc-devel.i686 0:2.12-1.80.el6_3.6 will be updated
--> Processing Dependency: glibc-devel = 2.12-1.80.el6_3.6 for package: glibc-static-2.12-1.80.el6_3.6.x86_64
---> Package glibc-devel.i686 0:2.12-1.107.el6 will be updated
--> Processing Dependency: glibc-devel = 2.12-1.107.el6 for package: glibc-static-2.12-1.107.el6.x86_64
---> Package glibc-devel.i686 0:2.12-1.132.el6_5.3 will be an update
---> Package libX11-common.noarch 0:1.3-2.el6 will be updated
---> Package libX11-common.noarch 0:1.5.0-4.el6 will be an update
---> Package libcom_err.x86_64 0:1.41.12-12.el6 will be updated
---> Package libcom_err.x86_64 0:1.41.12-18.el6_5.1 will be an update
--> Running transaction check
---> Package glibc-devel.i686 0:2.12-1.80.el6_3.6 will be updated
---> Package glibc-static.x86_64 0:2.12-1.80.el6_3.6 will be updated
---> Package glibc-static.x86_64 0:2.12-1.107.el6 will be updated
---> Package glibc-static.x86_64 0:2.12-1.132.el6_5.3 will be an update
---> Package libss.x86_64 0:1.41.12-12.el6 will be updated
---> Package libss.x86_64 0:1.41.12-18.el6_5.1 will be an update
--> Finished Dependency Resolution
Error: Package: glibc-devel-2.12-1.80.el6_3.6.i686 (@updates)
           Requires: glibc = 2.12-1.80.el6_3.6
           Removing: glibc-2.12-1.80.el6_3.6.i686 (@updates)
               glibc = 2.12-1.80.el6_3.6
           Updated By: glibc-2.12-1.132.el6_5.3.i686 (updates)
               glibc = 2.12-1.132.el6_5.3
           Removing: glibc-2.12-1.107.el6.x86_64 (installed)
               glibc = 2.12-1.107.el6
           Updated By: glibc-2.12-1.132.el6_5.3.x86_64 (updates)
               glibc = 2.12-1.132.el6_5.3
           Available: glibc-2.12-1.132.el6.i686 (base)
               glibc = 2.12-1.132.el6
           Available: glibc-2.12-1.132.el6_5.1.i686 (updates)
               glibc = 2.12-1.132.el6_5.1
           Available: glibc-2.12-1.132.el6_5.2.i686 (updates)
               glibc = 2.12-1.132.el6_5.2
Error: Package: glibc-static-2.12-1.80.el6_3.6.x86_64 (@updates)
           Requires: glibc-devel = 2.12-1.80.el6_3.6
           Removing: glibc-devel-2.12-1.80.el6_3.6.i686 (@updates)
               glibc-devel = 2.12-1.80.el6_3.6
           Updated By: glibc-devel-2.12-1.132.el6_5.3.i686 (updates)
               glibc-devel = 2.12-1.132.el6_5.3
           Removing: glibc-devel-2.12-1.107.el6.i686 (installed)
               glibc-devel = 2.12-1.107.el6
           Updated By: glibc-devel-2.12-1.132.el6_5.3.i686 (updates)
               glibc-devel = 2.12-1.132.el6_5.3
           Available: glibc-devel-2.12-1.132.el6.i686 (base)
               glibc-devel = 2.12-1.132.el6
           Available: glibc-devel-2.12-1.132.el6_5.1.i686 (updates)
               glibc-devel = 2.12-1.132.el6_5.1
           Available: glibc-devel-2.12-1.132.el6_5.2.i686 (updates)
               glibc-devel = 2.12-1.132.el6_5.2
Error: Package: glibc-common-2.12-1.80.el6_3.6.x86_64 (@updates)
           Requires: glibc = 2.12-1.80.el6_3.6
           Removing: glibc-2.12-1.80.el6_3.6.i686 (@updates)
               glibc = 2.12-1.80.el6_3.6
           Updated By: glibc-2.12-1.132.el6_5.3.i686 (updates)
               glibc = 2.12-1.132.el6_5.3
           Removing: glibc-2.12-1.107.el6.x86_64 (installed)
               glibc = 2.12-1.107.el6
           Updated By: glibc-2.12-1.132.el6_5.3.x86_64 (updates)
               glibc = 2.12-1.132.el6_5.3
           Available: glibc-2.12-1.132.el6.i686 (base)
               glibc = 2.12-1.132.el6
           Available: glibc-2.12-1.132.el6_5.1.i686 (updates)
               glibc = 2.12-1.132.el6_5.1
           Available: glibc-2.12-1.132.el6_5.2.i686 (updates)
               glibc = 2.12-1.132.el6_5.2
 You could try using --skip-broken to work around the problem
** Found 53 pre-existing rpmdb problem(s), 'yum check' output follows:
alsa-lib-devel-1.0.22-3.el6.x86_64 has missing requires of alsa-lib = ('0', '1.0.22', '3.el6')
alsa-lib-devel-1.0.22-3.el6.x86_64 has missing requires of libasound.so.2()(64bit)
alsa-plugins-pulseaudio-1.0.21-3.el6.x86_64 has missing requires of libasound.so.2()(64bit)
alsa-plugins-pulseaudio-1.0.21-3.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit)
alsa-utils-1.0.22-3.el6.x86_64 has missing requires of libasound.so.2()(64bit)
alsa-utils-1.0.22-3.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit)
alsa-utils-1.0.22-3.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0rc4)(64bit)
alsa-utils-1.0.22-3.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0rc8)(64bit)
8:arts-1.5.10-10.el6.x86_64 has missing requires of libasound.so.2()(64bit)
8:arts-1.5.10-10.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit)
1:control-center-2.28.1-37.el6.x86_64 has missing requires of alsa-lib
1:esound-libs-0.2.41-3.1.el6.x86_64 has missing requires of libasound.so.2()(64bit)
1:esound-libs-0.2.41-3.1.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit)
1:esound-libs-0.2.41-3.1.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0rc4)(64bit)
frontpage-2002-SR1.2.i386 has missing requires of libexpat.so.0
git-1.6.2.2-1.el5.kb.x86_64 has missing requires of libcrypto.so.6()(64bit)
git-1.6.2.2-1.el5.kb.x86_64 has missing requires of libcurl.so.3()(64bit)
git-1.6.2.2-1.el5.kb.x86_64 has missing requires of libexpat.so.0()(64bit)
git-1.6.2.2-1.el5.kb.x86_64 has missing requires of libssl.so.6()(64bit)
git-1.6.2.2-1.el5.kb.x86_64 has missing requires of perl(Error)
git-1.6.2.2-1.el5.kb.x86_64 has missing requires of perl(Git)
git-1.6.2.2-1.el5.kb.x86_64 has missing requires of perl-Git = ('0', '1.6.2.2', '1.el5.kb')
glibc-2.12-1.107.el6.x86_64 is a duplicate with glibc-2.12-1.80.el6_3.6.x86_64
glibc-common-2.12-1.107.el6.x86_64 is a duplicate with glibc-common-2.12-1.80.el6_3.6.x86_64
glibc-devel-2.12-1.107.el6.i686 is a duplicate with glibc-devel-2.12-1.80.el6_3.6.x86_64
glibc-devel-2.12-1.107.el6.i686 has missing requires of glibc-headers = ('0', '2.12', '1.107.el6')
glibc-static-2.12-1.107.el6.x86_64 is a duplicate with glibc-static-2.12-1.80.el6_3.6.x86_64
gstreamer-plugins-base-0.10.29-1.el6.x86_64 has missing requires of libasound.so.2()(64bit)
gstreamer-plugins-base-0.10.29-1.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit)
gstreamer-plugins-base-0.10.29-1.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0rc4)(64bit)
libcanberra-0.22-1.el6.centos.x86_64 has missing requires of libasound.so.2()(64bit)
libcanberra-0.22-1.el6.centos.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit)
libcanberra-0.22-1.el6.centos.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0rc4)(64bit)
libgcj-4.4.6-4.el6.x86_64 has missing requires of libasound.so.2()(64bit)
libgcj-4.4.6-4.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit)
libsndfile-1.0.20-5.el6.x86_64 has missing requires of libasound.so.2()(64bit)
libsndfile-1.0.20-5.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit)
libsndfile-1.0.20-5.el6.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0rc4)(64bit)
mencoder-1.0-0.47.svn20100703.el6.rf.x86_64 has missing requires of libasound.so.2()(64bit)
mencoder-1.0-0.47.svn20100703.el6.rf.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit)
mencoder-1.0-0.47.svn20100703.el6.rf.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0rc4)(64bit)
mpg123-1.14.4-1.el6.rf.x86_64 has missing requires of libasound.so.2()(64bit)
mpg123-1.14.4-1.el6.rf.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit)
mpg123-1.14.4-1.el6.rf.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0rc4)(64bit)
mplayer-1.0-0.47.svn20100703.el6.rf.x86_64 has missing requires of libasound.so.2()(64bit)
mplayer-1.0-0.47.svn20100703.el6.rf.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit)
mplayer-1.0-0.47.svn20100703.el6.rf.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0rc4)(64bit)
mplayer-1.0-0.47.svn20100703.el6.rf.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0rc8)(64bit)
pulseaudio-0.9.21-14.el6_3.x86_64 has missing requires of libasound.so.2()(64bit)
pulseaudio-0.9.21-14.el6_3.x86_64 has missing requires of libasound.so.2(ALSA_0.9)(64bit)
pulseaudio-0.9.21-14.el6_3.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0rc4)(64bit)
pulseaudio-0.9.21-14.el6_3.x86_64 has missing requires of libasound.so.2(ALSA_0.9.0rc8)(64bit)
xulrunner-10.0.12-1.el6.centos.x86_64 has missing requires of libasound.so.2()(64bit)
[email protected] [~]#
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,248
363
Hello

The issue is that your system package manager (YUM) is unable to update successfully due to multiple installations of the same RPM. You will need to remove the duplicate RPMs while ensuring the dependencies are not removed (--nodeps flag). You may want to get assistance with this from your data center or hosting provider as removing the wrong RPM can result is OS-level errors.

Thank you.
 

eManuka

Member
Aug 19, 2014
5
0
1
cPanel Access Level
Root Administrator
Hello

The issue is that your system package manager (YUM) is unable to update successfully due to multiple installations of the same RPM. You will need to remove the duplicate RPMs while ensuring the dependencies are not removed (--nodeps flag). You may want to get assistance with this from your data center or hosting provider as removing the wrong RPM can result is OS-level errors.

Thank you.
I already contacted DATA center and they said they cannot help with that since they only provide hardware support. can you tell me how to fix this issue?

Thanks
 

SS-Maddy

Well-Known Member
Mar 28, 2009
122
13
68
cPanel Access Level
Root Administrator
Hello

Remove the package from the local RPM database to trick yum into reinstalling the package. Please note that no files are deleted when using rpm -e with –justdb.

So here is what you have to do, to reinstall a openssh-server.

[[email protected] home]# rpm -qV openssh-server.x86_64
S.5....T c /etc/pam.d/sshd
S.5....T c /etc/ssh/sshd_config

[[email protected] home]# rpm -e --justdb --nodeps openssh-server.x86_64

[[email protected] home]# yum install openssh-server.x86_64

Make sure to replace the package name as per your requirement.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,248
363
I highly suggest consulting with a qualified system administrator to assist you with your system package issues. While it's certainly possible you could have someone provide you with the commands to copy and paste, it's risky to do this if you are not familiar with YUM or Linux. You could remove the wrong package and your system could become unusable.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,248
363
Would you mind sharing the ticket number so we can update this thread with the solution?

Thank you.