The server's system package manager, 'YUM', failed

mahmutyum

Registered
May 19, 2014
1
0
1
cPanel Access Level
DataCenter Provider
Code:
Package cpp-4.4.7-16.el6.x86_64 already installed and latest version
No package xorg-x11-dev available.
Package gcc-4.4.7-16.el6.x86_64 already installed and latest version
Package 1:enchant-1.5.0-5.el6.x86_64 already installed and latest version
No package ssl-dev available.
No package lex available.
Package autoconf-2.63-5.1.el6.noarch already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package coreutils.x86_64 0:8.4-31.el6_5.2 will be updated
---> Package coreutils.x86_64 0:8.4-37.el6 will be an update
--> Finished Dependency Resolution
Total download size: 3.0 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
[1;30;41mError unpacking rpm package coreutils-8.4-37.el6.x86_64[0m
  Updating   : coreutils-8.4-37.el6.x86_64                                  1/2
[1;30;41mcoreutils-8.4-31.el6_5.2.x86_64 was supposed to be removed but is not![0m
  Updating   : coreutils-8.4-37.el6.x86_64                                  1/2   Verifying  : coreutils-8.4-31.el6_5.2.x86_64                              1/2
  Updating   : coreutils-8.4-37.el6.x86_64                                  1/2   Verifying  : coreutils-8.4-31.el6_5.2.x86_64                              1/2
  Updating   : coreutils-8.4-37.el6.x86_64                                  1/2   Verifying  : coreutils-8.4-31.el6_5.2.x86_64                              1/2Complete!
  Updating   : coreutils-8.4-37.el6.x86_64                                  1/2   Verifying  : coreutils-8.4-31.el6_5.2.x86_64                              1/2
[1;30;41mThe system failed to execute yum with the arguments “-y -c /etc/yum.conf install aspell aspell-devel automake19 gettext libstdc++.x86_64 libpng-devel readline-devel openssl libpng-dev zlib-devel openldap23-client autoconf261 libidn-devel gmake libidn libXpm openssl-devel automake coreutils patch libltdl3-devel libltdl libopenssl0.9.7-static-devel readline-dev icu-dev libtool-ltdl-devel libicu sed libXpm-devel lsof libXpm-dev libenchant-dev enchant-devel krb5-dev flex glibc-dev expat-dev krb5-devel enchant-dev pspell-devel libstdc++-devel.x64_64 xorg-x11-devel libtool-ltdl libssl-dev bzip2-devel pam-devel icu-devel libenchant-devel libopenssl0-devel zlib1-devel openldap-devel expat-devel libicu-dev libopenssl0-dev pspell gcc-c++ expat glibc-devel libenchant zlib distcache-devel libicu-devel bison libjpeg-devel libtool-libltdl-devel libopenssl0 openssl-dev libtool libz-devel bzip2-libs libjpeg-dev pam-dev libopenssl0.9.7-devel fileutils libltdl-devel e2fsprogs-devel icu ca_root_nss make libstdc++-dev.x86_64 libX11-devel openldap-client libstdc++-devel.x86_64 gd cpp xorg-x11-dev gcc enchant ssl-dev lex autoconf” because of an error: The subprocess “/usr/bin/yum” reported the “EPERM” (1) error when it ended. : Error unpacking rpm package coreutils-8.4-37.el6.x86_64[0m
[1;30;41mcoreutils-8.4-31.el6_5.2.x86_64 was supposed to be removed but is not![0m
Use of uninitialized value $args[1] in substitution iterator at /usr/local/cpanel/Cpanel/CPAN/Locale/Maketext/Pseudo.pm line 63.
Loaded plugins: fastestmirror, security
Setting up Install Process
Loading mirror speeds from cached hostfile
* base: mirrors.ircam.fr
* extras: mirror.w2k.ch
* rpmforge: mirrors.ircam.fr
* updates: mirror.w2k.ch
Package 12:aspell-0.60.6-12.el6.x86_64 already installed and latest version
Package 12:aspell-devel-0.60.6-12.el6.x86_64 already installed and latest version
No package automake19 available.
Package gettext-0.17-18.el6.x86_64 already installed and latest version
Package libstdc++-4.4.7-16.el6.x86_64 already installed and latest version
Package 2:libpng-devel-1.2.49-1.el6_2.x86_64 already installed and latest version
Package readline-devel-6.0-4.el6.x86_64 already installed and latest version
Package openssl-1.0.1e-42.el6.x86_64 already installed and latest version
No package libpng-dev available.
Package zlib-devel-1.2.3-29.el6.x86_64 already installed and latest version
No package openldap23-client available.
No package autoconf261 available.
Package libidn-devel-1.18-2.el6.x86_64 already installed and latest version
No package gmake available.
Package libidn-1.18-2.el6.x86_64 already installed and latest version
Package libXpm-3.5.10-2.el6.x86_64 already installed and latest version
Package openssl-devel-1.0.1e-42.el6.x86_64 already installed and latest version
Package automake-1.11.1-4.el6.noarch already installed and latest version
Package patch-2.6-6.el6.x86_64 already installed and latest version
No package libltdl3-devel available.
No package libltdl available.
No package libopenssl0.9.7-static-devel available.
No package readline-dev available.
No package icu-dev available.
Package libtool-ltdl-devel-2.2.6-15.5.el6.x86_64 already installed and latest version
Package libicu-4.2.1-12.el6.x86_64 already installed and latest version
Package sed-4.2.1-10.el6.x86_64 already installed and latest version
Package libXpm-devel-3.5.10-2.el6.x86_64 already installed and latest version
Package lsof-4.82-5.el6.x86_64 already installed and latest version
No package libXpm-dev available.
No package libenchant-dev available.
Package 1:enchant-devel-1.5.0-5.el6.x86_64 already installed and latest version
No package krb5-dev available.
Package flex-2.5.35-9.el6.x86_64 already installed and latest version
No package glibc-dev available.
No package expat-dev available.
Package krb5-devel-1.10.3-42.el6.x86_64 already installed and latest version
No package enchant-dev available.
No package pspell-devel available.
No package libstdc++-devel.x64_64 available.
No package xorg-x11-devel available.
Package libtool-ltdl-2.2.6-15.5.el6.x86_64 already installed and latest version
No package libssl-dev available.
Package bzip2-devel-1.0.5-7.el6_0.x86_64 already installed and latest version
Package pam-devel-1.1.1-20.el6_7.1.x86_64 already installed and latest version
No package icu-devel available.
No package libenchant-devel available.
No package libopenssl0-devel available.
No package zlib1-devel available.
Package openldap-devel-2.4.40-6.el6_7.x86_64 already installed and latest version
Package expat-devel-2.0.1-11.el6_2.x86_64 already installed and latest version
No package libicu-dev available.
No package libopenssl0-dev available.
No package pspell available.
Package gcc-c++-4.4.7-16.el6.x86_64 already installed and latest version
Package expat-2.0.1-11.el6_2.x86_64 already installed and latest version
Package glibc-devel-2.12-1.166.el6_7.3.x86_64 already installed and latest version
No package libenchant available.
Package zlib-1.2.3-29.el6.x86_64 already installed and latest version
No package distcache-devel available.
Package libicu-devel-4.2.1-12.el6.x86_64 already installed and latest version
Package bison-2.4.1-5.el6.x86_64 already installed and latest version
Package libjpeg-turbo-devel-1.2.1-3.el6_5.x86_64 already installed and latest version
No package libtool-libltdl-devel available.
No package libopenssl0 available.
No package openssl-dev available.
Package libtool-2.2.6-15.5.el6.x86_64 already installed and latest version
No package libz-devel available.
Package bzip2-libs-1.0.5-7.el6_0.x86_64 already installed and latest version
No package libjpeg-dev available.
No package pam-dev available.
No package libopenssl0.9.7-devel available.
No package libltdl-devel available.
Package e2fsprogs-devel-1.41.12-22.el6.x86_64 already installed and latest version
Package icu-4.2.1-12.el6.x86_64 already installed and latest version
No package ca_root_nss available.
Package 1:make-3.81-20.el6.x86_64 already installed and latest version
No package libstdc++-dev.x86_64 available.
Package libX11-devel-1.6.0-6.el6.x86_64 already installed and latest version
No package openldap-client available.
Package libstdc++-devel-4.4.7-16.el6.x86_64 already installed and latest version
Package gd-2.0.35-11.el6.x86_64 already installed and latest version
Package cpp-4.4.7-16.el6.x86_64 already installed and latest version
No package xorg-x11-dev available.
Package gcc-4.4.7-16.el6.x86_64 already installed and latest version
Package 1:enchant-1.5.0-5.el6.x86_64 already installed and latest version
No package ssl-dev available.
No package lex available.
Package autoconf-2.63-5.1.el6.noarch already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package coreutils.x86_64 0:8.4-31.el6_5.2 will be updated
---> Package coreutils.x86_64 0:8.4-37.el6 will be an update
--> Finished Dependency Resolution
Total download size: 3.0 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
[1;30;41mError unpacking rpm package coreutils-8.4-37.el6.x86_64[0m
  Updating   : coreutils-8.4-37.el6.x86_64                                  1/2
[1;30;41mcoreutils-8.4-31.el6_5.2.x86_64 was supposed to be removed but is not![0m
  Updating   : coreutils-8.4-37.el6.x86_64                                  1/2   Verifying  : coreutils-8.4-31.el6_5.2.x86_64                              1/2
  Updating   : coreutils-8.4-37.el6.x86_64                                  1/2   Verifying  : coreutils-8.4-31.el6_5.2.x86_64                              1/2
  Updating   : coreutils-8.4-37.el6.x86_64                                  1/2   Verifying  : coreutils-8.4-31.el6_5.2.x86_64                              1/2Complete!
  Updating   : coreutils-8.4-37.el6.x86_64                                  1/2   Verifying  : coreutils-8.4-31.el6_5.2.x86_64                              1/2
[1;30;41mThe system failed to execute yum with the arguments “-y -c /etc/yum.conf install aspell aspell-devel automake19 gettext libstdc++.x86_64 libpng-devel readline-devel openssl libpng-dev zlib-devel openldap23-client autoconf261 libidn-devel gmake libidn libXpm openssl-devel automake coreutils patch libltdl3-devel libltdl libopenssl0.9.7-static-devel readline-dev icu-dev libtool-ltdl-devel libicu sed libXpm-devel lsof libXpm-dev libenchant-dev enchant-devel krb5-dev flex glibc-dev expat-dev krb5-devel enchant-dev pspell-devel libstdc++-devel.x64_64 xorg-x11-devel libtool-ltdl libssl-dev bzip2-devel pam-devel icu-devel libenchant-devel libopenssl0-devel zlib1-devel openldap-devel expat-devel libicu-dev libopenssl0-dev pspell gcc-c++ expat glibc-devel libenchant zlib distcache-devel libicu-devel bison libjpeg-devel libtool-libltdl-devel libopenssl0 openssl-dev libtool libz-devel bzip2-libs libjpeg-dev pam-dev libopenssl0.9.7-devel fileutils libltdl-devel e2fsprogs-devel icu ca_root_nss make libstdc++-dev.x86_64 libX11-devel openldap-client libstdc++-devel.x86_64 gd cpp xorg-x11-dev gcc enchant ssl-dev lex autoconf” because of an error: The subprocess “/usr/bin/yum” reported the “EPERM” (1) error when it ended. : Error unpacking rpm package coreutils-8.4-37.el6.x86_64[0m
[1;30;41mcoreutils-8.4-31.el6_5.2.x86_64 was supposed to be removed but is not![0m
!! ensure() rc was '0', exit status was '', perl '$?' was '0', exit sig '0', core dump: '0', shell '$?' was '0' !!

!! Simulating failed Cpanel::SysPkgs as per 'simulate-failed-syspkgs' flag !!

!! Could not ensure pkglist 'aspell, aspell-devel, automake19, gettext, libstdc++.x86_64, libpng-devel, readline-devel, openssl, libpng-dev, zlib-devel, openldap23-client, autoconf261, libidn-devel, gmake, libidn, libXpm, openssl-devel, automake, coreutils, patch, libltdl3-devel, libltdl, libopenssl0.9.7-static-devel, readline-dev, icu-dev, libtool-ltdl-devel, libicu, sed, libXpm-devel, lsof, libXpm-dev, libenchant-dev, enchant-devel, krb5-dev, flex, glibc-dev, expat-dev, krb5-devel, enchant-dev, pspell-devel, libstdc++-devel.x64_64, xorg-x11-devel, libtool-ltdl, libssl-dev, bzip2-devel, pam-devel, icu-devel, libenchant-devel, libopenssl0-devel, zlib1-devel, openldap-devel, expat-devel, libicu-dev, libopenssl0-dev, pspell, gcc-c++, expat, glibc-devel, libenchant, zlib, distcache-devel, libicu-devel, bison, libjpeg-devel, libtool-libltdl-devel, libopenssl0, openssl-dev, libtool, libz-devel, bzip2-libs, libjpeg-dev, pam-dev, libopenssl0.9.7-devel, fileutils, libltdl-devel, e2fsprogs-devel, icu, ca_root_nss, make, libstdc++-dev.x86_64, libX11-devel, openldap-client, libstdc++-devel.x86_64, gd, cpp, xorg-x11-dev, gcc, enchant, ssl-dev, lex, autoconf' !!
!! The server's system package manager, 'YUM', failed. !!

!! direct ensure() call will be used (does not support get_command_arrayref_only): pkglist = 'aspell aspell-devel automake19 gettext libstdc++.x86_64 libpng-devel readline-devel openssl libpng-dev zlib-devel openldap23-client autoconf261 libidn-devel gmake libidn libXpm openssl-devel automake coreutils patch libltdl3-devel libltdl libopenssl0.9.7-static-devel readline-dev icu-dev libtool-ltdl-devel libicu sed libXpm-devel lsof libXpm-dev libenchant-dev enchant-devel krb5-dev flex glibc-dev expat-dev krb5-devel enchant-dev pspell-devel libstdc++-devel.x64_64 xorg-x11-devel libtool-ltdl libssl-dev bzip2-devel pam-devel icu-devel libenchant-devel libopenssl0-devel zlib1-devel openldap-devel expat-devel libicu-dev libopenssl0-dev pspell gcc-c++ expat glibc-devel libenchant zlib distcache-devel libicu-devel bison libjpeg-devel libtool-libltdl-devel libopenssl0 openssl-dev libtool libz-devel bzip2-libs libjpeg-dev pam-dev libopenssl0.9.7-devel fileutils libltdl-devel e2fsprogs-devel icu ca_root_nss make libstdc++-dev.x86_64 libX11-devel openldap-client libstdc++-devel.x86_64 gd cpp xorg-x11-dev gcc enchant ssl-dev lex autoconf' !!

!! Please visit http://go.cpanel.net/eaerror for help with this error. !!

!! Restoring original working apache !!

!! Executing '/usr/local/cpanel/scripts/initsslhttpd' !!
!! Restarting 'httpd' ... !!
!! 'httpd' restart complete. !!
Building global cache for cpanel...Done
!! Executing '/usr/local/cpanel/scripts/initfpsuexec' !!
!! Executing '/usr/local/cpanel/scripts/initsslhttpd' !!
!! Executing '/usr/local/cpanel/scripts/fixmailman' !!
!! Executing '/usr/local/cpanel/scripts/update_apachectl' !!
Compiling report...
Sending report. As some of the attached files may be quite large, this could take a few minutes. Thanks for your patience.
I need to update with easyapache. I take error. What is problem?

I tested yum update but ı take error.
Code:
---> Package yum-plugin-security.noarch 0:1.1.30-17.el6_5 will be updated
---> Package yum-plugin-security.noarch 0:1.1.30-30.el6 will be an update
---> Package zsh.x86_64 0:4.3.10-9.el6 will be updated
---> Package zsh.x86_64 0:4.3.11-4.el6.centos will be an update
--> Running transaction check
---> Package GConf2.x86_64 0:2.28.0-6.el6 will be installed
--> Processing Dependency: libORBit-2.so.0()(64bit) for package: GConf2-2.28.0-6.el6.x86_64
---> Package abrt-python.x86_64 0:2.0.8-34.el6.centos will be installed
--> Processing Dependency: pygobject2 for package: abrt-python-2.0.8-34.el6.centos.x86_64
---> Package augeas-libs.x86_64 0:1.0.0-10.el6 will be installed
---> Package gdk-pixbuf2.x86_64 0:2.24.1-6.el6_7 will be installed
---> Package jakarta-commons-httpclient.x86_64 1:3.1-0.9.el6_5 will be installed
---> Package json-c.x86_64 0:0.11-12.el6 will be installed
---> Package libbasicobjects.x86_64 0:0.1.1-11.el6 will be installed
---> Package libreport-filesystem.x86_64 0:2.0.9-24.el6.centos will be installed
---> Package libreport-plugin-ureport.x86_64 0:2.0.9-24.el6.centos will be installed
---> Package mod_wsgi.x86_64 0:3.2-7.el6 will be an update
--> Processing Dependency: httpd-mmn = 20051115 for package: mod_wsgi-3.2-7.el6.x86_64
---> Package pcsc-lite-libs.x86_64 0:1.5.2-15.el6 will be installed
---> Package python-argparse.noarch 0:1.2.1-2.1.el6 will be installed
---> Package python-dmidecode.x86_64 0:3.10.13-3.el6_4 will be installed
---> Package python-sssdconfig.noarch 0:1.12.4-47.el6 will be installed
---> Package satyr.x86_64 0:0.16-2.el6 will be installed
---> Package sssd-ad.x86_64 0:1.12.4-47.el6 will be installed
---> Package sssd-common-pac.x86_64 0:1.12.4-47.el6 will be installed
---> Package sssd-ipa.x86_64 0:1.12.4-47.el6 will be installed
---> Package sssd-krb5.x86_64 0:1.12.4-47.el6 will be installed
---> Package sssd-krb5-common.x86_64 0:1.12.4-47.el6 will be installed
---> Package sssd-ldap.x86_64 0:1.12.4-47.el6 will be installed
---> Package sssd-proxy.x86_64 0:1.12.4-47.el6 will be installed
---> Package vim-filesystem.x86_64 2:7.4.629-5.el6 will be installed
--> Running transaction check
---> Package ORBit2.x86_64 0:2.14.17-5.el6 will be installed
--> Processing Dependency: libIDL-2.so.0()(64bit) for package: ORBit2-2.14.17-5.el6.x86_64
---> Package mod_wsgi.x86_64 0:3.2-7.el6 will be an update
--> Processing Dependency: httpd-mmn = 20051115 for package: mod_wsgi-3.2-7.el6.x86_64
---> Package pygobject2.x86_64 0:2.20.0-5.el6 will be installed
--> Running transaction check
---> Package libIDL.x86_64 0:0.8.13-2.1.el6 will be installed
---> Package mod_wsgi.x86_64 0:3.2-7.el6 will be an update
--> Processing Dependency: httpd-mmn = 20051115 for package: mod_wsgi-3.2-7.el6.x86_64
--> Finished Dependency Resolution
Error: Package: mod_wsgi-3.2-7.el6.x86_64 (base)
           Requires: httpd-mmn = 20051115
You could try using --skip-broken to work around the problem
** Found 7 pre-existing rpmdb problem(s), 'yum check' output follows:
axis-1.2.1-7.3.el6_3.noarch has missing requires of jakarta-commons-httpclient
coreutils-8.4-31.el6_5.2.x86_64 has missing requires of coreutils-libs = ('0', '8.4', '31.el6_5.2')
coreutils-libs-8.4-37.el6.x86_64 has missing requires of coreutils = ('0', '8.4', '37.el6')
1:mod_ssl-2.2.15-31.el6.centos.x86_64 has missing requires of httpd = ('0', '2.2.15', '31.el6.centos')
1:mod_ssl-2.2.15-31.el6.centos.x86_64 has missing requires of httpd-mmn = ('0', '20051115', None)
mod_wsgi-3.2-6.el6_5.x86_64 has missing requires of httpd-mmn = ('0', '20051115', None)
webalizer-2.21_02-3.3.el6.x86_64 has missing requires of httpd
I need help.
 

zmenchhofer

Member
Jun 16, 2004
14
0
151
i just got a very similar error in easyapache.


--> Finished Dependency Resolution
Error: Multilib version problems found. This often means that the root
The system failed to execute yum with the arguments â-y -c /etc/yum.conf install gettext automake19 libstdc++.x86_64 libpng-devel readline-devel openssl libpng-dev zlib-devel openldap23-client autoconf261 libidn-devel gmake libidn libXpm openssl-devel automake coreutils patch libltdl3-devel libltdl libopenssl0.9.7-static-devel readline-dev libtool-ltdl-devel sed libXpm-devel libXpm-dev lsof krb5-dev flex glibc-dev expat-dev krb5-devel libstdc++-devel.x64_64 libcap-devel xorg-x11-devel libtool-ltdl libssl-dev pam-devel libopenssl0-devel zlib1-devel openldap-devel expat-devel libopenssl0-dev gcc-c++ expat glibc-devel zlib bison libjpeg-devel libtool-libltdl-devel snmp-devel libtool openssl-dev libopenssl0 libz-devel libjpeg-dev pam-dev net-snmp-devel fileutils libltdl-devel libopenssl0.9.7-devel e2fsprogs-devel ca_root_nss libcap make libstdc++-dev.x86_64 libX11-devel openldap-client libstdc++-devel.x86_64 gd net-snmp cpp xorg-x11-dev gcc ssl-dev lex autoconfâ/usr/bin/yumâEPERMâ
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,917
2,246
363
--> Processing Dependency: httpd-mmn = 20051115 for package: mod_wsgi-3.2-7.el6.x86_64
Hello :)

The packages referenced in the error message you provided are not required. Apache is installed through EasyApache (as of EA version 3), so the "httpd" package is not required, nor are any of the packages associated with it. You can remove these packages to ensure "yum update" finishes successfully.

Error: Multilib version problems found. This often means that the root
What's the specific error message that YUM ends at?

Thank you.