The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

The service “httpd” appears to be down.

Discussion in 'General Discussion' started by HKjohn, Oct 2, 2016.

  1. HKjohn

    HKjohn Registered

    Joined:
    Oct 2, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Hong Kong
    cPanel Access Level:
    Root Administrator
    Noobie here and any help would be welcomed as i searched high and low and cant seem to find anything related to my error. I just set up Cpanel on AWS and after i get the same email notice very 1 minute for 3 days in a row, and i cant figure out whats wrong. This is the email error:

    Code:
    The service “httpd” appears to be down.
    Server host.example.com
    Primary IPAddress 10.0.0.8
    Service Name httpd
    Service Status failed 
    Notification The service “httpd” appears to be down.
    Service Check Method The system failed to connect to this service’s TCP/IP port.
    Reason Unable to connect to port 80 on 127.0.0.1: Connection refused: Died
    Number of Restart Attempts 620
    Startup Log No startup log
    Memory Information
    Used 272 MB
    Available 723 MB
    Installed 995 MB
    Load Information 0.08 0.10 0.10
    Uptime 2 days, 16 hours, 48 minutes, and 57 seconds
    IOStat Information avg-cpu: %user %nice %system %iowait %steal %idle 1.40 0.07 0.18 0.14 0.01 98.20 Device: tps Blk_read/s Blk_wrtn/s Blk_read Blk_wrtn xvda 3.70 132.54 88.47 30908945 20631400 loop0 0.00 0.01 0.00 1312 4
    Top Processes
    PID Owner CPU% Memory % Command
    21209 root 6.45 3.53 tailwatchd - chkservd - ftpd check
    21236 root 4.44 0.96 /usr/local/cpanel/scripts/restartsrv_pureftpd --check --notconfigured-ok
    20994 root 0.41 0.47 spamd-dormant: waiting for connections --max-spare=1 --max-children=3 --allowed-ips=127.0.0.1,::1 --pidfile=/var/run/spamd.pid --listen=5,6
    32765 mysql 0.02 4.36 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib64/mysql/plugin --user=mysql --log-error=/var/lib/mysql/host.example.com.err --open-files-limit=10000 --pid-file=/var/lib/mysql/host.example.com.pid
    1673 root 0.00 2.68 tailwatchd
    The chkservd process attempts to connect to “127.0.0.1:80” in order to validate that this service is functioning. If you blocked connections with iptables or the “Host Access Control” interface in WHM, this failure may be a false positive.
    
    To resolve this issue, either open the firewall to allow connections as the root user to “127.0.0.1:80” or disable checks for this service in WHM’s “Service Manager” interface with the “Configure Monitor Settings” link below.
    
    Configure Monitor Settings:
    https://host.example.com:2087/scripts/srvmng#service-chkservd
    
    Configure chkservd:
    https://host.example.com:2087/scripts2/tweaksettings?find=chkservd
    
    Disable HTML notifications:
    https://host.example.com:2087/scripts2/tweaksettings?find=chkservd_plaintext_notify
    
    The system generated this notice on Sunday, October 2, 2016 at 11:48:43 PM UTC.
    
    “Service failures (ChkServd)” notifications are currently configured to have an importance of “High”. You can change the importance or disable this type of notification in WHM’s Contact Manager at: https://host.example.com:2087/scripts2/editcontact?event=chkservd
    
    Do not reply to this automated message.
    
     
    #1 HKjohn, Oct 2, 2016
    Last edited by a moderator: Oct 2, 2016
  2. Iron_Butterfly

    Joined:
    Sep 9, 2010
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Russia
    Try to restart Apache with

    # service httpd stop
    # service httpd start

    and then check status with

    # service httpd status
     
  3. HKjohn

    HKjohn Registered

    Joined:
    Oct 2, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Hong Kong
    cPanel Access Level:
    Root Administrator
    httpd (no pid file) not running

    [root@host ~]# service httpd start

    /etc/init.d/httpd: line 89: /usr/local/apache/bin/httpd: No such file or directory

    httpd could not be started

    [root@host ~]# service httpd status

    httpd is stopped

    [root@host ~]#
     
    #3 HKjohn, Oct 4, 2016
    Last edited by a moderator: Oct 4, 2016
  4. Iron_Butterfly

    Joined:
    Sep 9, 2010
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Russia
    Make sure that you have this symlink:

    # ls -la /usr/local/apache/bin/httpd
    lrwxrwxrwx. 1 root root 15 Sep 23 17:17 /usr/local/apache/bin/httpd -> /usr/sbin/httpd
     
  5. NixTree

    NixTree Well-Known Member

    Joined:
    Aug 19, 2010
    Messages:
    386
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Gods Own Country
    cPanel Access Level:
    Root Administrator
    Yes If it is missing better get a Easy Apache rebuild done and then check it.

    Was there any changes you were doing or done recently
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page