The system does not possess a valid license provisioning file

sufianway

Registered
Feb 7, 2019
3
0
1
Mumbai, India
cPanel Access Level
Root Administrator
Hi Everyone,

I'm new to cPanel world, and just 1 hour back I installed WHM cPanel.

While everything is automatic and awesome but I stuck at autoSSL feature.

I'm not able to add Comodo SSL certificate using cPanel for my domain.

Here is the log:

Code:
Log for the AutoSSL run for all users: Thursday, February 7, 2019 4:03:54 PM GMT+05-30 (cPanel (powered by Comodo))
4:03:54 PM AutoSSL’s configured provider is “cPanel (powered by Comodo)”.
This AutoSSL provider does not poll for certificate availability immediately after a certificate request submission. Instead, it submits certificate requests then periodically polls the cPanel Store for each requested certificate and installs it after a successful retrieval. The system will record all requests, retrievals, and installations for the current AutoSSL run in this log.
Checking websites for “example” …
4:03:54 PM Analyzing “example.com” …
4:03:54 PM ERROR TLS Status: Defective
ERROR Defect: NO_SSL: No SSL certificate is installed.
4:03:54 PM Performing DCV (Domain Control Validation) …
4:03:54 PM Local HTTP DCV OK: example.com
Local HTTP DCV OK: www.example.com (via example.com)
Local HTTP DCV OK: mail.example.com (via example.com)
Local HTTP DCV OK: cpanel.example.com (via example.com)
Local HTTP DCV OK: webdisk.example.com (via example.com)
Local HTTP DCV OK: webmail.example.com (via example.com)
4:03:54 PM Analyzing “example.com”’s DCV results …
4:03:54 PM AutoSSL will request a new certificate.
4:03:54 PM The system will attempt to renew the SSL certificate for the website (example.com: example.com www.example.com mail.example.com webmail.example.com cpanel.example.com webdisk.example.com).
No CAA record added because there is no CAA record from another provider in the DNS for example.com.
WARN (XID m6qfeb) The system does not possess a valid license provisioning file, so it could not connect to the cPanel Store. Run the “/usr/local/cpanel/cpkeyclt” command. at bin/autossl_check.pl line 368.
4:03:54 PM The system has completed the AutoSSL check for “example”.
The system has finished checking 1 user.
Please help me what I'm missing..
 
Last edited by a moderator:

sufianway

Registered
Feb 7, 2019
3
0
1
Mumbai, India
cPanel Access Level
Root Administrator
Hi,

After troubleshooting things from my side with my little knowledge, I came to know my server is not sending emails too while I am receiving it from other servers of mine too.

I mean they are kept in queue for long time, and when I process the queue to deliver it now. it says process completed.

But my emails are again kept in queue. is there a firewall problem for communicating outside world or any configuration issue from my side.

Please help me to know how do I examine its a configuration or firewall issue..

I also tried connecting to my server using ssh, and I found:
Code:
[[email protected] ~]# firewall-cmd --direct --get-all-rules
FirewallD is not running
[[email protected] ~]#
Note I have NetworkManager installed but disabled:

Code:
[[email protected] ~]# systemctl status NetworkManager
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:NetworkManager(8)
[[email protected] ~]#
At this point I'm not able to decide what to do. Please help.
 

sufianway

Registered
Feb 7, 2019
3
0
1
Mumbai, India
cPanel Access Level
Root Administrator
Hi,

Now I got it.

Its a firewall issue, my server is not able to communicate with outside world, while server is able to receive things from outside world like its receiving emails but not able to send, here is the process queue log.

Code:
LOG: MAIN
  cwd=/usr/local/cpanel/whostmgr/docroot 4 args: /usr/sbin/exim -v -M 1griKr-000Fpm-1x
delivering 1griKr-000Fpm-1x
LOG: MAIN
  Sender identification U=example D=exampleway.com [email protected]
Connecting to makeexample.com [x.x.x.x]:25 ... failed: Connection timed out (timeout=5m)
LOG: MAIN
  H=makeexample.com [x.x.x.x] Connection timed out
LOG: MAIN
  == [email protected] R=dkim_lookuphost T=dkim_remote_smtp defer (110): Connection timed out
LOG: MAIN
  cwd=/usr/local/cpanel/whostmgr/docroot 4 args: /usr/sbin/exim -v -M 1gri5d-000FVz-8f
delivering 1gri5d-000FVz-8f
LOG: MAIN
  Sender identification U=example D=example.com [email protected]
Connecting to example.com [x.x.x.x]:25 ... failed: Connection timed out (timeout=5m)
LOG: MAIN
  H=example.com [x.x.x.x] Connection timed out
LOG: MAIN
  == [email protected] R=dkim_lookuphost T=dkim_remote_smtp defer (110): Connection timed out
Now please anyone help me to solve this issue.

Thanks in advance
 
Last edited by a moderator:

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,298
1,279
313
Houston