The system experienced a problem while it fetched the list of available modules.

bdennie

Member
Jan 21, 2015
7
0
1
cPanel Access Level
Root Administrator
Last night our servers started upgrading from CPanel version 11.50 to 11.52. After this we are no longer able to see available perl modules. This did work before the upgrade. Here is the errors in the log

/usr/local/cpanel/logs/error_log

Code:
Warning: something's wrong at /usr/local/cpanel/Cpanel/JSON/FailOK.pm line 46.
Attempt to reload Cpanel/JSON.pm aborted.
Compilation failed in require at /usr/local/cpanel/Cpanel/CachedDataStore.pm line 21.
BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/CachedDataStore.pm line 21.
Compilation failed in require at /usr/local/cpanel/Cpanel/Crypt/GPG/VendorKeys.pm line 59.
Compilation failed in require at /usr/local/cpanel/Cpanel/Crypt/GPG/VendorKeys/Verify.pm line 39.
BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/Crypt/GPG/VendorKeys/Verify.pm line 39.
Compilation failed in require at /usr/local/cpanel/Cpanel/HttpRequest.pm line 13.
BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/HttpRequest.pm line 13.
Compilation failed in require at /usr/local/cpanel/Cpanel/cPCPAN/MirrorSearch.pm line 106.

Any ideas would be greatly appreciated. I have not found anything searching yet.
 
Last edited by a moderator:

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,575
48
308
cPanel Access Level
Root Administrator
If you would, please open a support ticket (cPanel Customer Portal) on this system. We've been getting intermittent reports about updates failing on JSON. We'd like to inspect a system where it's happening.

Thank you.

Edit: typo