The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED The system failed to set the permissions

Discussion in 'General Discussion' started by modabasi, Dec 28, 2016.

  1. modabasi

    modabasi Registered

    Joined:
    Sep 17, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    151
    • CENTOS 6.8 x86_64 standard
    • WHM 60.0 (build 28)
    Getting fatal errors for everything, can not even create accounts. Tried a forced update and reboot but did not solve the issue. For example when I try to "Delete a DNS Zone", I get the following error;

    Code:
    ----------------------------------------
    A fatal error or timeout occurred while processing this directive.
    (XID hpwsq2) The system failed to set the permissions on “GLOB(0x6d49238)” to “0640” (as EUID: 0, EGID: 0) because of the following error: Operation not permitted at /usr/local/cpanel/Cpanel/FileUtils/Access.pm line 62. Cpanel::FileUtils::Access::ensure_mode_and_owner(GLOB(0x6d49238), 416, 0, 12) called at /usr/local/cpanel/Cpanel/Transaction/File/Base.pm line 165 Cpanel::Transaction::File::Base::_set_permissions(GLOB(0x6d49238), 416, ARRAY(0x6d48cc8)) called at /usr/local/cpanel/Cpanel/Transaction/File/Base.pm line 113 Cpanel::Transaction::File::Base::new("Cpanel::Transaction::File::Raw", "path", "/etc/mailips", "permissions", 416, "ownership", ARRAY(0x6d48cc8)) called at /usr/local/cpanel/Cpanel/Userdomains/CORE.pm line 425 Cpanel::Userdomains::CORE::_create_transaction(Cpanel::Userdomains::CORE=HASH(0x6d00938), HASH(0x6d43cd8)) called at /usr/local/cpanel/Cpanel/Userdomains/CORE.pm line 120 Cpanel::Userdomains::CORE::update(Cpanel::Userdomains::CORE=HASH(0x6d00938), "force", 0) called at /usr/local/cpanel/Cpanel/Userdomains.pm line 25 Cpanel::Userdomains::updateuserdomains() called at /usr/local/cpanel/Cpanel/DnsUtils.pm line 175 Cpanel::DnsUtils::dokilldns("domains", ARRAY(0x5af1e60)) called at whostmgr/bin/whostmgr.pl line 2796 main::killdns() called at whostmgr/bin/whostmgr.pl line 696
    ----------------------------------------
    
    Any ideas? Help will be greatly appreciated.
     
    #1 modabasi, Dec 28, 2016
    Last edited by a moderator: Dec 28, 2016
  2. modabasi

    modabasi Registered

    Joined:
    Sep 17, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    151
    OK, I've resolved the problem myself... Let me explain what was wrong, in case someone else experiences the same weirdness in the future;

    I'm using a custom /etc/mailips configuration to use different mail IPs for each domain's outgoing email. The trick was documented here;

    How to Configure the Exim Outgoing IP Address - cPanel Knowledge Base - cPanel Documentation

    Anyways, as cPanel overrides manual changes to this file, it was locked with the command;

    chattr +iA mailips

    and it turns out this single locked file was causing all the trouble...

    Peace...

    Mustafa
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,618
    Likes Received:
    296
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Thanks for posting an update to your issue.
     
Loading...

Share This Page