The “/usr/local/cpanel/scripts/update-packages” command reported error number 1 when it ended

bloatedstoat

Well-Known Member
Jun 14, 2012
215
33
78
Victoria, Australia
cPanel Access Level
Root Administrator
Hello.

Our shiny new server is not happy.

/usr/local/cpanel/scripts/update-packages died during the update process of upcp with a whole slew of errors.

The output is herewith:



/usr/local/cpanel/scripts/update-packages

checkyum version 22.3 (excludes: bind-chroot)
This system is receiving updates from CloudLinux Network server.
Last metadata expiration check: 0:25:18 ago on Fri May 26 21:49:20 2023.
Error:

Problem 1: package libstdc++-devel-8.5.0-16.el8_7.alma.x86_64 requires libstdc++(x86-64) = 8.5.0-16.el8_7.alma, but none of the providers can be installed
- cannot install both libstdc++-8.5.0-18.el8.alma.x86_64 and libstdc++-8.5.0-16.el8_7.alma.x86_64
- cannot install the best update candidate for package libstdc++-devel-8.5.0-16.el8_7.alma.x86_64
- cannot install the best update candidate for package libstdc++-8.5.0-16.el8_7.alma.x86_64

Problem 2: package libtiff-devel-4.0.9-26.el8_7.x86_64 requires libtiff(x86-64) = 4.0.9-26.el8_7, but none of the providers can be installed
- cannot install both libtiff-4.0.9-27.el8.x86_64 and libtiff-4.0.9-26.el8_7.x86_64
- cannot install the best update candidate for package libtiff-devel-4.0.9-26.el8_7.x86_64
- cannot install the best update candidate for package libtiff-4.0.9-26.el8_7.x86_64

Problem 3: package libxml2-devel-2.9.7-15.el8_7.1.x86_64 requires libxml2(x86-64) = 2.9.7-15.el8_7.1, but none of the providers can be installed
- cannot install both libxml2-2.9.7-16.el8.x86_64 and libxml2-2.9.7-15.el8_7.1.x86_64
- cannot install the best update candidate for package libxml2-devel-2.9.7-15.el8_7.1.x86_64
- cannot install the best update candidate for package libxml2-2.9.7-15.el8_7.1.x86_64

Problem 4: libgomp-8.5.0-16.el8_7.alma.i686 has inferior architecture
- package gcc-8.5.0-16.el8_7.alma.x86_64 requires libgomp = 8.5.0-16.el8_7.alma, but none of the providers can be installed
- cannot install both libgomp-8.5.0-18.el8.alma.x86_64 and libgomp-8.5.0-16.el8_7.alma.x86_64
- cannot install the best update candidate for package libgomp-8.5.0-16.el8_7.alma.x86_64
- cannot install the best update candidate for package gcc-8.5.0-16.el8_7.alma.x86_64

Problem 5: package ghostscript-9.27-4.el8.x86_64 requires libgs(x86-64) = 9.27-4.el8, but none of the providers can be installed
- cannot install both libgs-9.27-6.el8.x86_64 and libgs-9.27-4.el8.x86_64
- cannot install the best update candidate for package libgs-9.27-4.el8.x86_64
- cannot install the best update candidate for package ghostscript-9.27-4.el8.x86_64

Problem 6: package net-snmp-agent-libs-1:5.8-25.el8_7.1.x86_64 requires net-snmp-libs(x86-64) = 1:5.8-25.el8_7.1, but none of the providers can be installed
- cannot install both net-snmp-libs-1:5.8-27.el8.x86_64 and net-snmp-libs-1:5.8-25.el8_7.1.x86_64
- cannot install the best update candidate for package net-snmp-libs-1:5.8-25.el8_7.1.x86_64
- cannot install the best update candidate for package net-snmp-agent-libs-1:5.8-25.el8_7.1.x86_64

Problem 7: package perl-4:5.26.3-421.el8.x86_64 requires perl-interpreter(x86-64) = 4:5.26.3-421.el8, but none of the providers can be installed
- cannot install both perl-interpreter-4:5.26.3-422.el8.0.1.x86_64 and perl-interpreter-4:5.26.3-421.el8.x86_64
- cannot install the best update candidate for package perl-interpreter-4:5.26.3-421.el8.x86_64
- cannot install the best update candidate for package perl-4:5.26.3-421.el8.x86_64

Problem 8: package perl-devel-4:5.26.3-421.el8.x86_64 requires perl-libs(x86-64) = 4:5.26.3-421.el8, but none of the providers can be installed
- cannot install both perl-libs-4:5.26.3-422.el8.0.1.x86_64 and perl-libs-4:5.26.3-421.el8.x86_64
- cannot install the best update candidate for package perl-libs-4:5.26.3-421.el8.x86_64
- cannot install the best update candidate for package perl-devel-4:5.26.3-421.el8.x86_64

Problem 9: perl-libs-4:5.26.3-421.el8.i686 has inferior architecture
- package perl-utils-5.26.3-421.el8.noarch requires perl-libs = 4:5.26.3-421.el8, but none of the providers can be installed
- cannot install both perl-libs-4:5.26.3-422.el8.0.1.x86_64 and perl-libs-4:5.26.3-421.el8.x86_64
- package perl-Errno-1.28-422.el8.0.1.x86_64 requires perl-libs(x86-64) = 4:5.26.3-422.el8.0.1, but none of the providers can be installed
- cannot install the best update candidate for package perl-utils-5.26.3-421.el8.noarch
- cannot install the best update candidate for package perl-Errno-1.28-421.el8.x86_64

Problem 10: package bind-lite-devel-32:9.11.36-5.el8_7.2.x86_64 requires libxml2-devel(x86-64), but none of the providers can be installed
- package libxml2-devel-2.9.7-15.el8_7.1.x86_64 requires libxml2(x86-64) = 2.9.7-15.el8_7.1, but none of the providers can be installed
- package libxml2-devel-2.9.7-15.el8.x86_64 requires libxml2(x86-64) = 2.9.7-15.el8, but none of the providers can be installed
- cannot install both libxml2-2.9.7-16.el8.x86_64 and libxml2-2.9.7-15.el8_7.1.x86_64
- cannot install both libxml2-2.9.7-16.el8.x86_64 and libxml2-2.9.7-15.el8.x86_64
- package python3-libxml2-2.9.7-16.el8.x86_64 requires libxml2(x86-64) = 2.9.7-16.el8, but none of the providers can be installed
- cannot install the best update candidate for package python3-libxml2-2.9.7-15.el8_7.1.x86_64
- cannot install the best update candidate for package bind-lite-devel-32:9.11.36-5.el8_7.2.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
(XID zgnbm3) “/usr/bin/yum” reported error code “1” when it ended:



CloudLinux v8.7.0 standard
cPanel Version 110.0.6


Any advice on this one please, seems to be quite a few issues.

Thank you.
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
15,220
2,420
363
cPanel Access Level
Root Administrator
Hey there! That's certainly not ideal - if there are no accounts on the server yet, I'd be tempted to just reinstall the operating system, as RPM issues from the start are never a good sign.

I wouldn't expect the main repository to be unreachable or else *nothing* related to Yum would work properly, so maybe you could try the classic combo of these commands to see if that resolves the issue:

Code:
yum clean all
yum makecache
yum update
If not, you may need to reach out to your hosting provider to have them check the OS itself, as those are all system packages and not related to cPanel tools.
 

bloatedstoat

Well-Known Member
Jun 14, 2012
215
33
78
Victoria, Australia
cPanel Access Level
Root Administrator
That figures, I've been migrating accounts slowly and dealing with issues as they pop up. I'm 75% in now and hoped to complete this evening.

I can see from the reading I've done on here and elsewhere that this is not an error I'm experiencing alone.



In each and every case I've read there's either no resolution, suggestions to run commands I'm uncomfortable running or "wait until it goes away".

That said, there's a general consensus in many threads that this is a repository issue.

I'll try our hosting provider for suggestions.
 

bloatedstoat

Well-Known Member
Jun 14, 2012
215
33
78
Victoria, Australia
cPanel Access Level
Root Administrator
Hello,

This matter was resolved by CloudLinux Engineer Misael who sorted it out within half an hour of opening the ticket with them.
For the purposes of helping others who may find themselves with the same or a similar issue the problem in my case was a rogue repository.

"Thank you for your time. The issue was with this automatically added repository:
repo.cloudlinux.com_cloudlinux_8_BaseOS_x86_64_os_
It was causing the conflicts due to having outdated packages (because this is the BaseOS repo, which is for unregistered users).
I removed the repo file, and "yum" can now complete the update: "


If the issue presents itself again I'll update this thread but for now the issue is resolved.
 
Last edited: