SOLVED There are no domains which have * to display. AWStats, Webalizer, Visitors, etc

reberiii

Registered
Sep 24, 2018
2
0
1
Lancaster, PA, USA
cPanel Access Level
Root Administrator
Hello! Sorry if this is in the wrong location, but it seems to be where similar threads are located that I've found on Google.

I've created my 34th account on my server with cPanel, which is only important as this is the only account that encounters this error. Visitors, Webalizer Stats, and others give message

"There are no domains which * to display." Or something very similar. And the big one is Awstats. I have a timely PDF which is being served for a promotion, and I would love to see how many times the file has been pulled.

I've done some research, and come across the plethora of articles that suggest I

Code:
ls -lah /usr/local/cpanel/base/awstats.pl

ls -lah /usr/local/cpanel/3rdparty/bin/awstats.pl
But those return 755 permissions and a symlink which matches the symlinks for the other accounts on my server. Regardless, seeing as how the issue isn't just limited to Awstats and goes into Visitors, Webalizer, etc. Additionally, my bandwidth is reporting no data, and my Raw Access logs are empty.

I'm guessing I have something awry in my "Tweak Settings", but everything I've known to check so far looks good.

Your help is greatly appreciated!

-r3
 

reginaladonues

Registered
Oct 1, 2013
2
0
1
cPanel Access Level
Root Administrator
Resolved issue, in my case it was problems in the apache logs, the httpd.conf file had to be rebuilt and then apache restarted using the following commands:
# mv -v /usr/local/apache/conf/httpd.conf /usr/local/apache/conf/httpd.conf.BAK
# / scripts / rebuildhttpdconf
# / scripts / restartsrv_httpd