The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Thunderbird CalDav not connecting

Discussion in 'E-mail Discussions' started by tudorh, Apr 15, 2016.

Tags:
  1. tudorh

    tudorh Member

    Joined:
    Dec 9, 2004
    Messages:
    16
    Likes Received:
    1
    Trophy Points:
    3
    On CPanel/WHM WHM 54.0 (build 7).

    I'm trying to connect Thunderbird/Lightning (Version 38.6.0) extension to Caldav. I've followed the instructions here inserting the "Non-Autodiscovery webmail user" URL.

    It asked for the password, and then added the calendar, but it's marked as "Momentarily Unavailable" (if Offline mode is disabled) or greyed out (if Offline mode is enabled) and attempts to enable it automatically switch it off again.
    I looked in /usr/local/cpanel/logs/cpdavd_error_log. At first, cpHulkd complained with:
    Code:
    Internal Error: cphulkd request failed to process me@mydomain.com from 11.22.33.44 for service dav.
    Starting PID 2124: cpdavd - accepting connections on 2077, 2078, 2079, and 2080
    Internal Error: cphulkd request failed to process me@mydomain.com from 11.22.33.44 for service dav.
    Internal Error: cphulkd request failed to process me@mydomain.com from 11.22.33.44 for service dav.
    Starting PID 27094: cpdavd - accepting connections on 2077, 2078, 2079, and 2080
    Starting PID 22935: cpdavd - accepting connections on 2077, 2078, 2079, and 2080
    Brute force checking was skipped because cphulkd failed to process “me@mydomain.com” from “11.22.33.44” for the “dav” service.
    
    So I flushed CPHulk. Then restarted cpulkd and cpdavd. And the errors went away, but the connection still fails.

    What else can I try to get this connection working?
     
    #1 tudorh, Apr 15, 2016
    Last edited by a moderator: Apr 19, 2016
  2. tudorh

    tudorh Member

    Joined:
    Dec 9, 2004
    Messages:
    16
    Likes Received:
    1
    Trophy Points:
    3
    If I attempt to connect to it using the command-line WebDAV client `cadaver`, I get:

    Code:
    $ cadaver https://mydomain.com:2080/rpc/principals/me@mydomain.com
    Authentication required for Restricted Area on server `mydomain.com':
    Username: me@mydomain.com
    Password:
    Could not access /rpc/principals/me@mydomain.com/ (not WebDAV-enabled?):
    207 Multi-Status
    Connection to `mydomain.com' closed.
    dav:!>
    
     
  3. tudorh

    tudorh Member

    Joined:
    Dec 9, 2004
    Messages:
    16
    Likes Received:
    1
    Trophy Points:
    3
    I noticed what I think is a typo in the documentation. The URL contains 'pricipals' instead of 'principals'. This is the outcome from the documentation:
    Code:
    $ cadaver https://mydomain.com:2080/rpc/pricipals/me@mydomain.com
    Authentication required for Restricted Area on server `mydomain.com':
    Username: me@mydomain.com
    Password:
    Could not open collection:
    404 Not Found
    dav:/rpc/pricipals/me@mydomain.com/?
    Neither work, obviously, but I don't know if a 404 is better or worse than a 207 at this point.
     
  4. tudorh

    tudorh Member

    Joined:
    Dec 9, 2004
    Messages:
    16
    Likes Received:
    1
    Trophy Points:
    3
    Upgraded to WHM 54.0 build 21 but the outcomes are still identical to above. Does this work in 56.0?
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Are you able to reproduce the authentication issue when accessing the URL from your web browser? EX:

    Code:
    https://127.0.0.1:2080/rpc/principals/$cpanelusername
    Thank you.
     
  6. tudorh

    tudorh Member

    Joined:
    Dec 9, 2004
    Messages:
    16
    Likes Received:
    1
    Trophy Points:
    3
    No. I am unable to reproduce it using that URL. That is to say, I get the following.

    (I presume you didn't really mean 127.0.0.1, tho, because there's no server running on my desktop.)
     

    Attached Files:

  7. tudorh

    tudorh Member

    Joined:
    Dec 9, 2004
    Messages:
    16
    Likes Received:
    1
    Trophy Points:
    3
    So if https is working and caldav isn't, what does that tell us?
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
  9. tudorh

    tudorh Member

    Joined:
    Dec 9, 2004
    Messages:
    16
    Likes Received:
    1
    Trophy Points:
    3
    Done. Support request ID is 7537419
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    To update, per the support ticket, the advice was to update to cPanel version 56 due to the implementation of this case:

    Code:
    Fixed case CPANEL-2013: Add /rpc to calendar and contacts paths.
    Could you verify if that helped?

    Thank you.
     
  11. tudorh

    tudorh Member

    Joined:
    Dec 9, 2004
    Messages:
    16
    Likes Received:
    1
    Trophy Points:
    3
    Hi Michael, Unfortunately not in my case, it would seem. I have upgraded to 56 built 14 and I'm working with Aaron to see if we can get to the bottom of the issue.

    At the very least, I believe that the documentation is wrong. It lists:

    https://example.com:2080/rpc/pricipals/user@example.com

    as the URL to use, however, this URL gives me 404 errors consistently.

    I have found that adding an 'n' so the URL becomes:

    https://example.com:2080/rpc/principals/user@example.com

    illicits a more DAV-like response. However, it still isn't enough to make CalDAV clients happy. :-(

    I'll put up a proper answer here if I manage to get it working properly.
     
  12. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Thank you for this report. I've opened a case with our documentation team to have this corrected, and I'll update this thread once that happens.

    Thank you.
     
  13. Akuukis

    Akuukis Registered

    Joined:
    Nov 8, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Latvia
    cPanel Access Level:
    Website Owner
    Hello,

    Last few days I struggled to make cPanel direct calendar urls to work with Thunderbird. In the end, the problem was the wrong link under "Direct URLs for Calendars and Contacts" where
    Code:
    https://<domain>:<port>/rpc/calendars/<email>/calendar:iBqY_w2g0ENxFcDSzGSKNrT
    the ":" character had to be replaced with "~" character. I came up to this by manually inspecting links in
    Code:
    https://<domain>:<port>/rpc/principals/<email>.
    So, to make multiple cPanel calendars to work with Thunderbird, here are instructions that worked for me:
    1. Have an email user in cPanel
    2. In Horde, create all calendars and tasklists you need (these are seperated in cPanel in contrast to ownCube where they are bundled).
    3. In browser, enter in your Alternate Server URL and look up the correct direct links to your calendars and task lists (that should be prefixed with your
    Code:
    https://<domain>:<port>/
    )
    4. In Thunderbird, add each calendar separately
    5. In Thunderbird, add each tasklist just like calendar separately. The trick is that calendars don't support tasks, but tasklists do.
    6. If you have to add calendars/tasklists that are owned by different users, then either
    6.1. (recommended) log into Horde, share the calendar or tasklist and repeat steps 3-5.
    6.2. (desperate) Search and learn about config option "calendar.network.multirealm" in Thunderbird.
     
    #14 Akuukis, Nov 8, 2016
    Last edited by a moderator: Nov 8, 2016
Loading...

Share This Page