The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Time keeps changing to the wrong time

Discussion in 'General Discussion' started by zigzam, Oct 27, 2006.

  1. zigzam

    zigzam Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    The server time keeps changing to 2 hours ahead of the correct time nightly. When I click sync time with time server it works fine until the next day. This is a big issue with emails being sent, because they show up with incorrect times and all the crons are off.

    Any idea whats wrong? I want it to use Central Time
     
  2. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    You are only setting the software clock, not the hardware (BIOS) clock. You can sync them with hwclock and either:

    --hctosys set the system time from the hardware clock
    --systohc set the hardware clock to the current system time
     
  3. zigzam

    zigzam Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    Thanks, how do I run those?
     
  4. zigzam

    zigzam Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    Figured it out /sbin/hwclock --systohc
     
  5. zigzam

    zigzam Well-Known Member

    Joined:
    May 9, 2005
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    I tried that, but the time changed again. Ideas?
     
Loading...

Share This Page