The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Time to connect to FTP really slow for ftp useraccounts

Discussion in 'General Discussion' started by noimad1, May 13, 2003.

  1. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    I have one customer that has multiple FTP accounts set up on his system that he gives access to a few of his users to upload/download MP3's.

    He claims that all of his users have a common problem - it takes forever to connect via FTP. He said once they are connected, the upload time/speed is normal, but it just takes forever to connect to the server.

    He claims it took one user (56k) up to 5 minutes just to establish the connection through FTP.

    Anyone else had this?
     
  2. howard

    howard Well-Known Member

    Joined:
    Apr 20, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    If you are using proftpd, then maybe it is waiting for the the ident lookups / reverse dns checks (see http://www.proftpd.org/docs/directives/linked/config_ref_UseReverseDNS.html
    and http://www.proftpd.org/docs/directives/linked/config_ref_IdentLookups.html) time out thus causing delays for new connections

    You can see weather it is inded these options by disabling by editing /etc/proftpd.conf and putting somewhere near the top

    IdentLookups off
    UseReverseDNS off

    then restarting proftpd from either inside whm or by doing service proftpd stop / service proftpd start
     
  3. Dattatec

    Dattatec Active Member
    PartnerNOC

    Joined:
    Mar 12, 2003
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Argentina
    Change to PureFTPD.

    Im using PureFTPd and works more fast, much fast.
     
  4. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    That is what we are currently using...

    I think it is very strange. This is the only customer so far that has complained about it...

    Thanks,
    Damion
     
  5. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    We are seeing this with some pure-ftpd users aslo. The one that boggles me is our server that only hosts our site. It takes about 15 seconds to authenticate with passive mode enabled. Any tweaks out there for pure-ftpd?
     
Loading...

Share This Page