The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Timeout on copy acco

Discussion in 'General Discussion' started by indiboi, Dec 21, 2002.

  1. indiboi

    indiboi Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    I've been attempting to copy over accounts from one server to another for most of lastnight and today; however, they always seem to timeout during the &Creating Archive& portion of the script and restart the process over again. Sometimes it actually finishes, but this always leaves the user's directory on the 'new' server empty... usually it just dies with the unable to package account error.

    Both servers are running R-100, have ssh and ftp enabled. This seems to happen with very small accounts (~6/30MB) and larger accounts (200-300MB).

    Is there a commandline version of the copyaccount somewhere on the servers?
     
  2. Creazioni1

    Creazioni1 Well-Known Member

    Joined:
    Dec 28, 2003
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    I worked on several servers
    8 exim >>> 8 cpanel= trasnfer perfect

    I've only an EXIM server with a big problem...i can't move account

    ==========
    Creating Scripts on Remote Server...
    Copying copy script...
    pkgacct-enXim 100% 11KB 26.4MB/s 00:00

    Done
    Attemping to package account...
    enXim DNS is XXXXX.xx
    enXim Copying Mail files....Done
    enXim Copying proftpd file....Done
    enXim Copying www logs....Done
    enXim Grabbing mysql dbs...Done
    enXim Copying homedir.............
    Done
    ...............
    Timeout ...
    Attemping to package account...
    enXim DNS is XXXXX.xx
    enXim Copying Mail files....Done
    enXim Copying proftpd file....Done
    enXim Copying www logs....Done
    enXim Grabbing mysql dbs...Done
    enXim Copying homedir.............
    Done
    ...............
    Timeout ...
    Attemping to package account...
    enXim DNS is XXXXX.xx
    enXim Copying Mail files....Done
    enXim Copying proftpd file....Done
    enXim Copying www logs....Done
    enXim Grabbing mysql dbs...Done
    enXim Copying homedir.............
    Done
    ...............
    Timeout ...

    Unable to package account


    ==========

    I try in all way
    into exim, after my try i look much process like


    ==========
    00 [cp <defunct>]
    root 29644 0.0 0.4 1972 728 ? S 12:02 0:00 bash -c echo sshcmdstart;/scripts/pkgacct ilvendolo {} --split;echo sshcmddone
    root 29645 0.0 0.7 3052 1192 ? S 12:02 0:00 /usr/bin/perl /scripts/pkgacct ilvendolo {} --split
    root 29651 0.0 0.1 1400 212 ? T 12:02 0:00 rm -rf /home/cpmove-ilvendolo.tar.gz
    root 29653 0.0 0.0 0 0 ? Z 12:02 0:00 [rm <defunct>]
    root 29659 0.0 0.1 1408 212 ? T 12:02 0:00 cp -a /var/lib/mysql/ilvendolo_it /home/cpmove-ilvendolo/mysql/ilvendolo_ilvendolo_it
    root 29660 0.0 0.0 0 0 ? Z 12:02 0:00 [cp <defunct>]
    root 29663 0.0 0.1 1412 212 ? T 12:02 0:00 cp -a /var/lib/mysql/ilvendolo_it /home/cpmove-ilvendolo/mysql/ilvendolo_it
    root 29666 0.0 0.1 1412 212 ? T 12:02 0:00 cp -a /home/virtual/site7/fst/home/ilvendolo /home/cpmove-ilvendolo/homedir
    root 29667 0.0 0.0 0 0 ? Z 12:02 0:00 [cp <defunct>]
    root 29668 0.0 0.0 0 0 ? Z 12:02 0:00 [cp <defunct>]
    root 29670 0.0 0.1 1404 212 ? T 12:02 0:00 r

    this process don't kill alone....i must kill 1to1


    could be a proble of old server?
    few ram? few CPU?
     
Loading...

Share This Page