The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Timeout on createacct API Call and DNS

Discussion in 'cPanel Developers' started by Gonzalo De Spirito, Apr 18, 2016.

  1. Gonzalo De Spirito

    Gonzalo De Spirito Registered

    Joined:
    Apr 18, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Santiago, Chile
    cPanel Access Level:
    Root Administrator
    Hi!

    As a web developer, i created a custom administration panel for my clients, as they can for example, create new hosting accounts in some "region".

    At the moment i have just 2 servers, one in USA and the other one in Chile.
    When the users create an account in the USA server, everything works, and the process take about 8 seconds. (I internally call the createacct API call)

    But now, i enabled this Chilean Server with Centos 7.2, and at the beginning everything just works, but now the process is throwing a Connection timeout everytime. I dont even change nothing in the WHM panel (i think). I extended the timeout time to 60 seconds and nothing... still fails. Any other API call works just great, and even the createacct works if the domain already exists or somehting (it throws the errore sucessfully), but when the data passed are valid, it doesnt return nothing and throws the timeout, but the domain is sucessfully created (at least, it appers in the WHM panel)

    Now, after repeating the task, sometime it completes the task but takes more than 60 seconds.
    And when deleting the accounts through the WHM, its seems that "delete DNS records" take a lot of time.

    can it be a problem with DNS? Maybe my DNS cluster is misconfigured

    I Have three server: 2 Web servers and 1 DNS ONLY Server.
    So i decided the DNS only and the USA one will be my main DNS servers.

    Chile: DNS Clusted enables -> Write only to both servers
    USA Web: DNS cluster enabled with write only to DNS-ONLY
    Usa DNS Only: DNS Cluster enabled but no servers configured.


    Please help!
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,760
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Have you tried using a utility such as traceroute to test the connection between the two servers and verify if there is high latency or response times?

    Thank you.
     
Loading...

Share This Page