The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tip: When upgrading phpsuexec & Apache 1.3.x cPanel 9.4

Discussion in 'EasyApache' started by hicom, Jul 31, 2004.

  1. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    272
    Likes Received:
    0
    Trophy Points:
    16
    If you upgrade Apache & cPanel to secure the latest vulnerabilities, you might be surprised to find out that some PHP scripts will stop working.

    To fix this problem, you need to check your httpd.conf file (/usr/local/apache/conf/)

    Make sure the following lines are not omitted out (no # in front of them):

    LoadModule php4_module libexec/libphp4.so

    AddModule mod_php4.c


    This should be obvious for ppl using PHP extensively, but just in case someone out there needed help with it. Keep that in mind. Also, if you path the phpsuexec vulnerability, you better off do a /scripts/upcp --force
     
  2. bradandersen

    bradandersen Active Member

    Joined:
    Oct 6, 2003
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Thank You!

    Thank you very much for the update. Not everyone is as all knowing as your typical sysadmin.

    Thanks for the pointer,
    Brad
     
  3. chadi

    chadi BANNED

    Joined:
    Apr 20, 2004
    Messages:
    415
    Likes Received:
    0
    Trophy Points:
    0
    So basically if I enable phpsuxec support in whm this should prevent anyone using php scripts from having trouble sending out emails NOT as "nobody"?
     
  4. Faldran

    Faldran Well-Known Member

    Joined:
    May 28, 2002
    Messages:
    136
    Likes Received:
    0
    Trophy Points:
    16
    Actaully if you are setting up php_suexec, these lines should be with # in front of them, for it to work correctly.

    #LoadModule php4_module libexec/libphp4.so

    #AddModule mod_php4.c


    If you have problems with sites, most likely it is items in .htaccess causing the problems.
    Most common are php_value type items set within .htaccess, that should be set in php.ini if you are using php_suexec.
    Search these forums for many answers to that.
    BTW.. all php files should be chmod 644 and not 755 like many will try and tell you.
     
Loading...

Share This Page