tips upgrading buildapache.sea

wozza

Member
Feb 14, 2002
8
0
301
Hi
Just wanted to share some things that I found when upgrading with the latest buildapache.sea (php4.2.0) on redhat7.2
issues I had were :
mysql was automatically &builtin& mode (cause it couldnt find mysql) .. alot slower than external mode
Globals were tuened off (breaking lots of websites)
no postgresql support in list of modules
..............................................

I found that downloading (wget) , and running the script was easy..
chmod 0755 buildapache.sea
./buildapache.sea
bla bla .........
the neat interface which allows you to choose more modules was great - BUT I couldnt find pgsql (postgresql) module to enable.. which was a bugger..
anyway , I carried on , and all went fine.
I restarted apache ... checked mysql db web sites, and no go!!
I found that Globals is turned off by default in php4.2.0
so alot of websites were broken , including XMB forums etc

had to work fast as we had 600 users on there...
no php.ini in /usr/local/lib .. so what I did was..
in the directory that you run the ./buildapache.sea .. it creates a source directory called buildapache/
I went in there. and into php-4.2.0/
had a look at php.ini-dist found the line which said (line 312)

register_globals = Off
to
register_globals = On
then saved it as php.ini
cp php.ini /usr/local/lib/

restarted apache - great all XMB forums working, and shopping carts etc ... (cant really turn that off with out giving all users notice to recode their php programs etc)

I still didnt have postgres support in php (phppgadmin wouldnt work for example)
so I manually compiled php.
like this...
go into the /buildapache/php-4.2.0/
and this is the configure script I used..
(using: =/usr to fix mysql , and prefix=/usr/local (default for sea install) and with-pgsql support )

./configure --prefix=/usr/local --with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --with-curl --with-swf=/usr/local/flash --enable-ftp --with-gd=../gd-1.8.4 --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-imap=../imap-2001.BETA.SNAP-0105220031 --with-mcrypt --with-ming=../ming-0.1.1 --enable-magic-quotes --with-mysql=/usr --with-pgsql=/usr --with-pear --enable-xslt --with-xslt-sablot --enable-safe-mode --enable-track-vars --with-ttf --enable-versioning --with-zlib
[enter].....
make clean [enter]
......
make [enter] ......... ................................
make install ......
restart apache ... checked everything .... great all working :)

hope that might help someone :)

warren
:)
Nucleus Limited
 

wozza

Member
Feb 14, 2002
8
0
301
mcrypt issue with latest apachebuild

Hi all
today I upgrade with apachebuild.sea
it wouldnt compile on our redhat 7.2 with php -with-mcrypt and also had to remove ming
I just edited apachebuild/buildscript
and removed those from the php configure lines
(4) of them

and then it compiled ok
hope that a future build enables the above , we will see

cheers

wozza
 

haze

Well-Known Member
Dec 21, 2001
1,550
3
318
We didn't have any issues compiling with ming and mcrypt on our 7.2 machines at all. Perhaps this is something not related to buildapache?
 

Vital

Active Member
Nov 17, 2001
37
0
306
[quote:ecfe6954e7][i:ecfe6954e7]Originally posted by iminteractive[/i:ecfe6954e7]
We didn't have any issues compiling with ming and mcrypt on our 7.2 machines at all. Perhaps this is something not related to buildapache?[/quote:ecfe6954e7]

Wasn't able to figure this either.. 2 boxes refuse to compile with ming and mcrypt, saying &could not determine mcrypt version&... This is not up to buildapache, but rather to some difference between RH releases. Anyone has the idea, what causes this? Bugging autoconf?
 
O

ozzi4648

Guest
[quote:f6424850b8][i:f6424850b8]Originally posted by wozza[/i:f6424850b8]

Hi
Just wanted to share some things that I found when upgrading with the latest buildapache.sea (php4.2.0) on redhat7.2
issues I had were :
mysql was automatically &builtin& mode (cause it couldnt find mysql) .. alot slower than external mode
Globals were tuened off (breaking lots of websites)
no postgresql support in list of modules
..............................................

I found that downloading (wget) , and running the script was easy..
chmod 0755 buildapache.sea
./buildapache.sea
bla bla .........
the neat interface which allows you to choose more modules was great - BUT I couldnt find pgsql (postgresql) module to enable.. which was a bugger..
anyway , I carried on , and all went fine.
I restarted apache ... checked mysql db web sites, and no go!!
I found that Globals is turned off by default in php4.2.0
so alot of websites were broken , including XMB forums etc

had to work fast as we had 600 users on there...
no php.ini in /usr/local/lib .. so what I did was..
in the directory that you run the ./buildapache.sea .. it creates a source directory called buildapache/
I went in there. and into php-4.2.0/
had a look at php.ini-dist found the line which said (line 312)

register_globals = Off
to
register_globals = On
then saved it as php.ini
cp php.ini /usr/local/lib/

restarted apache - great all XMB forums working, and shopping carts etc ... (cant really turn that off with out giving all users notice to recode their php programs etc)

I still didnt have postgres support in php (phppgadmin wouldnt work for example)
so I manually compiled php.
like this...
go into the /buildapache/php-4.2.0/
and this is the configure script I used..
(using: =/usr to fix mysql , and prefix=/usr/local (default for sea install) and with-pgsql support )

./configure --prefix=/usr/local --with-apxs=/usr/local/apache/bin/apxs --with-xml --enable-bcmath --enable-calendar --with-curl --with-swf=/usr/local/flash --enable-ftp --with-gd=../gd-1.8.4 --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-imap=../imap-2001.BETA.SNAP-0105220031 --with-mcrypt --with-ming=../ming-0.1.1 --enable-magic-quotes --with-mysql=/usr --with-pgsql=/usr --with-pear --enable-xslt --with-xslt-sablot --enable-safe-mode --enable-track-vars --with-ttf --enable-versioning --with-zlib
[enter].....
make clean [enter]
......
make [enter] ......... ................................
make install ......
restart apache ... checked everything .... great all working :)

hope that might help someone :)

warren
:)
Nucleus Limited

[/quote:f6424850b8]

Hey thank you very much. After installing 1.3.7 we lost mcrypt ability. Phpmanager now works again.
;)