yaashul

Member
May 3, 2017
7
0
1
India
cPanel Access Level
Root Administrator
Hi,

Since Aug 15,2018 IETF has announced TLS 1.3 is finally published. Its been about 9 months now but cPanel/Whm has not supported TLS 1.3 yet or I am missing something that It is announced but I am not able to configure it yet.

Please let us know if there is a deadline when It is going to be supported. I am getting 65% user from the browser which support TLS 1.3 0RTT now but cPanel has yet to support it @least on my server.
 

LucasRolff

Well-Known Member
Community Guide Contributor
May 27, 2013
142
94
78
cPanel Access Level
Root Administrator
Even if you get TLSv1.3 enabled, doesn't mean you automatically support 0RTT :)

Now, cPanel currently ships Apache with OpenSSL 1.0.2r, 1.1.1 is required for TLS 1.3 - thus there's no 0RTT support in Apache at this point (as far as I know).

If you want TLSv1.3 with 0RTT, QUIC etc - then LiteSpeed Web Server might be a good choice :)
 

cPanelLauren

Product Owner II
Staff member
Nov 14, 2017
13,274
1,291
313
Houston
The suggestion by @LucasRolff is probably the most recommended at this time. We do have a feature request open for this as well Add Support for TLS 1.3 which I'd encourage you to vote on.

I know there is movement on this internally as well but there is no deadline/eta for this at this time.