Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

TLS handshake failure - v70.0.42

Discussion in 'E-mail Discussion' started by web-project, May 18, 2018.

  1. web-project

    web-project Well-Known Member

    Joined:
    Nov 23, 2007
    Messages:
    62
    Likes Received:
    5
    Trophy Points:
    58
    After upgrade to the latest version of cPanel I have noticed that mail server accept only hostname as POP/IMAP/SMTP address, but cpanel is clearly shows different mail client manual settings.

    It seems to me the domain is redirecting to hostname and mail client check the hostname SSL certificate instead of domain name certificate, the SSL certificates are enabled for SNI SSL domain and hostname.

    from mail client I do get the following error log:
    as for /var/log/maillog
    could you point to right direction how to fix the bug?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #1 web-project, May 18, 2018
    Last edited: May 18, 2018
  2. web-project

    web-project Well-Known Member

    Joined:
    Nov 23, 2007
    Messages:
    62
    Likes Received:
    5
    Trophy Points:
    58
    the Exim option for OpenSSL is set to


    and SSL/TLS Cipher Suite List:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cPanelLauren

    cPanelLauren Forums Analyst II
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    3,042
    Likes Received:
    212
    Trophy Points:
    173
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    This seems to indicate that there was a certificate mismatch, is the sending domain (i.e. the domain getting this error) a domain owned by you or present on your server?

    If so does the domain have an SSL?
    If it does have an SSL is the PTR record set to the hostname or the domain name?
    Have you modified /etc/mailhelo?

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice