TLS1.2/TLS1.1 Support on older computers like ipad, osx <10.6, Outlook

nosajix

Well-Known Member
Jul 30, 2005
63
2
158
I am having a hard time understanding this. Obviously telling my clients they need to upgrade their less than 5 year old hardware to use their domain based email hosted with cpanel is CRAZY - I mean especially when they still can load in any gmail, outlook.com, yahoo, apple, Veriizon, ect ect email into the programs without any issue. I mean, they obviously arent using TLS1 are they? What gives? What advice can you give me? I know I can simply enable TLS1 and change the cipher list but does that not severely reduce security? Not to mention PCI Compliance - what do I do?

-Jason