The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomcat Integration

Discussion in 'General Discussion' started by GodCandy, Mar 19, 2005.

  1. GodCandy

    GodCandy Registered

    Joined:
    Dec 15, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I have installed Tomcat to our cpanel server. Everything works great using domain.com:8080 except I would like integration with apache. Therefore I setup one domain with jsp support in the whm... It creates a WEB-INF folder under that domain. So I moved all of the jar and class files int that WEB-INF folder just as they were in the origional webapp folder for tomcat. I then moved the html form the webapp directory in tomcat to my domains public_html folder... at first I was getting an error with a vector that was in some java script... that was easly correctable... my newest error is probably just as simple but it is just not comming to me right now.

    The error is as follows:
    org.apache.jasper.JasperException: /pages/links.jsp(9,0) The value for the useBean class attribute Business.linksInfo is invalid.

    There is a lot more stuff to it but that is what is important...

    Essentially this jsp page uses a bean to call a method to get some data to populate a menu. Probably not the best way to do it I know but thats how it is done... I wrote the bean to handle the connections back to the database and the sorting of the results. It is in the WEB-INF/classes/Business directory...

    I think it has somehing to do with the path and how it is written in the code... if so iw ould be more than happy to update the code...

    Any help is appreciated...

    Thanks,
    Godcandy


    Skitzo Hosting Solutions
     
  2. naveen3

    naveen3 Active Member

    Joined:
    Jan 28, 2005
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    6
    can u help me

    hello,
    one of my client want to run his web application on my server.
    i installed tomcat and enable servlets on that site from WHM.
    i put a jsp test file, and it was running very well.
    then, i told him to put classes and jar in web-inf and html, jsp files in public_html.
    he did it
    but now we are getting internal server 500 error on all jsp files.

    any idea ?

    -Naveen
     
  3. openXS

    openXS Member

    Joined:
    Jul 5, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    /urs/bin/
    Same issues for me with tomcat, ever found a solution to it? :(
     
  4. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    just a curious question.. is the web-inf in CAPS ? i mean WEB-INF ?
     
  5. openXS

    openXS Member

    Joined:
    Jul 5, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    /urs/bin/
    Yes, WEB-INF.
     
  6. sibu

    sibu Member

    Joined:
    Jul 14, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
Loading...

Share This Page