The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomcat is not running after installed

Discussion in 'General Discussion' started by Charles.Gao, Jan 28, 2008.

  1. Charles.Gao

    Charles.Gao Registered

    Joined:
    Jan 28, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have installed tomcat in my WHM (WHM -> cPanel -> Manage plugins -> click on Addon Modules tomcat ).

    After installed, It doesn't running.

    I try to start it with "starttomcat", but it also faild to start.
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Are there any errors output when issuing the starttomcat command? How about in /usr/local/jakarta/tomcat/logs/catalina.out (or catalina.err)?
     
  3. Charles.Gao

    Charles.Gao Registered

    Joined:
    Jan 28, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello Kenneth,

    There are not errors output when issuing the starttomcat command. And there are any output in /usr/local/jakarta/tomcat/logs/catalina.out.

    When I was executing the /usr/local/jakarta/tomcat/bin/setclasspath.sh, the outputs are:

    The BASEDIR environment variable is not defined
    This environment variable is needed to run this program

    And executing the /usr/local/jakarta/tomcat/bin/startup.sh, the outputs are:

    Using CATALINA_BASE: /usr/local/jakarta/tomcat
    Using CATALINA_HOME: /usr/local/jakarta/tomcat
    Using CATALINA_TMPDIR: /usr/local/jakarta/tomcat/temp
    Using JRE_HOME: /usr/local/jdk

    the outputs in /usr/local/jakarta/tomcat/logs/catalina.out are:

    an 29, 2008 10:04:47 AM org.apache.coyote.http11.Http11Protocol init
    INFO: Initializing Coyote HTTP/1.1 on http-8043
    Jan 29, 2008 10:04:47 AM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 1782 ms
    Jan 29, 2008 10:04:47 AM org.apache.catalina.core.StandardService start
    INFO: Starting service Catalina
    Jan 29, 2008 10:04:47 AM org.apache.catalina.core.StandardEngine start
    INFO: Starting Servlet Engine: Apache Tomcat/5.5.9
    Jan 29, 2008 10:04:47 AM org.apache.catalina.core.StandardHost start
    INFO: XML validation disabled
     
Loading...

Share This Page