The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomcat Module, dead after upgrade

Discussion in 'cPanel Developers' started by mcoms, Mar 26, 2005.

  1. mcoms

    mcoms Member

    Joined:
    Jun 15, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I have just upgraded cPanel & WHM and to the latest release version and with it came an update for the tomcat module.

    It was previously working, now tomcat won't start. Has anyone experienced anything similar?

    /usr/local/jakarta/jakarta-tomcat-5.5.7/logs/catalina.err tells me:
    Code:
    jsvc.exec error: Service exit with a return value of 1
    jsvc.exec debug: user changed to 'tomcat'
    jsvc.exec debug: Using default JVM in /usr/local/jdk/jre/lib/i386/client/libjvm.so
    jsvc.exec debug: Attemtping to load library /usr/local/jdk/jre/lib/i386/client/libjvm.so
    jsvc.exec debug: JVM library /usr/local/jdk/jre/lib/i386/client/libjvm.so loaded
    jsvc.exec debug: JVM library entry point found (0x401FA174)
    jsvc.exec debug: +-- DUMPING JAVA VM CREATION ARGUMENTS -----------------
    jsvc.exec debug: | Version:                       10002
    jsvc.exec debug: | Ignore Unrecognized Arguments: False
    jsvc.exec debug: | Extra options:                 3
    jsvc.exec debug: |   "-Djava.class.path=./bootstrap.jar" (0x00000000)
    jsvc.exec debug: |   "-Djava.endorsed.dirs=../common/endorsed" (0x00000000)
    jsvc.exec debug: |   "-verbose" (0x00000000)
    jsvc.exec debug: +-------------------------------------------------------
    jsvc.exec debug: Java VM created successfully
    jsvc.exec debug: Class org/apache/commons/daemon/support/DaemonLoader found
    jsvc.exec debug: Native methods registered
    jsvc.exec debug: Checking daemon
    jsvc.exec debug: Daemon checked successfully
    Mar 26, 2005 11:14:56 PM org.apache.catalina.startup.Bootstrap initClassLoaders
    SEVERE: Class loader creation threw exception
    java.lang.NoClassDefFoundError: javax/management/MBeanServerFactory
            at org.apache.catalina.startup.Bootstrap.createClassLoader(Bootstrap.java:161)
            at org.apache.catalina.startup.Bootstrap.initClassLoaders(Bootstrap.java:97)
            at org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:189)
            at org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:257)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:324)
            at org.apache.commons.daemon.support.DaemonLoader.load(DaemonLoader.java:201)
    jsvc.exec error: Service exit with a return value of 1
    Also, can someone point me in the direction of a quick how-to for allowing my users to install their own servlets?

    Many thanks,
    - Nick
     
  2. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    To fix that error, a simple reinstall should work. I also recommend NOT allowing tomcat to autoupdate.
     
  3. mcoms

    mcoms Member

    Joined:
    Jun 15, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Sorted

    Cheers a re-install did it, didn't realise you could just dump compiled classes into public_html/WEB_INF without restarting anything!
     
Loading...

Share This Page