The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tomcat - workers2.proerties other than servlets...

Discussion in 'General Discussion' started by denisdekat09, Apr 27, 2004.

  1. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    Hello,

    I have one client who wants to run his webapps folder a tad different. All works well for the most part.

    However, when I set the workers2.properties to have this:

    [uri:www.domain_name.com/albums/*]
    worker=ajp13:localhost:8009

    [uri:domain_name.com/albums/*]
    worker=ajp13:localhost:8009

    They did not work.

    :confused:

    I got this to work:
    [uri:/albums/*]
    worker=ajp13:localhost:8009

    but it makes all web sites turn to JSP if they go to a directory album on their site.

    :confused: :confused:

    I tried this:
    [uri:/albums/*.jsp]
    worker=ajp13:localhost:8009


    Works, but as long as the files are all .jsp :rolleyes:


    So, why did this not work?


    [uri:www.domain_name.com/albums/*]
    worker=ajp13:localhost:8009

    [uri:domain_name.com/albums/*]
    worker=ajp13:localhost:8009

    This would make it all work just fine for me :) Also, it seems to be the documented way to do this. Should I have included a port number?

    Thanks for any ideas !!


    :cool:
     
  2. denisdekat09

    denisdekat09 Well-Known Member

    Joined:
    Mar 2, 2002
    Messages:
    265
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    San Francisco
    Also, does any one know how to find out what version mod_jk2 I have on my server? it came with the 4.1 install.

    My logs show this:

    Apr 27, 2004 1:29:06 PM org.apache.commons.digester.Digester fatalError
    SEVERE: Parse Fatal Error at line 307 column 39: The string "--" is not permitted within comments.
    org.xml.sax.SAXParseException: The string "--" is not permitted within comments.


    Though I fail to find these in my web.xml and server.xml

    I see the lies 307, but no such characters. Any ideas on this also?

    :D
     
Loading...

Share This Page