The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Too many connections from your ip

Discussion in 'General Discussion' started by noimad1, Oct 28, 2004.

  1. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    I have a customer that has 50 e-mail accounts. However, they keep getting this error:

    The server responded with an error. Account: 'email@theirdomain.com', Server: 'mail.theirdomain.com', Protocol: POP3, Server
    Response: '-ERR Too many connections from your ip
    address (reached max connections)', Port: 110,
    Secure(SSL): No, Server Error: 0x800CCC90, Error
    Number: 0x800CCC90

    I'm sure this is a configurable setting. Does anyone know where I can change the max. connections by IP address?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Cannot remember which one, but either:

    WHM > Tweak Settings > Attempt to prevent pop3 connection floods

    or

    WHM > Tweak Settings > The number of times users are allowed to check their mail using pop3 per hour

    Probably the latter.
     
  3. apodigm

    apodigm Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    ... I have tried tweaking these settings, but I'm not sure I understand how they work.

    Are they still basing the number of connections "per user" based on the incoming IP address?

    The reason I ask, is this scenario... a customer has 10 or 15 users that are all locally connected to the Internet using the same DSL (and yes... let's make it a dynamic IP address). They all have thier mail client set to check every 5 minutes. So.. in this WHM settings, I would think that "per user" I could set a limit of around 15 (twelve regular checks through the hour, plus some wiggle room). But that is not the case. It appears that I have to set this limit to 225 (15 users * 15 connections calculated in previous sentence). ... Now obviously 225 seems like a high limit for the case where it was just one computer checking (ie... pop3 connection DoS attack).

    ... I'm wondering if they did have a static IP address, perhaps I could allow that IP address to connect with a higher limit (or no limit). Is that possible?

    ... and is there anyway to examine how the WHM settings are applied to the server POP3 server?


    thanks,
    Apodigm
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    IIRC, No to all of those :)

    It uses the IP address
    You cannot configure it on a per IP address basis
    The POP3 server cppop is closed source
     
  5. apodigm

    apodigm Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    ...

    well... I can confirm that it is based on IP address, after my testing. I'm not sure that the "per hour" really is an hourly value.

    I remember something about /etc/relayhosts that gets updated when someone does a POP3 connection, and that this file would allow people to send mail within a preset time period without re-authenticating. I was hoping that there was a similar file that would provide access to POP3 without having the same server-wide limitation on POP3 connections.

    .... so ... If I disable the "Attempt to prevent POP3 connection floods" in the WHM settings... I still get the "too many connections from this IP". It seems like that setting doesn't work, or there is something else at play here.


    Any advice would be helpful. I'm just worried about the case where we land a company of 50+ employees, but doesn't have an inhouse mail server. I'd like to sell them a managed server, but I'm not sure how to prevent them from having end user problems when they share the same IP address.
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Unfortunately, the thread I investigated all of this seems to have gone from the forum :( It was several months back.

    Thinking more on it, I believe the flood checking is per IP address, however the pops per hour are account based. This is definitely per hour as the files are stored in:

    /usr/local/cpanel/etc/cppop/auth/username\@domain.com

    And contains epoch timestamps for each POP which is cleared down on an hourly rotation.
     
  7. apodigm

    apodigm Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    ahh... ok... this make sense.

    I do see that it has the timestamps, and that the timestamps are "expired" after they are an hour old... it looks like it just keeps a running list of timestamps. ... but it looks like after I have 21 entries in there, I get the "too many connections error"

    ... strange... because I have the pop3 connection limitation set to 100 per hour (per user).

    now, I do have 15 accounts that are configured for the send and recieve. But that still doesn't add up.

    And... just for fun... I tried clearing out the auth file for one of the accounts to see if it would let me connect on that account, and I still got the "too many connections" error.

    Is it possible that APF or IPTables might be causing this?
     
  8. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    cppop may cache them as well as write them to file (incase it is restarted). Did you try restarting cppop and see if you could then POP after deleting the file.
     
Loading...

Share This Page