Track delivery - connection problem

Endurand

Member
Aug 28, 2021
9
0
1
Србија
cPanel Access Level
Root Administrator
Hi,
I send emails and go to track delivery to check delivery status. Some of them get successfully sent, but some get "Connection refused" status.
After 15 or so minutes, I guess the server tries to send them again and they get sent successfully.
Also, I get the "Connection timed out", and "Retry time not reached for any host for..." status.
What could be causing this? I worry because for now, I have a 10 email list. I'm planning to have 1000+ emails, but if I have problems with sending 10, what could happen with 1000+..
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,494
1,009
313
cPanel Access Level
Root Administrator
Hey there! It really depends, and I'm not sure there's going to be a good way to answer it.

The most likely explanation I can think of is that the remote server has some type of greylisting set up similar to cPanel's here: Greylisting | cPanel & WHM Documentation

This tool temporarily rejects a message, causing the mailserver to attempt a retry. If it does retry, that is an indication it is a valid mailserver and not some automated tool sending spam, and then the message is accepted. There isn't really a way to verify this, although checking the logs directly in the /var/log/exim_mainlog file may give you more details about the specific delivery attempt.
 

Endurand

Member
Aug 28, 2021
9
0
1
Србија
cPanel Access Level
Root Administrator
Hey there! It really depends, and I'm not sure there's going to be a good way to answer it.

The most likely explanation I can think of is that the remote server has some type of greylisting set up similar to cPanel's here: Greylisting | cPanel & WHM Documentation

This tool temporarily rejects a message, causing the mailserver to attempt a retry. If it does retry, that is an indication it is a valid mailserver and not some automated tool sending spam, and then the message is accepted. There isn't really a way to verify this, although checking the logs directly in the /var/log/exim_mainlog file may give you more details about the specific delivery attempt.
Thank you for answering. I checked greylisting and it is disabled so I don't think that it is making a problem here.
My log is full of this:
[Wed Sep 01 06:10:55.543251 2021] [core:crit] [pid 12447] (13)Permission denied: [client 185.189.182.234:57856] AH00529: /home/endurand/public_html/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that '/home/endurand/public_html/' is executable

I checked and .hracess is readable, public_html is executable???
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,494
1,009
313
cPanel Access Level
Root Administrator
I actually meant greylisting on the recipient's end, so that isn't something you'd be able to test.

The .htaccess file on the server wouldn't be related to the email issues, but public_html should be 755 and the .htaccess file should be 644.
 

Endurand

Member
Aug 28, 2021
9
0
1
Србија
cPanel Access Level
Root Administrator
I actually meant greylisting on the recipient's end, so that isn't something you'd be able to test.

The .htaccess file on the server wouldn't be related to the email issues, but public_html should be 755 and the .htaccess file should be 644.
I'm sorry, I don't think that is the problem.
I tested this; I sent the emails to myself "@gmail.com", I know for a fact that greylisting is not turned on by my side, but still, sometimes server gets the connection refused for the first few attempts..
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,494
1,009
313
cPanel Access Level
Root Administrator
Interesting - if it's "connection refused" that almost sounds like there is a network error on the server.

Can you try changing your /etc/resolve.conf file to the following to see if that changes the behavior? You can just comment out any existing lines in that file and use these for testing:

Code:
nameserver 8.8.8.8
nameserver 8.8.4.4
 

Endurand

Member
Aug 28, 2021
9
0
1
Србија
cPanel Access Level
Root Administrator
Interesting - if it's "connection refused" that almost sounds like there is a network error on the server.

Can you try changing your /etc/resolve.conf file to the following to see if that changes the behavior? You can just comment out any existing lines in that file and use these for testing:

Code:
nameserver 8.8.8.8
nameserver 8.8.4.4
Thank you so much for taking the time to help me..
I changed nameservers to what you said and still, I get the connection refused status, and again after few attempts, the email gets accepted. I send to the same email addresses every day and every day different email address creates problems.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,494
1,009
313
cPanel Access Level
Root Administrator
I can't think of a logical reason that behavior would happen. At this point it would be best to submit a ticket to our support team so we can check the system directly and see if we are able to get more information. If you are able to submit a ticket, please post the number here so I can follow along.
 

Endurand

Member
Aug 28, 2021
9
0
1
Србија
cPanel Access Level
Root Administrator
I can't think of a logical reason that behavior would happen. At this point it would be best to submit a ticket to our support team so we can check the system directly and see if we are able to get more information. If you are able to submit a ticket, please post the number here so I can follow along.
What is this for? (check attachment) Could this make me deliverability problems?
 

Attachments

Endurand

Member
Aug 28, 2021
9
0
1
Србија
cPanel Access Level
Root Administrator
That could definitely be an issue - do you know the difference in the way those messages were sent? Was one possibly sent using an automated form?
I send my emails via mailwizz. This is the same email, only the first time it got "Connection Refused", then the server automatically tries to send that email again after 10 or so minutes then it gets accepted.. I don't know why the first time it was -system-, and the second try it was -remote-. It is literally the same email.
 

cPJustinD

Administrator
Staff member
Jan 12, 2021
286
51
103
Houston
cPanel Access Level
Root Administrator
Hi there! This certainly sounds strange, and without the ability to replicate on our end, it would be difficult for us to determine what exactly is occurirg.

I think cPRex has the right idea here -it may be best to open a support ticket so that our analysts can review the issue more thoroughly and determine what exactly is occurring. You can submit a support request using the "Submit a ticket" link in my signature below.

Please be sure to link this thread when opening the ticket and provide the ticket number here so that we can track the issue appropriately. If possible, please post the resolution on this thread as it may help other community members with similar issues.
 

Endurand

Member
Aug 28, 2021
9
0
1
Србија
cPanel Access Level
Root Administrator
Hi there! This certainly sounds strange, and without the ability to replicate on our end, it would be difficult for us to determine what exactly is occurirg.

I think cPRex has the right idea here -it may be best to open a support ticket so that our analysts can review the issue more thoroughly and determine what exactly is occurring. You can submit a support request using the "Submit a ticket" link in my signature below.

Please be sure to link this thread when opening the ticket and provide the ticket number here so that we can track the issue appropriately. If possible, please post the resolution on this thread as it may help other community members with similar issues.
Ticked ID #94367488