Transaction Check Error: package openssl already installed


Well-Known Member
May 20, 2003
cPanel Access Level
Root Administrator
I ran into one small problem updating to CloudLinux I thought I might post here in case someone else runs into the same issue and looks for a way past it.

From Easy Apache build Error Summary:


!! ensure() rc was '0', exit status was '256', perl '$?' was '0', exit sig '0', core dump: '0', shell '$?' was '1' !!

!! Simulating failed Cpanel::SysPkgs as per 'simulate-failed-syspkgs' flag !!
!! Could not ensure pkglist 'automake19, gettext, libpng-devel, readline-devel, openssl, libpng-dev, zlib-devel, autoconf261, libidn-devel, gmake, libidn, libXpm, openssl-devel, automake, coreutils, patch, libstdc++-dev, libltdl3-devel, libltdl, libopenssl0.9.7-static-devel, readline-dev, libtool-ltdl-devel, libXpm-devel, sed, libXpm-dev, lsof, krb5-dev, flex, glibc-dev, expat-dev, krb5-devel, xorg-x11-devel, libtool-ltdl, libssl-dev, bzip2-devel, pam-devel, libopenssl0-devel, zlib1-devel, liblve-devel, expat-devel, libopenssl0-dev, glibc-devel, expat, gcc-c++, libstdc++, zlib, bison, libstdc++-devel, libjpeg-devel, libtool-libltdl-devel, libtool, openssl-dev, libopenssl0, bzip2-libs, libz-devel, libjpeg-dev, pam-dev, fileutils, libltdl-devel, libopenssl0.9.7-devel, e2fsprogs-devel, make, libX11-devel, libstdc++-devel.x86_64, gd, cpp, xorg-x11-dev, gcc, ssl-dev, lex, autoconf' !!
!! The server's system package manager, 'YUM', failed. !!
This is the command that failed:

yum --exclude=kernel* -y install automake19 gettext libpng-devel readline-devel openssl libpng-dev zlib-devel autoconf261 libidn-devel gmake libidn libXpm openssl-devel automake coreutils patch libstdc++-dev libltdl3-devel libltdl libopenssl0.9.7-static-devel readline-dev libtool-ltdl-devel libXpm-devel sed libXpm-dev lsof krb5-dev flex glibc-dev expat-dev krb5-devel xorg-x11-devel libtool-ltdl libssl-dev bzip2-devel pam-devel libopenssl0-devel zlib1-devel liblve-devel expat-devel libopenssl0-dev glibc-devel expat gcc-c++ libstdc++ zlib bison libstdc++-devel libjpeg-devel libtool-libltdl-devel libtool openssl-dev libopenssl0 bzip2-libs libz-devel libjpeg-dev pam-dev fileutils libltdl-devel libopenssl0.9.7-devel e2fsprogs-devel make libX11-devel libstdc++-devel.x86_64 gd cpp xorg-x11-dev gcc ssl-dev lex autoconf

Since EasyApache was unable to resolve it automatically you should:
1) Manually run the failed YUM command (shown above) via SSH
2) See if your particular error is addressed at EaError < AllDocumentation < TWiki
3) Resolve the YUM problem manually
4) Re-run EasyApache
!! Please visit EaError < AllDocumentation < TWiki for help with this error. !!
Earlier in the build log I see this:

Dependencies Resolved

 Package    Arch Version                         Repository                Size
 openssl    i686 0.9.8e-12.el5_5.7               cloudlinux-base          1.4 M

I couldn't find anything on openssl issues at that link mentioned in the error, but I did find this post from last year on the forums related to openssl issues on CentOS:

Re: OpenSSL (Yum) update error as seen in nightly cron email

Which suggested running these two commands to sort out the CentOS repository mixup:

rpm -e --justdb --nodeps openssl.i386
yum install openssl

This solved the issue I was having, Easy Apache was then able to finished as expected.