SOLVED Transaction Check Error

Dent

Member
Dec 16, 2015
10
1
3
Earth
cPanel Access Level
Root Administrator
Hello,

CENTOS 6.9 x86_64 virtuozzo – server cPanel & WHM 64.0 (build 29)

When I try to do yum update (to upgrade the kernel) I get this error message.

Transaction Check Error:
file /usr/lib64/libmp3lame.so.0.0.0 from install of lame-libs-3.99.5-8.el6.x86_64 conflicts with file from package libmp3lame0-3.99.3-23.el6.x86_64

I have tried to find a solution using google but I could not find anything specific enough. Does anyone know how I could solve this?
 

Jcats

Well-Known Member
PartnerNOC
May 25, 2011
806
156
168
New Jersey
cPanel Access Level
DataCenter Provider
Can you provide the output of:

Code:
yum list installed |grep lame
Code:
yum repolist
 

Dent

Member
Dec 16, 2015
10
1
3
Earth
cPanel Access Level
Root Administrator
Can you provide the output of:

Code:
yum list installed |grep lame



Code:
yum repolist

[email protected] [~]# yum list installed |grep lame
lame-devel.x86_64 3.99.3-23.el6 @Subhosting
libmp3lame0.x86_64 3.99.3-23.el6 @Subhosting
twolame.x86_64 0.3.12-2.el6 @Subhosting
[email protected] [~]#




[email protected] [~]# yum repolist
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* cpanel-addons-production-feed: 67.222.0.10
* base: mirror.jax.hugeserver.com
* epel: mirror.oss.ou.edu
* extras: repos-tx.psychz.net
* updates: mirror.tzulo.com
repo id repo name status
cpanel-addons-production-feed cPanel Addons Production Feed 20
base CentOS-6 - Base 6,338+368
cpanel-plugins cPanel Plugins project (CentOS 6) 77
epel Extra Packages for Enterprise Linux 6 - x8 10,446+1,917
extras CentOS-6 - Extras 45
updates CentOS-6 - Updates 392+3
vz-base vz-base 3
vz-updates vz-updates 8
repolist: 17,329
[email protected] [~]#
 

Jcats

Well-Known Member
PartnerNOC
May 25, 2011
806
156
168
New Jersey
cPanel Access Level
DataCenter Provider
I would remove 3.99.3 packages since 3.99.5 is the latest, run yum update, then reinstall those packages using the latest release.

Code:
yum remove lame-devel.x86_64 3.99.3-23.el6 libmp3lame0.x86_64 3.99.3-23.el6
yum -y update
you can build from source or find a repo that contains the latest like:

lame-3.99.5-1.el6.x86_64.rpm CentOS 6 Download
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,227
463
Hello,

These are third-party RPMs and thus unsupported, but the previous post should help. Let us know if you have additional questions.

Thank you.
 

Dent

Member
Dec 16, 2015
10
1
3
Earth
cPanel Access Level
Root Administrator
I would remove 3.99.3 packages since 3.99.5 is the latest, run yum update, then reinstall those packages using the latest release.

Code:
yum remove lame-devel.x86_64 3.99.3-23.el6 libmp3lame0.x86_64 3.99.3-23.el6
yum -y update
you can build from source or find a repo that contains the latest like:

lame-3.99.5-1.el6.x86_64.rpm CentOS 6 Download



Dependency Removed:
ffmpeg.x86_64 0:0.7.11-52.el6 ffmpeg-devel.x86_64 0:0.7.11-52.el6
libavcodec52.x86_64 0:0.7.11-52.el6 libavdevice52.x86_64 0:0.7.11-52.el6
libavfilter1.x86_64 0:0.7.11-52.el6 libavformat52.x86_64 0:0.7.11-52.el6
mplayer.x86_64 4:1.0-90_snap20120311.el6

Complete!
[email protected] [~]# yum -y update
Loaded plugins: fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
* cpanel-addons-production-feed: 67.222.0.10
* base: mirrors.gigenet.com
* epel: pubmirror2.math.uh.edu
* extras: repos-tx.psychz.net
* updates: mirror.tzulo.com
Resolving Dependencies
--> Running transaction check
---> Package kernel.x86_64 0:2.6.32-696.3.2.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================
Package Arch Version Repository Size
=====================================================================================
Installing:
kernel x86_64 2.6.32-696.3.2.el6 updates 32 M

Transaction Summary
=====================================================================================
Install 1 Package(s)

Total size: 32 M
Installed size: 131 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : kernel-2.6.32-696.3.2.el6.x86_64 1/1
Verifying : kernel-2.6.32-696.3.2.el6.x86_64 1/1

Installed:
kernel.x86_64 0:2.6.32-696.3.2.el6

Complete!




Thank you so much Jcats :)
 
  • Like
Reactions: cPanelMichael

Dent

Member
Dec 16, 2015
10
1
3
Earth
cPanel Access Level
Root Administrator
you can build from source or find a repo that contains the latest like:

lame-3.99.5-1.el6.x86_64.rpm CentOS 6 Download

Unfortunately some websites stopped working after a reboot so I take it they need the dependencies.

It looks like I will have to install them again.


Edit: Actually a restart of Apache solved that issue. All websites look up and running now. So I might not have to reinstall it again after all.